DONATE


OSPF CCNA CCNP LAB

 

Open Shortest Path First (OSPF) 

Open shortest path first is an open standard routing protocol implemented by a wide variety of network vendors, including Cisco. And it’s that open standard characteristic that’s the key to OSPF flexibility and popularity. OSPF uses the Dijkstra algorithm to initially construct a shortest path tree and follows that by populating the routing table with the resulting best route. Its quick convergence is another reason it’s a favorite. Another two great advantages OSPF offers are that it supports multiple, equal-cost routes to the same destination and it also supports both IPv4 and IPv6 routed protocols read more...

OSPF STUBS

OSPF stubs allow the OSPF routers in an area to use default routes for forwarding packets to Area Border Routers (ABRs), rather than more specific routes. OSPF stubs reduce memory consumption and CPU processing time on the routers inside the area because the routers in that area can have fewer LSAs in their LSDBs Read more...


EIGRP is sometimes referred to as a hybrid routing protocol or an advanced distance vector protocol because is has characteristics of both distance-vector some link-state protocols. For example, EIGRP doesn't send link-state packets like OSPF does. instead, it traditional distance-vector updates that include information about networks plus the cost of reaching them from the perspective of the advertising router Read more...


Route redistribution 
 when we take a route from one routing protocol and inject that route or distribute it into another routing protocol.  Routers by default only advertise and share routing information with other routers running the same protocol and in a same AS. If you have 2 routers and one runs EIGRP and the other runs OSPF and you want them to know about each other’s routes, by default, router do not share routes information because they are not running the same protocol. Here we need redistribution Read more...

An Open Shortest Path First (OSPF) autonomous system all areas must be physically connected to the backbone area (Area 0). In some cases, if this is not possible, we can use a virtual link to connect to the backbone (Area 0) through a non-backbone area. We can also use the virtual links to connect two parts of a partitioned backbone (Area 0) through a non-backbone area. The area through which we configure the virtual link, known as a transit area, must have full routing information. Remember the transit area cannot be a stub area Read more...















Goal:-

  • Configure the topology as per the diagram
  • Configure the IP addresses as per the topology
  • Configure loopback interface as per the topology 
  • Configure OSPF & advertise directly connected interfaces 
  • Configure OSPF areas on routers as per the topology 
  • Configure EIGRP 100 on router 12
  • Configure EIGRP 300 on router 13
  • Configure redistribution between EIGRP 100, EIGRP 300 and OSPF
  • Configure OSPF Virtual-link 
  • Configure redistribution between OSPF 111 & OSPF 222 on router 7
  • Configure passive interfaces 
  • Configure OSPF stub area 4 
  • make sure all the routing table is correct 




OSPF-111-R1-(config)#interface serial 5/0
OSPF-111-R1-(config-if)#ip address 12.1.1.1 255.0.0.0
OSPF-111-R1-(config-if)#no shutdown
OSPF-111-R1-(config-if)#exit

OSPF-111-R1-(config)#interface serial 5/1
OSPF-111-R1-(config-if)#ip address 111.1.1.1 255.0.0.0
OSPF-111-R1-(config-if)#no shutdown
OSPF-111-R1-(config-if)#exit

OSPF-111-R1-(config)#interface serial 5/2
OSPF-111-R1-(config-if)#ip address 31.1.1.2 255.0.0.0
OSPF-111-R1-(config-if)#no shutdown
OSPF-111-R1-(config-if)#exit

OSPF-111-R1-(config)#interface fastethernet 0/0
OSPF-111-R1-(config-if)#ip address 10.1.1.1 255.0.0.0
OSPF-111-R1-(config-if)#no shutdown
OSPF-111-R1-(config-if)#exit

OSPF-111-R1-(config)#interface fastethernet 2/0
OSPF-111-R1-(config-if)#ip address 20.1.1.1 255.0.0.0
OSPF-111-R1-(config-if)#no shutdown
OSPF-111-R1-(config-if)#exit

OSPF-111-R1-(config)#interface fastethernet 3/0
OSPF-111-R1-(config-if)#ip address 30.1.1.1 255.0.0.0
OSPF-111-R1-(config-if)#no shutdown
OSPF-111-R1-(config-if)#exit
 




 OSPF-111-R2-(config)#interface serial 5/0
OSPF-111-R2-(config-if)#ip address 1.1.1.2 255.0.0.0
OSPF-111-R2-(config-if)#no shutdown
OSPF-111-R2-(config-if)#exit
 
OSPF-111-R2-(config)#interface serial 5/1
OSPF-111-R2-(config-if)#ip address 23.1.1.1 255.0.0.0
OSPF-111-R2-(config-if)#no shutdown
OSPF-111-R2-(config-if)#exit
 
OSPF-111-R2-(config)#interface serial 5/2
OSPF-111-R2-(config-if)#ip address 21.1.1.1 255.0.0.0
OSPF-111-R2-(config-if)#no shutdown
OSPF-111-R2-(config-if)#exit

OSPF-111-R2-#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Serial5/0                  1.1.1.2         YES manual up                    up
Serial5/1                  23.1.1.1        YES manual up                    up
Serial5/2                  21.1.1.1        YES manual up                    up

 
OSPF-111-R3-(config)#interface serial 5/0
OSPF-111-R3-(config-if)#ip address 39.1.1.1 255.0.0.0
OSPF-111-R3-(config-if)#no shutdown
OSPF-111-R3-(config-if)#exit
 
OSPF-111-R3-(config)#interface serial 5/1
OSPF-111-R3-(config-if)#ip address 23.1.1.2 255.0.0.0
OSPF-111-R3-(config-if)#exit

OSPF-111-R3-(config-if)#interface serial 5/1
OSPF-111-R3-(config-if)#no shutdown
OSPF-111-R3-(config-if)#exit

OSPF-111-R3-(config)#interface serial 5/2
OSPF-111-R3-(config-if)#ip address 31.1.1.1 255.0.0.0
OSPF-111-R3-(config-if)#no shutdown
OSPF-111-R3-(config-if)#exit

OSPF-111-R3-(config)#interface serial 5/3
OSPF-111-R3-(config-if)#ip address 34.1.1.1 255.0.0.0
OSPF-111-R3-(config-if)#no shutdown
OSPF-111-R3-(config-if)#exit

OSPF-111-R3-(config)#interface fastethernet 0/0
OSPF-111-R3-(config-if)#ip address 30.1.1.1 255.0.0.0
OSPF-111-R3-(config-if)#no shutdown
OSPF-111-R3-(config-if)#exit

OSPF-111-R3-(config)#interface fastethernet 2/0
OSPF-111-R3-(config-if)#ip address 32.1.1.1 255.0.0.0
OSPF-111-R3-(config-if)#no shutdown
OSPF-111-R3-(config-if)#exit

OSPF-111-R3-(config)#interface fastethernet 3/0
OSPF-111-R3-(config-if)#ip address 33.1.1.1 255.0.0.0
OSPF-111-R3-(config-if)#no shutdown
OSPF-111-R3-(config-if)#exit
 







 
OSPF-R4-(config)#interface serial 5/3
OSPF-R4-(config-if)#ip address 34.1.1.2 255.0.0.0
OSPF-R4-(config-if)#no shutdown
OSPF-R4-(config-if)#exit
 
OSPF-R4-(config)#interface serial 6/0
OSPF-R4-(config-if)#ip address 45.1.1.1 255.0.0.0
OSPF-R4-(config-if)#no shutdown
OSPF-R4-(config-if)#exit

OSPF-R4-(config)#interface serial 6/1
OSPF-R4-(config-if)#ip address 46.1.1.1 255.0.0.0
OSPF-R4-(config-if)#no shutdown
OSPF-R4-(config-if)#exit

OSPF-R4-(config)#interface loopback 1
OSPF-R4-(config-if)#ip address 14.1.1.1 255.255.255.0
OSPF-R4-(config-if)#no shutdown
OSPF-R4-(config-if)#exit

OSPF-R4-(config)#interface loopback 2
OSPF-R4-(config-if)#ip address 14.1.2.1 255.255.255.0
OSPF-R4-(config-if)#no shutdown
OSPF-R4-(config-if)#exit

OSPF-R4-(config)#interface loopback 3
OSPF-R4-(config-if)#ip address 14.1.3.1 255.255.255.0
OSPF-R4-(config-if)#no shutdown
OSPF-R4-(config-if)#exit

OSPF-R4-(config)#interface loopback 4
OSPF-R4-(config-if)#ip address 14.1.4.1 255.255.255.0
OSPF-R4-(config-if)#no shutdown
OSPF-R4-(config-if)#exit

OSPF-R4-(config)#interface fastethernet 0/0
OSPF-R4-(config-if)#ip address 40.1.1.1 255.0.0.0
OSPF-R4-(config-if)#no shutdown
OSPF-R4-(config-if)#no keepalive
OSPF-R4-(config-if)#exit
 

 
OSPF-R5-(config)#interface serial 6/0
OSPF-R5-(config-if)#ip address 45.1.1.2 255.0.0.0
OSPF-R5-(config-if)#no shutdown
OSPF-R5-(config-if)#exit

OSPF-R5-(config)#interface serial 6/2
OSPF-R5-(config-if)#ip address 56.1.1.1 255.0.0.0
OSPF-R5-(config-if)#no shutdown
OSPF-R5-(config-if)#exit

OSPF-R5-(config)#interface serial 6/3
OSPF-R5-(config-if)#ip address 58.1.1.1 255.0.0.0
OSPF-R5-(config-if)#no shutdown

OSPF-R5-(config)#interface fastethernet 0/0
OSPF-R5-(config-if)#ip address 50.1.1.1 255.0.0.0
OSPF-R5-(config-if)#no keepalive
OSPF-R5-(config-if)#no shutdown
OSPF-R5-(config-if)#exit

OSPF-R5-(config)#interface loopback 1
OSPF-R5-(config-if)#ip address 15.1.1.1 255.255.255.0
OSPF-R5-(config-if)#no shutdown
OSPF-R5-(config-if)#exit

OSPF-R5-(config)#interface loopback 2
OSPF-R5-(config-if)#ip address 15.1.2.1 255.255.255.0
OSPF-R5-(config-if)#no shutdown
OSPF-R5-(config-if)#exit

OSPF-R5-(config)#interface loopback 3
OSPF-R5-(config-if)#ip address 15.1.3.1 255.255.255.0
OSPF-R5-(config-if)#no shutdown
OSPF-R5-(config-if)#exit

OSPF-R5-(config)#interface loopback 4
OSPF-R5-(config-if)#ip address 15.1.4.1 255.255.255.0
OSPF-R5-(config-if)#no shutdown
OSPF-R5-(config-if)#exit


 
OSPF-R6-(config)#interface serial 6/1
OSPF-R6-(config-if)#ip address 46.1.1.2 255.0.0.0
OSPF-R6-(config-if)#no shutdown
OSPF-R6-(config-if)#exit

OSPF-R6-(config)#interface serial 6/2
OSPF-R6-(config-if)#ip address 56.1.1.2 255.0.0.0
OSPF-R6-(config-if)#no shutdown
OSPF-R6-(config-if)#exit

OSPF-R6-(config)#interface serial 6/3
OSPF-R6-(config-if)#ip address 67.1.1.1  255.0.0.0
OSPF-R6-(config-if)#no shutdown
OSPF-R6-(config-if)#exit

OSPF-R6-(config)#interface loopback 1
OSPF-R6-(config-if)#ip address 16.1.1.1 255.255.255.0
OSPF-R6-(config-if)#no shutdown
OSPF-R6-(config-if)#exit

OSPF-R6-(config)#interface loopback 2
OSPF-R6-(config-if)#ip address 16.1.2.1 255.255.255.0
OSPF-R6-(config-if)#no shutdown
OSPF-R6-(config-if)#exit

OSPF-R6-(config)#interface loopback 3
OSPF-R6-(config-if)#ip address 16.1.3.1 255.255.255.0
OSPF-R6-(config-if)#no shutdown
OSPF-R6-(config-if)#exit

OSPF-R6-(config)#interface loopback 4
OSPF-R6-(config-if)#ip address 16.1.4.1 255.255.255.0
OSPF-R6-(config-if)#no shutdown
OSPF-R6-(config-if)#exit

OSPF-R6-(config)#interface fastethernet 0/0
OSPF-R6-(config-if)#ip address 60.1.1.1 255.0.0.0
OSPF-R6-(config-if)#no shutdown
OSPF-R6-(config-if)#no keepalive
OSPF-R6-(config-if)#exit

OSPF-R6-#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            60.1.1.1        YES manual up                    up
Serial6/1                  46.1.1.2        YES manual up                    up
Serial6/2                  56.1.1.2        YES manual up                    up
Serial6/3                  67.1.1.1        YES manual up                    up
Loopback1                  16.1.1.1        YES manual up                    up
Loopback2                  16.1.2.1        YES manual up                    up
Loopback3                  16.1.3.1        YES manual up                    up
Loopback4                  16.1.4.1        YES manual up                    up


OSPF-222-R7-(config)#interface serial 6/3
OSPF-222-R7-(config-if)#ip address 67.1.1.2 255.0.0.0
OSPF-222-R7-(config-if)#no shutdown
OSPF-222-R7-(config-if)#exit

OSPF-222-R7-(config)#interface fastethernet 0/0
OSPF-222-R7-(config-if)#ip address 70.1.1.1 255.0.0.0
OSPF-222-R7-(config-if)#no shutdown
OSPF-222-R7-(config-if)#no keepalive
OSPF-222-R7-(config-if)#exit

OSPF-222-R7-(config)#interface loopback 1
OSPF-222-R7-(config-if)#ip address 17.1.1.1 255.255.255.0
OSPF-222-R7-(config-if)#no shutdown
OSPF-222-R7-(config-if)#exit

OSPF-222-R7-(config)#interface loopback 2
OSPF-222-R7-(config-if)#ip address 17.1.2.1 255.255.255.0
OSPF-222-R7-(config-if)#no shutdown
OSPF-222-R7-(config-if)#exit

OSPF-222-R7-(config)#interface loopback 3
OSPF-222-R7-(config-if)#ip address 17.1.3.1 255.255.255.0
OSPF-222-R7-(config-if)#no shutdown
OSPF-222-R7-(config-if)#exit

OSPF-222-R7-(config)#interface loopback 4
OSPF-222-R7-(config-if)#ip address 17.1.4.1 255.255.255.0
OSPF-222-R7-(config-if)#no shutdown
OSPF-222-R7-(config-if)#exit

 
OSPF-111-AREA-2-R8-(config)#interface serial 6/3
OSPF-111-AREA-2-R8-(config-if)#ip address 58.1.1.2 255.0.0.0
OSPF-111-AREA-2-R8-(config-if)#no shutdown
OSPF-111-AREA-2-R8-(config-if)#exit

OSPF-111-AREA-2-R8-(config)#interface fastethernet 0/0
OSPF-111-AREA-2-R8-(config-if)#ip address 80.1.1.1 255.0.0.0
OSPF-111-AREA-2-R8-(config-if)#no shutdown
OSPF-111-AREA-2-R8-(config-if)#no keepalive
OSPF-111-AREA-2-R8-(config-if)#exit

OSPF-111-AREA-2-R8-(config)#interface loopback 1
OSPF-111-AREA-2-R8-(config-if)#ip address 18.1.1.1 255.255.255.0
OSPF-111-AREA-2-R8-(config-if)#no shutdown
OSPF-111-AREA-2-R8-(config-if)#exit

OSPF-111-AREA-2-R8-(config)#interface loopback 2
OSPF-111-AREA-2-R8-(config-if)#ip address 18.1.2.1 255.255.255.0
OSPF-111-AREA-2-R8-(config-if)#no shutdown
OSPF-111-AREA-2-R8-(config-if)#exit

OSPF-111-AREA-2-R8-(config)#interface loopback 3
OSPF-111-AREA-2-R8-(config-if)#ip address 18.1.3.1 255.255.255.0
OSPF-111-AREA-2-R8-(config-if)#no shutdown
OSPF-111-AREA-2-R8-(config-if)#exit

OSPF-111-AREA-2-R8-(config)#interface loopback 4
OSPF-111-AREA-2-R8-(config-if)#ip address 18.1.4.1 255.255.255.0
OSPF-111-AREA-2-R8-(config-if)#no shutdown
OSPF-111-AREA-2-R8-(config-if)#exit


OSPF-111-AREA-2-R8-#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            80.1.1.1        YES manual up                    up
Serial6/3                  58.1.1.2        YES manual up                    up
Loopback1                  18.1.1.1        YES manual up                    up
Loopback2                  18.1.2.1        YES manual up                    up
Loopback3                  18.1.3.1        YES manual up                    up
Loopback4                  18.1.4.1        YES manual up                    up

 
 
OSPF-111-R9-(config)#interface serial 5/0
OSPF-111-R9-(config-if)#ip address 39.1.1.2 255.0.0.0
OSPF-111-R9-(config-if)#no shutdown
OSPF-111-R9-(config-if)#exit
OSPF-111-R9-(config)#interface fastethernet 0/0
OSPF-111-R9-(config-if)#ip address 90.1.1.1 255.0.0.0
OSPF-111-R9-(config-if)#no shutdown
OSPF-111-R9-(config-if)#no keepalive
OSPF-111-R9-(config-if)#exit

OSPF-111-R9-(config)#interface loopback 1
OSPF-111-R9-(config-if)#ip address 19.1.1.1 255.255.255.0
OSPF-111-R9-(config-if)#no shutdown
OSPF-111-R9-(config-if)#exit

OSPF-111-R9-(config)#interface loopback 2
OSPF-111-R9-(config-if)#ip address 19.1.2.1 255.255.255.0
OSPF-111-R9-(config-if)#no shutdown
OSPF-111-R9-(config-if)#exit

OSPF-111-R9-(config)#interface loopback 3
OSPF-111-R9-(config-if)#ip address 19.1.3.1 255.255.255.0
OSPF-111-R9-(config-if)#no shutdown
OSPF-111-R9-(config-if)#exit

OSPF-111-R9-(config)#interface loopback 4
OSPF-111-R9-(config-if)#ip address 19.1.4.1 255.255.255.0
OSPF-111-R9-(config-if)#no shutdown
OSPF-111-R9-(config-if)#exit
 
OSPF-111-R9-#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            90.1.1.1        YES manual up                    up
Serial5/0                  39.1.1.2        YES manual up                    up
Loopback1                  19.1.1.1        YES manual up                    up
Loopback2                  19.1.2.1        YES manual up                    up
Loopback3                  19.1.3.1        YES manual up                    up
Loopback4                  19.1.4.1        YES manual up                    up
 


OSPF-AREA-4-R10-(config)#interface serial 5/2
OSPF-AREA-4-R10-(config-if)#ip address 21.1.1.2 255.0.0.0
OSPF-AREA-4-R10-(config-if)#no shutdown
OSPF-AREA-4-R10-(config-if)#exit

OSPF-AREA-4-R10-(config)#interface fastethernet 0/0
OSPF-AREA-4-R10-(config-if)#ip address 100.1.1.1 255.0.0.0
OSPF-AREA-4-R10-(config-if)#no shutdown
OSPF-AREA-4-R10-(config-if)#no keepalive
OSPF-AREA-4-R10-(config-if)#exit

OSPF-AREA-4-R10-(config)#interface loopback 1
OSPF-AREA-4-R10-(config-if)#ip address 110.1.1.1 255.255.255.0
OSPF-AREA-4-R10-(config-if)#no shutdown
OSPF-AREA-4-R10-(config-if)#exit

OSPF-AREA-4-R10-(config)#interface loopback 2
OSPF-AREA-4-R10-(config-if)#ip address 110.1.2.1 255.255.255.0
OSPF-AREA-4-R10-(config-if)#no shutdown
OSPF-AREA-4-R10-(config-if)#exit

OSPF-AREA-4-R10-(config)#interface loopback 3
OSPF-AREA-4-R10-(config-if)#ip address 110.1.3.1 255.255.255.0
OSPF-AREA-4-R10-(config-if)#no shutdown
OSPF-AREA-4-R10-(config-if)#exit

OSPF-AREA-4-R10-(config)#interface loopback 4
OSPF-AREA-4-R10-(config-if)#ip address 110.1.4.1 255.255.255.0
OSPF-AREA-4-R10-(config-if)#no shutdown
OSPF-AREA-4-R10-(config-if)#exit

OSPF-AREA-4-R10-#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            100.1.1.1       YES manual up                    up
Serial5/2                  21.1.1.2        YES manual up                    up
Loopback1                  110.1.1.1       YES manual up                    up
Loopback2                  110.1.2.1       YES manual up                    up
Loopback3                  110.1.3.1       YES manual up                    up
Loopback4                  110.1.4.1       YES manual up                    up

 
OSPF-AREA-3-R11-(config)#interface serial 5/1
OSPF-AREA-3-R11-(config-if)#ip address 111.1.1.2 255.0.0.0
OSPF-AREA-3-R11-(config-if)#no shutdown
OSPF-AREA-3-R11-(config-if)#exit

OSPF-AREA-3-R11-(config)#interface serial 5/0
OSPF-AREA-3-R11-(config-if)#ip address 112.1.1.1 255.0.0.0
OSPF-AREA-3-R11-(config-if)#no shutdown
OSPF-AREA-3-R11-(config-if)#exit

OSPF-AREA-3-R11-(config)#interface serial 5/2
OSPF-AREA-3-R11-(config-if)#ip address 103.1.1.1 255.0.0.0
OSPF-AREA-3-R11-(config-if)#no shutdown
OSPF-AREA-3-R11-(config-if)#exit
 
EIGRP-100-R12-(config)#interface serial 5/0
EIGRP-100-R12-(config-if)#ip address 112.1.1.2 255.0.0.0
EIGRP-100-R12-(config-if)#no shutdown
EIGRP-100-R12-(config-if)#exit

EIGRP-100-R12-(config)#interface fastethernet 0/0
EIGRP-100-R12-(config-if)#ip address 120.1.1.1 255.0.0.0
EIGRP-100-R12-(config-if)#no shutdown
EIGRP-100-R12-(config-if)#no keepalive
EIGRP-100-R12-(config-if)#exit

EIGRP-100-R12-(config)#interface loopback 1
EIGRP-100-R12-(config-if)#ip address 102.1.1.1 255.255.255.0
EIGRP-100-R12-(config-if)#no shutdown
EIGRP-100-R12-(config-if)#exit

EIGRP-100-R12-(config)#interface loopback 2
EIGRP-100-R12-(config-if)#ip address 102.1.2.1 255.255.255.0
EIGRP-100-R12-(config-if)#no shutdown
EIGRP-100-R12-(config-if)#exit

EIGRP-100-R12-(config)#interface loopback 3
EIGRP-100-R12-(config-if)#ip address 102.1.3.1 255.255.255.0
EIGRP-100-R12-(config-if)#no shutdown
EIGRP-100-R12-(config-if)#exit

EIGRP-100-R12-(config)#interface loopback 4
EIGRP-100-R12-(config-if)#ip address 102.1.4.1 255.255.255.0
EIGRP-100-R12-(config-if)#no shutdown
EIGRP-100-R12-(config-if)#exit
 
EIGRP-300-R13-(config)#interface serial 5/2
EIGRP-300-R13-(config-if)#ip address 103.1.1.2 255.0.0.0
EIGRP-300-R13-(config-if)#no shutdown
EIGRP-300-R13-(config-if)#exit

EIGRP-300-R13-(config)#interface loopback 1
EIGRP-300-R13-(config-if)#ip address 113.1.1.1 255.255.255.0
EIGRP-300-R13-(config-if)#no shutdown
EIGRP-300-R13-(config-if)#exit

EIGRP-300-R13-(config)#interface loopback 2
EIGRP-300-R13-(config-if)#ip address 113.1.2.1 255.255.255.0
EIGRP-300-R13-(config-if)#no shutdown
EIGRP-300-R13-(config-if)#exit

EIGRP-300-R13-(config)#interface loopback 3
EIGRP-300-R13-(config-if)#ip address 113.1.3.1 255.255.255.0
EIGRP-300-R13-(config-if)#no shutdown
EIGRP-300-R13-(config-if)#exit
 
EIGRP-300-R13-(config)#interface loopback 4
EIGRP-300-R13-(config-if)#ip address 113.1.4.1 255.255.255.0
EIGRP-300-R13-(config-if)#no shutdown
EIGRP-300-R13-(config-if)#exit
 
 
 OSPF-111-R1-(config)#router ospf 111
OSPF-111-R1-(config-router)#network 12.0.0.0 0.255.255.255 area 0
OSPF-111-R1-(config-router)#network 31.0.0.0 0.255.255.255 area 0
OSPF-111-R1-(config-router)#network 111.0.0.0 0.255.255.255 area 3
OSPF-111-R1-(config-router)#network 10.0.0.0 0.255.255.255 area 0
OSPF-111-R1-(config-router)#network 20.0.0.0 0.255.255.255 area 0
OSPF-111-R1-(config-router)#network 30.0.0.0 0.255.255.255 area 0
OSPF-111-R1-(config-router)#end

OSPF-111-R1-#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

O    34.0.0.0/8 [110/128] via 31.1.1.1, 00:14:23, Serial5/2
     16.0.0.0/32 is subnetted, 4 subnets
O IA    16.1.1.1 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O IA    16.1.2.1 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O IA    16.1.3.1 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O IA    16.1.4.1 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O IA 50.0.0.0/8 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O    32.0.0.0/8 [110/65] via 31.1.1.1, 00:14:23, Serial5/2
     19.0.0.0/32 is subnetted, 4 subnets
O       19.1.3.1 [110/129] via 31.1.1.1, 00:14:23, Serial5/2
O       19.1.2.1 [110/129] via 31.1.1.1, 00:14:23, Serial5/2
O       19.1.1.1 [110/129] via 31.1.1.1, 00:14:23, Serial5/2
O       19.1.4.1 [110/129] via 31.1.1.1, 00:14:23, Serial5/2
O IA 100.0.0.0/8 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O    33.0.0.0/8 [110/65] via 31.1.1.1, 00:14:24, Serial5/2
O IA 21.0.0.0/8 [110/192] via 31.1.1.1, 00:08:48, Serial5/2
C    20.0.0.0/8 is directly connected, FastEthernet2/0
O    39.0.0.0/8 [110/128] via 31.1.1.1, 00:14:24, Serial5/2
O    23.0.0.0/8 [110/128] via 31.1.1.1, 00:14:24, Serial5/2
O IA 67.0.0.0/8 [110/256] via 31.1.1.1, 00:08:48, Serial5/2
     110.0.0.0/32 is subnetted, 4 subnets
O IA    110.1.4.1 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O IA    110.1.2.1 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O IA    110.1.3.1 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O IA    110.1.1.1 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O IA 58.0.0.0/8 [110/256] via 31.1.1.1, 00:08:48, Serial5/2
C    111.0.0.0/8 is directly connected, Serial5/1
O IA 40.0.0.0/8 [110/129] via 31.1.1.1, 00:08:48, Serial5/2
C    10.0.0.0/8 is directly connected, FastEthernet0/0
O IA 56.0.0.0/8 [110/256] via 31.1.1.1, 00:08:48, Serial5/2
C    12.0.0.0/8 is directly connected, Serial5/0
O IA 46.0.0.0/8 [110/192] via 31.1.1.1, 00:08:48, Serial5/2
     14.0.0.0/32 is subnetted, 4 subnets
O IA    14.1.4.1 [110/129] via 31.1.1.1, 00:08:48, Serial5/2
O IA    14.1.2.1 [110/129] via 31.1.1.1, 00:08:48, Serial5/2
O IA    14.1.3.1 [110/129] via 31.1.1.1, 00:08:48, Serial5/2
O IA    14.1.1.1 [110/129] via 31.1.1.1, 00:08:50, Serial5/2
C    31.0.0.0/8 is directly connected, Serial5/2
O    90.0.0.0/8 [110/129] via 31.1.1.1, 00:14:25, Serial5/2
O IA 60.0.0.0/8 [110/193] via 31.1.1.1, 00:08:50, Serial5/2
O IA 45.0.0.0/8 [110/192] via 31.1.1.1, 00:08:50, Serial5/2
C    30.0.0.0/8 is directly connected, FastEthernet3/0
     15.0.0.0/32 is subnetted, 4 subnets
O IA    15.1.4.1 [110/193] via 31.1.1.1, 00:08:50, Serial5/2
O IA    15.1.3.1 [110/193] via 31.1.1.1, 00:08:50, Serial5/2
O IA    15.1.2.1 [110/193] via 31.1.1.1, 00:08:50, Serial5/2
O IA    15.1.1.1 [110/193] via 31.1.1.1, 00:08:50, Serial5/2

 
 
OSPF-111-R2-(config)#router ospf 111
OSPF-111-R2-(config-router)#network 12.0.0.0 0.255.255.255 area 0
OSPF-111-R2-(config-router)#network 23.0.0.0 0.255.255.255 area 0
OSPF-111-R2-(config-router)#network 21.0.0.0 0.255.255.255 area 4
OSPF-111-R2-(config-router)#end

 
 
OSPF-111-R3-(config)#router ospf 111
OSPF-111-R3-(config-router)#network 23.0.0.0 0.255.255.255 area 0
OSPF-111-R3-(config-router)#network 23.0.0.0 0.255.255.255 area 0
OSPF-111-R3-(config-router)#network 31.0.0.0 0.255.255.255 area 0
OSPF-111-R3-(config-router)#network 34.0.0.0 0.255.255.255 area 0
OSPF-111-R3-(config-router)#network 39.0.0.0 0.255.255.255 area 0
OSPF-111-R3-(config-router)#network 30.0.0.0 0.255.255.255 area 0
OSPF-111-R3-(config-router)#network 32.0.0.0 0.255.255.255 area 0
OSPF-111-R3-(config-router)#network 33.0.0.0 0.255.255.255 area 0
OSPF-111-R3-(config-router)#end

 
OSPF-R4-(config)#router ospf 111
OSPF-R4-(config-router)#network 34.0.0.0 0.255.255.255 area 0
OSPF-R4-(config-router)#network 45.0.0.0 0.255.255.255 area 1
OSPF-R4-(config-router)#network 46.0.0.0 0.255.255.255 area 1
OSPF-R4-(config-router)#network 40.0.0.0 0.255.255.255 area 1
OSPF-R4-(config-router)#network 14.1.1.0 255.0.0.0 area 1
OSPF-R4-(config-router)#network 14.1.2.0 255.0.0.0 area 1
OSPF-R4-(config-router)#network 14.1.3.0 255.0.0.0 area 1
OSPF-R4-(config-router)#network 14.1.4.0 255.0.0.0 area 1
OSPF-R4-(config-router)#end
 
OSPF-R5-(config)#router ospf 111
OSPF-R5-(config-router)#network 50.0.0.0 0.255.255.255 area 1
OSPF-R5-(config-router)#network 45.0.0.0 0.255.255.255 area 1
OSPF-R5-(config-router)#network 45.0.0.0 0.255.255.255 area 1
OSPF-R5-(config-router)#network 56.0.0.0 0.255.255.255 area 1
OSPF-R5-(config-router)#network 58.0.0.0 0.255.255.255 area 1
OSPF-R5-(config-router)#network 15.1.1.0 255.0.0.0 area 1
OSPF-R5-(config-router)#network 15.1.2.0 255.0.0.0 area 1
OSPF-R5-(config-router)#network 15.1.3.0 255.0.0.0 area 1
OSPF-R5-(config-router)#network 15.1.4.0 255.0.0.0 area 1
OSPF-R5-(config-router)#exit

OSPF-R6-(config)#router ospf 111
OSPF-R6-(config-router)#network 60.0.0.0 0.255.255.255 area 1
OSPF-R6-(config-router)#network 56.0.0.0 0.255.255.255 area 1
OSPF-R6-(config-router)#network 56.0.0.0 0.255.255.255 area 1
OSPF-R6-(config-router)#network 67.0.0.0 0.255.255.255 area 1
OSPF-R6-(config-router)#network 46.0.0.0 0.255.255.255 area 1
OSPF-R6-(config-router)#network 16.1.1.0 255.0.0.0 area 1
OSPF-R6-(config-router)#network 16.1.2.0 255.0.0.0 area 1
OSPF-R6-(config-router)#network 16.1.3.0 255.0.0.0 area 1
OSPF-R6-(config-router)#network 16.1.4.0 255.0.0.0 area 1
OSPF-R6-(config-router)#exit
 
OSPF-222-R7-(config)#router ospf 222
OSPF-222-R7-(config-router)#network 70.0.0.0 0.255.255.255 area 0
OSPF-222-R7-(config-router)#network 17.1.1.0 255.0.0.0 area 0
OSPF-222-R7-(config-router)#network 17.1.2.0 255.0.0.0 area 0
OSPF-222-R7-(config-router)#network 17.1.3.0 255.0.0.0 area 0
OSPF-222-R7-(config-router)#network 17.1.4.0 255.0.0.0 area 0
OSPF-222-R7-(config-router)#exit

OSPF-222-R7-(config)#router ospf 111
OSPF-222-R7-(config-router)#network 67.0.0.0 255.0.0.0 area 1
OSPF-222-R7-(config-router)#exit
 
 
OSPF-111-AREA-2-R8-(config)#router ospf 111
OSPF-111-AREA-2-R8-(config-router)#network 58.0.0.0 0.255.255.255 area 1                                      OSPF-111-AREA-2-R8-(config-router)#network 80.0.0.0 0.255.255.255 area 2
OSPF-111-AREA-2-R8-(config-router)#network 18.1.1.0 255.0.0.0 area 2
OSPF-111-AREA-2-R8-(config-router)#network 18.1.2.0 255.0.0.0 area 2
OSPF-111-AREA-2-R8-(config-router)#network 18.1.3.0 255.0.0.0 area 2
OSPF-111-AREA-2-R8-(config-router)#network 18.1.4.0 255.0.0.0 area 2
OSPF-111-AREA-2-R8-(config-router)#exit
 
 
OSPF-111-R9-(config)#router ospf 111
OSPF-111-R9-(config-router)#network 90.0.0.0 0.255.255.255 area 0
OSPF-111-R9-(config-router)#network 39.0.0.0 0.255.255.255 area 0
OSPF-111-R9-(config-router)#network 19.1.1.0 255.0.0.0 area 0
OSPF-111-R9-(config-router)#network 19.1.2.0 255.0.0.0 area 0
OSPF-111-R9-(config-router)#network 19.1.3.0 255.0.0.0 area 0
OSPF-111-R9-(config-router)#network 19.1.4.0 255.0.0.0 area 0
OSPF-111-R9-(config-router)#end
 
OSPF-AREA-4-R10-(config)#router ospf 111
OSPF-AREA-4-R10-(config-router)#network 21.0.0.0 0.255.255.255 area 4
OSPF-AREA-4-R10-(config-router)#network 100.0.0.0 0.255.255.255 area 4
OSPF-AREA-4-R10-(config-router)#network 110.1.1.0 255.0.0.0 area 4
OSPF-AREA-4-R10-(config-router)#network 110.1.2.0 255.0.0.0 area 4
OSPF-AREA-4-R10-(config-router)#network 110.1.3.0 255.0.0.0 area 4
OSPF-AREA-4-R10-(config-router)#network 110.1.4.0 255.0.0.0 area 4
OSPF-AREA-4-R10-(config-router)#exit
 
OSPF-AREA-3-R11-(config)#router ospf 111
OSPF-AREA-3-R11-(config-router)#network 111.0.0.0 0.255.255.255 area 4
OSPF-AREA-3-R11-(config-router)#no network 111.0.0.0 0.255.255.255 area 4
OSPF-AREA-3-R11-(config-router)#exit

OSPF-AREA-3-R11-(config)#router ospf 111
OSPF-AREA-3-R11-(config-router)#network 111.0.0.0 0.255.255.255 area 3
OSPF-AREA-3-R11-(config-router)#exit

OSPF-AREA-3-R11-(config)#router eigrp 100
OSPF-AREA-3-R11-(config-router)#network 112.0.0.0
OSPF-AREA-3-R11-(config-router)#no auto-summary
OSPF-AREA-3-R11-(config-router)#exit

OSPF-AREA-3-R11-(config)#router eigrp 300
OSPF-AREA-3-R11-(config-router)#network 103.0.0.0
OSPF-AREA-3-R11-(config-router)#no auto-summary
OSPF-AREA-3-R11-(config-router)#exit
OSPF-AREA-3-R11-(config)#

 
 
EIGRP-100-R12-(config)#router eigrp 100
EIGRP-100-R12-(config-router)#network 120.0.0.0
EIGRP-100-R12-(config-router)#network 102.1.1.0
EIGRP-100-R12-(config-router)#network 102.1.2.0
EIGRP-100-R12-(config-router)#network 102.1.3.0
EIGRP-100-R12-(config-router)#network 102.1.4.0
EIGRP-100-R12-(config-router)#network 112.0.0.0
EIGRP-100-R12-(config-router)#no auto-summary
EIGRP-100-R12-(config-router)#exit
 
 
EIGRP-300-R13-(config)#router eigrp 300
EIGRP-300-R13-(config-router)#network 113.1.1.0
EIGRP-300-R13-(config-router)#network 113.1.2.0
EIGRP-300-R13-(config-router)#network 113.1.3.0
EIGRP-300-R13-(config-router)#network 113.1.4.0
EIGRP-300-R13-(config-router)#network 103.0.0.0
EIGRP-300-R13-(config-router)#no auto-summary
EIGRP-300-R13-(config-router)#exit








OSPF-111-R1-#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

O    34.0.0.0/8 [110/128] via 31.1.1.1, 00:14:23, Serial5/2
     16.0.0.0/32 is subnetted, 4 subnets
O IA    16.1.1.1 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O IA    16.1.2.1 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O IA    16.1.3.1 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O IA    16.1.4.1 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O IA 50.0.0.0/8 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O    32.0.0.0/8 [110/65] via 31.1.1.1, 00:14:23, Serial5/2
     19.0.0.0/32 is subnetted, 4 subnets
O       19.1.3.1 [110/129] via 31.1.1.1, 00:14:23, Serial5/2
O       19.1.2.1 [110/129] via 31.1.1.1, 00:14:23, Serial5/2
O       19.1.1.1 [110/129] via 31.1.1.1, 00:14:23, Serial5/2
O       19.1.4.1 [110/129] via 31.1.1.1, 00:14:23, Serial5/2
O IA 100.0.0.0/8 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O    33.0.0.0/8 [110/65] via 31.1.1.1, 00:14:24, Serial5/2
O IA 21.0.0.0/8 [110/192] via 31.1.1.1, 00:08:48, Serial5/2
C    20.0.0.0/8 is directly connected, FastEthernet2/0
O    39.0.0.0/8 [110/128] via 31.1.1.1, 00:14:24, Serial5/2
O    23.0.0.0/8 [110/128] via 31.1.1.1, 00:14:24, Serial5/2
O IA 67.0.0.0/8 [110/256] via 31.1.1.1, 00:08:48, Serial5/2
     110.0.0.0/32 is subnetted, 4 subnets
O IA    110.1.4.1 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O IA    110.1.2.1 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O IA    110.1.3.1 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O IA    110.1.1.1 [110/193] via 31.1.1.1, 00:08:48, Serial5/2
O IA 58.0.0.0/8 [110/256] via 31.1.1.1, 00:08:48, Serial5/2
C    111.0.0.0/8 is directly connected, Serial5/1
O IA 40.0.0.0/8 [110/129] via 31.1.1.1, 00:08:48, Serial5/2
C    10.0.0.0/8 is directly connected, FastEthernet0/0
O IA 56.0.0.0/8 [110/256] via 31.1.1.1, 00:08:48, Serial5/2
C    12.0.0.0/8 is directly connected, Serial5/0
O IA 46.0.0.0/8 [110/192] via 31.1.1.1, 00:08:48, Serial5/2
     14.0.0.0/32 is subnetted, 4 subnets
O IA    14.1.4.1 [110/129] via 31.1.1.1, 00:08:48, Serial5/2
O IA    14.1.2.1 [110/129] via 31.1.1.1, 00:08:48, Serial5/2
O IA    14.1.3.1 [110/129] via 31.1.1.1, 00:08:48, Serial5/2
O IA    14.1.1.1 [110/129] via 31.1.1.1, 00:08:50, Serial5/2
C    31.0.0.0/8 is directly connected, Serial5/2
O    90.0.0.0/8 [110/129] via 31.1.1.1, 00:14:25, Serial5/2
O IA 60.0.0.0/8 [110/193] via 31.1.1.1, 00:08:50, Serial5/2
O IA 45.0.0.0/8 [110/192] via 31.1.1.1, 00:08:50, Serial5/2
C    30.0.0.0/8 is directly connected, FastEthernet3/0
     15.0.0.0/32 is subnetted, 4 subnets
O IA    15.1.4.1 [110/193] via 31.1.1.1, 00:08:50, Serial5/2
O IA    15.1.3.1 [110/193] via 31.1.1.1, 00:08:50, Serial5/2
O IA    15.1.2.1 [110/193] via 31.1.1.1, 00:08:50, Serial5/2
O IA    15.1.1.1 [110/193] via 31.1.1.1, 00:08:50, Serial5/2


OSPF-AREA-3-R11-(config)#router ospf 111
OSPF-AREA-3-R11-(config-router)#redistribute eigrp 100 subnet metric 100 metric-type 1
OSPF-AREA-3-R11-(config-router)#exit
 
OSPF-AREA-3-R11-(config)#router ospf 111
OSPF-AREA-3-R11-(config-router)#redistribute eigrp 300 subnet
OSPF-AREA-3-R11-(config-router)#exit

OSPF-AREA-3-R11-#show ip protocol
Routing Protocol is "ospf 111"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 112.1.1.1
  It is an autonomous system boundary router
  Redistributing External Routes from,
    eigrp 100 with metric mapped to 100, includes subnets in redistribution
    eigrp 300, includes subnets in redistribution
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    111.0.0.0 0.255.255.255 area 3
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    111.1.1.1            110      00:03:17
  Distance: (default is 110)

Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 100
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    112.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    112.1.1.2             90      00:25:45
  Distance: internal 90 external 170

Routing Protocol is "eigrp 300"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 300
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    103.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    103.1.1.2             90      00:24:46
  Distance: internal 90 external 170

OSPF-222-R7-(config)#router ospf 111
OSPF-222-R7-(config-router)#redistribute ospf 222 subnet metric-type 1
OSPF-222-R7-(config-router)#exit


OSPF-111-R1-#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     17.0.0.0/24 is subnetted, 4 subnets
O E1    17.1.1.0 [110/257] via 31.1.1.1, 00:01:34, Serial5/2
O E1    17.1.2.0 [110/257] via 31.1.1.1, 00:01:34, Serial5/2
O E1    17.1.3.0 [110/257] via 31.1.1.1, 00:01:34, Serial5/2
O E1    17.1.4.0 [110/257] via 31.1.1.1, 00:01:34, Serial5/2
O    34.0.0.0/8 [110/128] via 31.1.1.1, 00:47:53, Serial5/2
     102.0.0.0/24 is subnetted, 4 subnets
O E1    102.1.4.0 [110/164] via 111.1.1.2, 00:01:34, Serial5/1
O E1    102.1.3.0 [110/164] via 111.1.1.2, 00:01:34, Serial5/1
O E1    102.1.2.0 [110/164] via 111.1.1.2, 00:01:34, Serial5/1
O E1    102.1.1.0 [110/164] via 111.1.1.2, 00:01:34, Serial5/1
     16.0.0.0/32 is subnetted, 4 subnets
O IA    16.1.1.1 [110/193] via 31.1.1.1, 00:17:11, Serial5/2
O IA    16.1.2.1 [110/193] via 31.1.1.1, 00:17:12, Serial5/2
O IA    16.1.3.1 [110/193] via 31.1.1.1, 00:17:12, Serial5/2
O IA    16.1.4.1 [110/193] via 31.1.1.1, 00:17:12, Serial5/2
O IA 50.0.0.0/8 [110/193] via 31.1.1.1, 00:17:12, Serial5/2
O E2 103.0.0.0/8 [110/20] via 111.1.1.2, 00:01:35, Serial5/1
O    32.0.0.0/8 [110/65] via 31.1.1.1, 00:47:54, Serial5/2
     19.0.0.0/32 is subnetted, 4 subnets
O       19.1.3.1 [110/129] via 31.1.1.1, 00:47:54, Serial5/2
O       19.1.2.1 [110/129] via 31.1.1.1, 00:47:54, Serial5/2
O       19.1.1.1 [110/129] via 31.1.1.1, 00:47:54, Serial5/2
O       19.1.4.1 [110/129] via 31.1.1.1, 00:47:54, Serial5/2
O IA 100.0.0.0/8 [110/193] via 31.1.1.1, 00:17:12, Serial5/2
O E1 70.0.0.0/8 [110/257] via 31.1.1.1, 00:01:35, Serial5/2
O    33.0.0.0/8 [110/65] via 31.1.1.1, 00:47:54, Serial5/2
O IA 21.0.0.0/8 [110/192] via 31.1.1.1, 00:17:12, Serial5/2
C    20.0.0.0/8 is directly connected, FastEthernet2/0
O    39.0.0.0/8 [110/128] via 31.1.1.1, 00:47:54, Serial5/2
     113.0.0.0/24 is subnetted, 4 subnets
O E2    113.1.1.0 [110/20] via 111.1.1.2, 00:01:35, Serial5/1
O E2    113.1.2.0 [110/20] via 111.1.1.2, 00:01:35, Serial5/1
O E2    113.1.3.0 [110/20] via 111.1.1.2, 00:01:35, Serial5/1
O E2    113.1.4.0 [110/20] via 111.1.1.2, 00:01:35, Serial5/1
O    23.0.0.0/8 [110/128] via 31.1.1.1, 00:47:54, Serial5/2
O E1 112.0.0.0/8 [110/164] via 111.1.1.2, 00:01:36, Serial5/1
O IA 67.0.0.0/8 [110/256] via 31.1.1.1, 00:17:12, Serial5/2
     110.0.0.0/32 is subnetted, 4 subnets
O IA    110.1.4.1 [110/193] via 31.1.1.1, 00:17:12, Serial5/2
O IA    110.1.2.1 [110/193] via 31.1.1.1, 00:17:12, Serial5/2
O IA    110.1.3.1 [110/193] via 31.1.1.1, 00:17:12, Serial5/2
O IA    110.1.1.1 [110/193] via 31.1.1.1, 00:17:12, Serial5/2
O IA 58.0.0.0/8 [110/256] via 31.1.1.1, 00:17:12, Serial5/2
C    111.0.0.0/8 is directly connected, Serial5/1
O IA 40.0.0.0/8 [110/129] via 31.1.1.1, 00:17:12, Serial5/2
C    10.0.0.0/8 is directly connected, FastEthernet0/0
O IA 56.0.0.0/8 [110/256] via 31.1.1.1, 00:17:12, Serial5/2
C    12.0.0.0/8 is directly connected, Serial5/0
O IA 46.0.0.0/8 [110/192] via 31.1.1.1, 00:17:12, Serial5/2
     14.0.0.0/32 is subnetted, 4 subnets
O IA    14.1.4.1 [110/129] via 31.1.1.1, 00:17:12, Serial5/2
O IA    14.1.2.1 [110/129] via 31.1.1.1, 00:17:12, Serial5/2
O IA    14.1.3.1 [110/129] via 31.1.1.1, 00:17:12, Serial5/2
O IA    14.1.1.1 [110/129] via 31.1.1.1, 00:17:12, Serial5/2
C    31.0.0.0/8 is directly connected, Serial5/2
O E1 120.0.0.0/8 [110/164] via 111.1.1.2, 00:01:36, Serial5/1
O    90.0.0.0/8 [110/129] via 31.1.1.1, 00:47:54, Serial5/2
O IA 60.0.0.0/8 [110/193] via 31.1.1.1, 00:17:12, Serial5/2
O IA 45.0.0.0/8 [110/192] via 31.1.1.1, 00:17:13, Serial5/2
C    30.0.0.0/8 is directly connected, FastEthernet3/0
     15.0.0.0/32 is subnetted, 4 subnets
O IA    15.1.4.1 [110/193] via 31.1.1.1, 00:17:13, Serial5/2
O IA    15.1.3.1 [110/193] via 31.1.1.1, 00:17:13, Serial5/2
O IA    15.1.2.1 [110/193] via 31.1.1.1, 00:17:13, Serial5/2
O IA    15.1.1.1 [110/193] via 31.1.1.1, 00:17:13, Serial5/2




OSPF-111-AREA-2-R8-(config)#router ospf 111
OSPF-111-AREA-2-R8-(config-router)#area 1 virtual-link 14.1.4.1
OSPF-111-AREA-2-R8-(config-router)#end

OSPF-R4-(config)#router ospf 111
OSPF-R4-(config-router)#area 1 virtual-link 18.1.4.1
OSPF-R4-(config-router)#end

*Oct 15 15:32:06.483: %OSPF-5-ADJCHG: Process 111, Nbr 18.1.4.1 on OSPF_VL0 from LOADING to FULL, Loading Done

OSPF-222-R7-(config)#router ospf 111
OSPF-222-R7-(config-router)#redistribute ospf 222 subnet metric-type 1
OSPF-222-R7-(config-router)#exit


OSPF-111-R1-#show ip route ospf
     17.0.0.0/24 is subnetted, 4 subnets
O E1    17.1.1.0 [110/257] via 31.1.1.1, 00:00:12, Serial5/2
O E1    17.1.2.0 [110/257] via 31.1.1.1, 00:00:12, Serial5/2
O E1    17.1.3.0 [110/257] via 31.1.1.1, 00:00:12, Serial5/2
O E1    17.1.4.0 [110/257] via 31.1.1.1, 00:00:12, Serial5/2
O    34.0.0.0/8 [110/128] via 31.1.1.1, 00:00:12, Serial5/2
     102.0.0.0/24 is subnetted, 4 subnets
O E1    102.1.4.0 [110/164] via 111.1.1.2, 00:00:12, Serial5/1
O E1    102.1.3.0 [110/164] via 111.1.1.2, 00:00:12, Serial5/1
O E1    102.1.2.0 [110/164] via 111.1.1.2, 00:00:12, Serial5/1
O E1    102.1.1.0 [110/164] via 111.1.1.2, 00:00:12, Serial5/1
     16.0.0.0/32 is subnetted, 4 subnets
O IA    16.1.1.1 [110/193] via 31.1.1.1, 00:00:12, Serial5/2
O IA    16.1.2.1 [110/193] via 31.1.1.1, 00:00:12, Serial5/2
O IA    16.1.3.1 [110/193] via 31.1.1.1, 00:00:12, Serial5/2
O IA    16.1.4.1 [110/193] via 31.1.1.1, 00:00:12, Serial5/2
O IA 50.0.0.0/8 [110/193] via 31.1.1.1, 00:00:12, Serial5/2
O E2 103.0.0.0/8 [110/20] via 111.1.1.2, 00:00:12, Serial5/1
O    32.0.0.0/8 [110/65] via 31.1.1.1, 00:00:12, Serial5/2
     19.0.0.0/32 is subnetted, 4 subnets
O       19.1.3.1 [110/129] via 31.1.1.1, 00:00:12, Serial5/2
O       19.1.2.1 [110/129] via 31.1.1.1, 00:00:12, Serial5/2
O       19.1.1.1 [110/129] via 31.1.1.1, 00:00:12, Serial5/2
O       19.1.4.1 [110/129] via 31.1.1.1, 00:00:13, Serial5/2
O IA 100.0.0.0/8 [110/193] via 31.1.1.1, 00:00:13, Serial5/2
O E1 70.0.0.0/8 [110/257] via 31.1.1.1, 00:00:13, Serial5/2
O    33.0.0.0/8 [110/65] via 31.1.1.1, 00:00:13, Serial5/2
     18.0.0.0/32 is subnetted, 4 subnets
O IA    18.1.2.1 [110/257] via 31.1.1.1, 00:00:13, Serial5/2
O IA    18.1.3.1 [110/257] via 31.1.1.1, 00:00:13, Serial5/2
O IA    18.1.1.1 [110/257] via 31.1.1.1, 00:00:13, Serial5/2
O IA    18.1.4.1 [110/257] via 31.1.1.1, 00:00:13, Serial5/2
O IA 21.0.0.0/8 [110/192] via 31.1.1.1, 00:00:13, Serial5/2
O IA 80.0.0.0/8 [110/257] via 31.1.1.1, 00:00:13, Serial5/2
O    39.0.0.0/8 [110/128] via 31.1.1.1, 00:00:13, Serial5/2
     113.0.0.0/24 is subnetted, 4 subnets
O E2    113.1.1.0 [110/20] via 111.1.1.2, 00:00:13, Serial5/1
O E2    113.1.2.0 [110/20] via 111.1.1.2, 00:00:13, Serial5/1
O E2    113.1.3.0 [110/20] via 111.1.1.2, 00:00:13, Serial5/1
O E2    113.1.4.0 [110/20] via 111.1.1.2, 00:00:13, Serial5/1
O    23.0.0.0/8 [110/128] via 31.1.1.1, 00:00:13, Serial5/2
O E1 112.0.0.0/8 [110/164] via 111.1.1.2, 00:00:13, Serial5/1
O IA 67.0.0.0/8 [110/256] via 31.1.1.1, 00:00:13, Serial5/2
     110.0.0.0/32 is subnetted, 4 subnets
O IA    110.1.4.1 [110/193] via 31.1.1.1, 00:00:13, Serial5/2
O IA    110.1.2.1 [110/193] via 31.1.1.1, 00:00:13, Serial5/2
O IA    110.1.3.1 [110/193] via 31.1.1.1, 00:00:14, Serial5/2
O IA    110.1.1.1 [110/193] via 31.1.1.1, 00:00:14, Serial5/2
O IA 58.0.0.0/8 [110/256] via 31.1.1.1, 00:00:14, Serial5/2
O IA 40.0.0.0/8 [110/129] via 31.1.1.1, 00:00:14, Serial5/2
O IA 56.0.0.0/8 [110/256] via 31.1.1.1, 00:00:14, Serial5/2
O IA 46.0.0.0/8 [110/192] via 31.1.1.1, 00:00:14, Serial5/2
     14.0.0.0/32 is subnetted, 4 subnets
O IA    14.1.4.1 [110/129] via 31.1.1.1, 00:00:14, Serial5/2
O IA    14.1.2.1 [110/129] via 31.1.1.1, 00:00:14, Serial5/2
O IA    14.1.3.1 [110/129] via 31.1.1.1, 00:00:14, Serial5/2
O IA    14.1.1.1 [110/129] via 31.1.1.1, 00:00:14, Serial5/2
O E1 120.0.0.0/8 [110/164] via 111.1.1.2, 00:00:14, Serial5/1
O    90.0.0.0/8 [110/129] via 31.1.1.1, 00:00:14, Serial5/2
O IA 60.0.0.0/8 [110/193] via 31.1.1.1, 00:00:14, Serial5/2
O IA 45.0.0.0/8 [110/192] via 31.1.1.1, 00:00:14, Serial5/2
     15.0.0.0/32 is subnetted, 4 subnets
O IA    15.1.4.1 [110/193] via 31.1.1.1, 00:00:14, Serial5/2
O IA    15.1.3.1 [110/193] via 31.1.1.1, 00:00:14, Serial5/2
O IA    15.1.2.1 [110/193] via 31.1.1.1, 00:00:14, Serial5/2
O IA    15.1.1.1 [110/193] via 31.1.1.1, 00:00:14, Serial5/2





OSPF-111-R1-(config)#router ospf 111
OSPF-111-R1-(config-router)#passive-interface fastEthernet 0/0
OSPF-111-R1-(config-router)#passive-interface fastEthernet 2/0
OSPF-111-R1-(config-router)#passive-interface fastEthernet 3/0
OSPF-111-R1-(config-router)#exit


OSPF-111-R3-(config)#router ospf 111
OSPF-111-R3-(config-router)#passive-interface fastEthernet 0/0
OSPF-111-R3-(config-router)#passive-interface fastEthernet 2/0
OSPF-111-R3-(config-router)#passive-interface fastEthernet 3/0
OSPF-111-R3-(config-router)#end


OSPF-AREA-4-R10-(config)#router ospf 111
OSPF-AREA-4-R10-(config-router)#area 4 stub
OSPF-AREA-4-R10-(config-router)#end

*Oct 15 15:30:45.291: %OSPF-5-ADJCHG: Process 111, Nbr 23.1.1.1 on Serial5/2 from FULL to DOWN, Neighbor Down: Adjacency forced to reset*Oct 15 15:31:04.207: %OSPF-5-ADJCHG: Process 111, Nbr 23.1.1.1 on Serial5/2 from LOADING to FULL, Loading Done



OSPF-AREA-4-R10-#show ip route ospf
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

O IA 34.0.0.0/8 [110/192] via 21.1.1.1, 00:00:11, Serial5/2
     16.0.0.0/32 is subnetted, 4 subnets
O IA    16.1.1.1 [110/257] via 21.1.1.1, 00:00:11, Serial5/2
O IA    16.1.2.1 [110/257] via 21.1.1.1, 00:00:11, Serial5/2
O IA    16.1.3.1 [110/257] via 21.1.1.1, 00:00:11, Serial5/2
O IA    16.1.4.1 [110/257] via 21.1.1.1, 00:00:11, Serial5/2
O IA 50.0.0.0/8 [110/257] via 21.1.1.1, 00:00:11, Serial5/2
O IA 32.0.0.0/8 [110/129] via 21.1.1.1, 00:00:11, Serial5/2
     19.0.0.0/32 is subnetted, 4 subnets
O IA    19.1.3.1 [110/193] via 21.1.1.1, 00:00:11, Serial5/2
O IA    19.1.2.1 [110/193] via 21.1.1.1, 00:00:11, Serial5/2
O IA    19.1.1.1 [110/193] via 21.1.1.1, 00:00:11, Serial5/2
O IA    19.1.4.1 [110/193] via 21.1.1.1, 00:00:11, Serial5/2
O IA 33.0.0.0/8 [110/129] via 21.1.1.1, 00:00:11, Serial5/2
     18.0.0.0/32 is subnetted, 4 subnets
O IA    18.1.2.1 [110/321] via 21.1.1.1, 00:00:11, Serial5/2
O IA    18.1.3.1 [110/321] via 21.1.1.1, 00:00:11, Serial5/2
O IA    18.1.1.1 [110/321] via 21.1.1.1, 00:00:11, Serial5/2
O IA    18.1.4.1 [110/321] via 21.1.1.1, 00:00:11, Serial5/2
O IA 80.0.0.0/8 [110/321] via 21.1.1.1, 00:00:11, Serial5/2
O IA 20.0.0.0/8 [110/193] via 21.1.1.1, 00:00:11, Serial5/2
O IA 39.0.0.0/8 [110/192] via 21.1.1.1, 00:00:11, Serial5/2
O IA 23.0.0.0/8 [110/128] via 21.1.1.1, 00:00:11, Serial5/2
O IA 67.0.0.0/8 [110/320] via 21.1.1.1, 00:00:12, Serial5/2
O IA 58.0.0.0/8 [110/320] via 21.1.1.1, 00:00:12, Serial5/2
O IA 111.0.0.0/8 [110/256] via 21.1.1.1, 00:00:12, Serial5/2
O IA 40.0.0.0/8 [110/193] via 21.1.1.1, 00:00:12, Serial5/2
O IA 10.0.0.0/8 [110/193] via 21.1.1.1, 00:00:12, Serial5/2
O IA 56.0.0.0/8 [110/320] via 21.1.1.1, 00:00:12, Serial5/2
O IA 12.0.0.0/8 [110/256] via 21.1.1.1, 00:00:12, Serial5/2
O IA 46.0.0.0/8 [110/256] via 21.1.1.1, 00:00:12, Serial5/2
     14.0.0.0/32 is subnetted, 4 subnets
O IA    14.1.4.1 [110/193] via 21.1.1.1, 00:00:12, Serial5/2
O IA    14.1.2.1 [110/193] via 21.1.1.1, 00:00:12, Serial5/2
O IA    14.1.3.1 [110/193] via 21.1.1.1, 00:00:12, Serial5/2
O IA    14.1.1.1 [110/193] via 21.1.1.1, 00:00:12, Serial5/2
O IA 31.0.0.0/8 [110/192] via 21.1.1.1, 00:00:12, Serial5/2
O IA 90.0.0.0/8 [110/193] via 21.1.1.1, 00:00:12, Serial5/2
O IA 60.0.0.0/8 [110/257] via 21.1.1.1, 00:00:12, Serial5/2
O IA 45.0.0.0/8 [110/256] via 21.1.1.1, 00:00:12, Serial5/2
O IA 30.0.0.0/8 [110/129] via 21.1.1.1, 00:00:12, Serial5/2
     15.0.0.0/32 is subnetted, 4 subnets
O IA    15.1.4.1 [110/257] via 21.1.1.1, 00:00:12, Serial5/2
O IA    15.1.3.1 [110/257] via 21.1.1.1, 00:00:12, Serial5/2
O IA    15.1.2.1 [110/257] via 21.1.1.1, 00:00:12, Serial5/2
O IA    15.1.1.1 [110/257] via 21.1.1.1, 00:00:12, Serial5/2
O*IA 0.0.0.0/0 [110/65] via 21.1.1.1, 00:00:12, Serial5/2




OSPF-111-R1-#show ip route ospf
     17.0.0.0/24 is subnetted, 4 subnets
O E1    17.1.1.0 [110/257] via 31.1.1.1, 00:20:22, Serial5/2
O E1    17.1.2.0 [110/257] via 31.1.1.1, 00:20:22, Serial5/2
O E1    17.1.3.0 [110/257] via 31.1.1.1, 00:20:22, Serial5/2
O E1    17.1.4.0 [110/257] via 31.1.1.1, 00:20:22, Serial5/2
O    34.0.0.0/8 [110/128] via 31.1.1.1, 00:20:22, Serial5/2
     102.0.0.0/24 is subnetted, 4 subnets
O E1    102.1.4.0 [110/164] via 111.1.1.2, 00:20:22, Serial5/1
O E1    102.1.3.0 [110/164] via 111.1.1.2, 00:20:22, Serial5/1
O E1    102.1.2.0 [110/164] via 111.1.1.2, 00:20:22, Serial5/1
O E1    102.1.1.0 [110/164] via 111.1.1.2, 00:20:22, Serial5/1
     16.0.0.0/32 is subnetted, 4 subnets
O IA    16.1.1.1 [110/193] via 31.1.1.1, 00:20:22, Serial5/2
O IA    16.1.2.1 [110/193] via 31.1.1.1, 00:20:22, Serial5/2
O IA    16.1.3.1 [110/193] via 31.1.1.1, 00:20:22, Serial5/2
O IA    16.1.4.1 [110/193] via 31.1.1.1, 00:20:22, Serial5/2
O IA 50.0.0.0/8 [110/193] via 31.1.1.1, 00:20:22, Serial5/2
O E2 103.0.0.0/8 [110/20] via 111.1.1.2, 00:20:22, Serial5/1
O    32.0.0.0/8 [110/65] via 31.1.1.1, 00:20:22, Serial5/2
     19.0.0.0/32 is subnetted, 4 subnets
O       19.1.3.1 [110/129] via 31.1.1.1, 00:20:22, Serial5/2
O       19.1.2.1 [110/129] via 31.1.1.1, 00:20:22, Serial5/2
O       19.1.1.1 [110/129] via 31.1.1.1, 00:20:22, Serial5/2
O       19.1.4.1 [110/129] via 31.1.1.1, 00:20:23, Serial5/2
O IA 100.0.0.0/8 [110/193] via 31.1.1.1, 00:20:23, Serial5/2
O E1 70.0.0.0/8 [110/257] via 31.1.1.1, 00:20:23, Serial5/2
O    33.0.0.0/8 [110/65] via 31.1.1.1, 00:20:23, Serial5/2
     18.0.0.0/32 is subnetted, 4 subnets
O IA    18.1.2.1 [110/257] via 31.1.1.1, 00:20:23, Serial5/2
O IA    18.1.3.1 [110/257] via 31.1.1.1, 00:20:23, Serial5/2
O IA    18.1.1.1 [110/257] via 31.1.1.1, 00:20:23, Serial5/2
O IA    18.1.4.1 [110/257] via 31.1.1.1, 00:20:23, Serial5/2
O IA 21.0.0.0/8 [110/192] via 31.1.1.1, 00:20:23, Serial5/2
O IA 80.0.0.0/8 [110/257] via 31.1.1.1, 00:20:23, Serial5/2
O    39.0.0.0/8 [110/128] via 31.1.1.1, 00:20:23, Serial5/2
     113.0.0.0/24 is subnetted, 4 subnets
O E2    113.1.1.0 [110/20] via 111.1.1.2, 00:20:23, Serial5/1
O E2    113.1.2.0 [110/20] via 111.1.1.2, 00:20:23, Serial5/1
O E2    113.1.3.0 [110/20] via 111.1.1.2, 00:20:23, Serial5/1
O E2    113.1.4.0 [110/20] via 111.1.1.2, 00:20:23, Serial5/1
O    23.0.0.0/8 [110/128] via 31.1.1.1, 00:20:23, Serial5/2
O E1 112.0.0.0/8 [110/164] via 111.1.1.2, 00:20:23, Serial5/1
O IA 67.0.0.0/8 [110/256] via 31.1.1.1, 00:20:23, Serial5/2
     110.0.0.0/32 is subnetted, 4 subnets
O IA    110.1.4.1 [110/193] via 31.1.1.1, 00:20:23, Serial5/2
O IA    110.1.2.1 [110/193] via 31.1.1.1, 00:20:23, Serial5/2
O IA    110.1.3.1 [110/193] via 31.1.1.1, 00:20:23, Serial5/2
O IA    110.1.1.1 [110/193] via 31.1.1.1, 00:20:23, Serial5/2
O IA 58.0.0.0/8 [110/256] via 31.1.1.1, 00:20:23, Serial5/2
O IA 40.0.0.0/8 [110/129] via 31.1.1.1, 00:20:23, Serial5/2
O IA 56.0.0.0/8 [110/256] via 31.1.1.1, 00:20:23, Serial5/2
O IA 46.0.0.0/8 [110/192] via 31.1.1.1, 00:20:23, Serial5/2
     14.0.0.0/32 is subnetted, 4 subnets
O IA    14.1.4.1 [110/129] via 31.1.1.1, 00:20:23, Serial5/2
O IA    14.1.2.1 [110/129] via 31.1.1.1, 00:20:23, Serial5/2
O IA    14.1.3.1 [110/129] via 31.1.1.1, 00:20:23, Serial5/2
O IA    14.1.1.1 [110/129] via 31.1.1.1, 00:20:23, Serial5/2
O E1 120.0.0.0/8 [110/164] via 111.1.1.2, 00:20:23, Serial5/1
O    90.0.0.0/8 [110/129] via 31.1.1.1, 00:20:23, Serial5/2
O IA 60.0.0.0/8 [110/193] via 31.1.1.1, 00:20:23, Serial5/2
O IA 45.0.0.0/8 [110/192] via 31.1.1.1, 00:20:23, Serial5/2
     15.0.0.0/32 is subnetted, 4 subnets
O IA    15.1.4.1 [110/193] via 31.1.1.1, 00:20:23, Serial5/2
O IA    15.1.3.1 [110/193] via 31.1.1.1, 00:20:23, Serial5/2
O IA    15.1.2.1 [110/193] via 31.1.1.1, 00:20:23, Serial5/2
O IA    15.1.1.1 [110/193] via 31.1.1.1, 00:20:23, Serial5/2


I hope you like this blog please visit to our YouTube channel https://www.youtube.com/@internetworkss

No comments:

Post a Comment

Border Gateway Protocol attributes CCNA FREE LAB

  Border Gateway Protocol (BGP) advertises, learns, and chooses the best paths inside the wide internet. When two ISPs connect, they typical...

INSTAGRAM FEED

@Edger C Francis