DONATE


BGP Weight configuration


Weight is Cisco proprietary attribute; weight tells how to exit the autonomous system. Path with the highest weight is more desirable range is 0 through 65,535, by default 0 for learned routes, 32,768 for locally injected routes. Weight is partial attribute; set on inbound route update.



Here’s what we need to know about weight:
  • Weight attribute is the first BGP attribute in the list.
  • BGP Weight is a Cisco proprietary so you won’t find it on other vendor routers.
  • BGP Weight attribute is not exchanged between BGP routers. Its only local on the router.
  • The path with the highest weight is desirable




lets see the configuration:-


Topology:-





TASK:

Our task is to changing router 2 AS 65123 path, by default router 2 take AS 65444 to reach router 5 AS 65555 because it has less ASs but our requirement is router 2 have to take AS 65111 , AS 65444 to reach 50.1.1.1 network via router 1 with use of BGP Weight attribute.

  • configure the topology as per the diagram 
  • configure IP addresses to their interfaces
  • configure BGP internal and external 
  • configure weight on router 2 

from router 1

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#Interface fastethernet 0/0
Router(config-if)#Ip address 10.1.1.1   255.0.0.0
Router(config-if)#No shutdown
Router(config-if)#No keepalive
Router(config-if)#Exit

Router(config)#Interface serial 3/0
Router(config-if)#Ip address  1.1.1.1 255.0.0.0
Router(config-if)#No shutdown
Router(config-if)#Exit

Router(config)#Interface serial 3/3
Router(config-if)#Ip address  4.4.4.2 255.0.0.0
Router(config-if)#No shutdown
Router(config-if)#Exit

Router(config)#Interface loopback 0
Router(config-if)#Ip address 11.0.0.1 255.255.255.0
Router(config-if)#Exit

Router(config)#Interface loopback  1
Router(config-if)#Ip address 11.0.1.1 255.255.255.0
Router(config-if)#Exit

Router(config)#Interface loopback  2
Router(config-if)#Ip address 11.0.2.1 255.255.255.0
Router(config-if)#Exit
Router(config)#Interface loopback 3
Router(config-if)#Ip address 11.0.3.1 255.255.255.0
Router(config-if)#Exit

*Nov 25 22:32:36.227: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback3, changed state to up
*Nov 25 22:32:36.423: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Nov 25 22:32:36.831: %LINK-3-UPDOWN: Interface Serial3/0, changed state to up
*Nov 25 22:32:37.087: %LINK-3-UPDOWN: Interface Serial3/3, changed state to up
*Nov 25 22:32:37.839: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up
*Nov 25 22:32:38.095: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/3, changed state to up
*Nov 25 22:32:40.163: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
*Nov 25 22:33:00.195: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to down
*Nov 25 22:33:00.207: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/3, changed state to down
*Nov 25 22:33:30.231: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up


from router 2

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#Interface fastethernet 0/0
Router(config-if)#Ip address 20.1.1.1   255.0.0.0
Router(config-if)#No shutdown
Router(config-if)#No keepalive
Router(config-if)#Exit

Router(config)#Interface serial 3/0
Router(config-if)#Ip address  1.1.1.2 255.0.0.0
Router(config-if)#No shutdown
Router(config-if)#Exit

Router(config)#Interface serial 3/1
Router(config-if)#Ip address  2.2.2.1 255.0.0.0
Router(config-if)#No shutdown
Router(config-if)#Exit

Router(config)#Interface loopback  1
Router(config-if)#Ip address 12.0.1.1 255.255.255.0
Router(config-if)#Exit
Router(config)#Interface loopback  2
Router(config-if)#Ip address 12.0.2.1 255.255.255.0
Router(config-if)#Exit
Router(config)#Interface loopback 3
Router(config-if)#Ip address 12.0.3.1 255.255.255.0
Router(config-if)#Exit

*Nov 25 22:36:07.175: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
*Nov 25 22:36:07.543: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up
*Nov 25 22:36:07.851: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback3, changed state to up

*Nov 25 22:33:12.623: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Nov 25 22:33:13.251: %LINK-3-UPDOWN: Interface Serial3/0, changed state to up
*Nov 25 22:33:13.387: %LINK-3-UPDOWN: Interface Serial3/1, changed state to up
*Nov 25 22:33:14.259: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up
*Nov 25 22:33:14.387: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/1, changed state to up
*Nov 25 22:33:20.499: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
*Nov 25 22:33:40.519: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/1, changed state to down
*Nov 25 22:34:00.503: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/1, changed state to up



from router3

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#Interface fastethernet 0/0
Router(config-if)#Ip address 30.1.1.1   255.0.0.0
Router(config-if)#No shutdown
Router(config-if)#No keepalive
Router(config-if)#Exit

Router(config)#Interface serial 3/1
Router(config-if)#Ip address  2.2.2.2 255.0.0.0
Router(config-if)#No shutdown
Router(config-if)#Exit

Router(config)#Interface serial 3/2
Router(config-if)#Ip address  3.3.3.1 255.0.0.0
Router(config-if)#No shutdown
Router(config-if)#Exit

Router(config)#Interface loopback 0
Router(config-if)#Ip address 13.0.0.1 255.255.255.0
Router(config-if)#Exit

Router(config)#Interface loopback  1
Router(config-if)#Ip address 13.0.1.1 255.255.255.0
Router(config-if)#Exit
Router(config)#Interface loopback  2
Router(config-if)#Ip address 13.0.2.1 255.255.255.0
Router(config-if)#Exit
Router(config)#Interface loopback 3
Router(config-if)#Ip address 13.0.3.1 255.255.255.0
Router(config-if)#Exit

*Nov 25 22:33:49.239: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
*Nov 25 22:33:49.659: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
*Nov 25 22:33:49.959: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up
*Nov 25 22:33:50.251: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback3, changed state to up
*Nov 25 22:33:50.311: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Nov 25 22:33:50.823: %LINK-3-UPDOWN: Interface Serial3/1, changed state to up
*Nov 25 22:33:51.043: %LINK-3-UPDOWN: Interface Serial3/2, changed state to up
*Nov 25 22:33:51.311: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
*Nov 25 22:33:51.823: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/1, changed state to up
*Nov 25 22:33:52.051: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to up
*Nov 25 22:34:21.143: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to down
*Nov 25 22:34:31.139: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to up


from router  4

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#Interface fastethernet 0/0
Router(config-if)#Ip address 40.1.1.1   255.0.0.0
Router(config-if)#No shutdown
Router(config-if)#No keepalive
Router(config-if)#Exit

Router(config)#Interface serial 3/2
Router(config-if)#Ip address  3.3.3.2 255.0.0.0
Router(config-if)#No shutdown
Router(config-if)#Exit

Router(config)#interface serial 3/3
Router(config-if)#ip address 4.4.4.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#Interface serial 3/4
Router(config-if)#Ip address  5.5.5.2 255.0.0.0
Router(config-if)#No shutdown
Router(config-if)#Exit

Router(config)#Interface loopback 0
Router(config-if)#Ip address 14.0.0.1 255.255.255.0
Router(config-if)#Exit

Router(config)#Interface loopback  1
Router(config-if)#Ip address 14.0.1.1 255.255.255.0
Router(config-if)#Exit
Router(config)#Interface loopback  2
Router(config-if)#Ip address 14.0.2.1 255.255.255.0
Router(config-if)#Exit
Router(config)#Interface loopback 3
Router(config-if)#Ip address 14.0.3.1 255.255.255.0
Router(config-if)#Exit

*Nov 25 22:34:26.699: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
*Nov 25 22:34:27.115: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
*Nov 25 22:34:27.411: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up
*Nov 25 22:34:27.687: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback3, changed state to up
*Nov 25 22:34:28.011: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Nov 25 22:34:28.427: %LINK-3-UPDOWN: Interface Serial3/2, changed state to up
*Nov 25 22:34:28.635: %LINK-3-UPDOWN: Interface Serial3/4, changed state to up
*Nov 25 22:34:29.435: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to up
*Nov 25 22:34:29.643: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/4, changed state to up
*Nov 25 22:34:30.351: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
*Nov 25 22:34:50.347: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/4, changed state to down
*Nov 25 22:35:10.371: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/4, changed state to up


from router 5

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#Interface fastethernet 0/0
Router(config-if)#Ip address 50.1.1.1   255.0.0.0
Router(config-if)#No shutdown
Router(config-if)#No keepalive
Router(config-if)#Exit

Router(config)#Interface serial 3/4
Router(config-if)#Ip address  5.5.5.1 255.0.0.0
Router(config-if)#No shutdown
Router(config-if)#Exit

Router(config)#Interface loopback 0
Router(config-if)#Ip address 15.0.0.1 255.255.255.0
Router(config-if)#Exit

Router(config)#Interface loopback  1
Router(config-if)#Ip address 15.0.1.1 255.255.255.0
Router(config-if)#Exit
Router(config)#Interface loopback  2
Router(config-if)#Ip address 15.0.2.1 255.255.255.0
Router(config-if)#Exit
Router(config)#Interface loopback 3
Router(config-if)#Ip address 15.0.3.1 255.255.255.0
Router(config-if)#Exit

*Nov 25 23:08:41.015: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
*Nov 25 23:08:41.475: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
*Nov 25 23:08:41.807: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up
*Nov 25 23:08:42.135: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback3, changed state to up
*Nov 25 23:08:42.331: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Nov 25 23:08:42.795: %LINK-3-UPDOWN: Interface Serial3/4, changed state to up
*Nov 25 23:08:43.807: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/4, changed state to up
*Nov 25 23:08:49.675: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

from router 1
Router>enable
Router#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0                    1.1.1.1         YES manual up                    up
Serial3/3                   4.4.4.2         YES manual up                    up
Loopback0              11.0.0.1        YES manual up                    up
Loopback1              11.0.1.1        YES manual up                    up
Loopback2              11.0.2.1        YES manual up                    up
Loopback3              11.0.3.1        YES manual up                    up


from router 2

Router>enable
Router#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                    1.1.1.2         YES manual up                    up
Serial3/1                    2.2.2.1         YES manual up                    up
Loopback1              12.0.1.1        YES manual up                    up
Loopback2              12.0.2.1        YES manual up                    up
Loopback3              12.0.3.1        YES manual up                    up


from router 3

Router>enable
Router#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/1                    2.2.2.2         YES manual up                    up
Serial3/2                    3.3.3.1         YES manual up                    up
Loopback0              13.0.0.1        YES manual up                    up
Loopback1              13.0.1.1        YES manual up                    up
Loopback2              13.0.2.1        YES manual up                    up
Loopback3              13.0.3.1        YES manual up                    up

from router 4

Router>enable
Router#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up

Serial3/2              3.3.3.2         YES manual up                    up
Serial3/3              4.4.4.1         YES manual up                    up
Serial3/4              5.5.5.2         YES manual up                    up
Loopback0              14.0.0.1        YES manual up                    up
Loopback1              14.0.1.1        YES manual up                    up
Loopback2              14.0.2.1        YES manual up                    up
Loopback3              14.0.3.1        YES manual up                    up


from router 5

Router#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        50.1.1.1        YES manual up                    up
Serial3/4                   5.5.5.1         YES manual up                    up
Loopback0              15.0.0.1        YES manual up                    up
Loopback1              15.0.1.1        YES manual up                    up
Loopback2              15.0.2.1        YES manual up                    up
Loopback3              15.0.3.1        YES manual up                    up

from router 1

Router(config)#router bgp 65111
Router(config-router)#neighbor 1.1.1.2 remote-as 65123
Router(config-router)#neighbor 4.4.4.1 remote-as 65444
Router(config-router)#network 10.0.0.0
Router(config-router)#network 1.0.0.0
Router(config-router)#network 4.0.0.0
Router(config-router)#network 11.0.0.0 mask 255.255.255.0
Router(config-router)#network 11.0.1.0 mask 255.255.255.0
Router(config-router)#network 11.0.2.0 mask 255.255.255.0
Router(config-router)#network 11.0.3.0 mask 255.255.255.0
Router(config-router)#no auto-summary
Router(config-router)#no synchronization
Router(config-router)#exit

*Nov 25 22:39:28.279: %BGP-5-ADJCHANGE: neighbor 1.1.1.2 Up

*Nov 25 22:49:24.211: %BGP-5-ADJCHANGE: neighbor 4.4.4.1 Up




 from router2

Router(config)#router bgp 65123
Router(config-router)#neighbor 1.1.1.1 remote-as 65111
Router(config-router)#neighbor 2.2.2.2 remote-as 65123
Router(config-router)#neighbor 2.2.2.2 next-hop-self

Router(config-router)#network 1.0.0.0
Router(config-router)#network 2.0.0.0
Router(config-router)#network 20.0.0.0
Router(config-router)#network 12.0.0.0 mask 255.255.255.0
Router(config-router)#network 12.0.1.0 mask 255.255.255.0
Router(config-router)#network 12.0.2.0 mask 255.255.255.0
Router(config-router)#network 12.0.3.0 mask 255.255.255.0
Router(config-router)#no auto-summary
Router(config-router)#no synchronization
Router(config-router)#exit

*Nov 25 22:42:39.387: %BGP-5-ADJCHANGE: neighbor 2.2.2.2 Up

from router  3

Router(config)#router bgp 65123
Router(config-router)#neighbor 2.2.2.1 remote
Router(config-router)#neighbor 2.2.2.1 remote-as 65123
Router(config-router)#neighbor 2.2.2.1 next-hop-self
Router(config-router)#neighbor 3.3.3.2 remote-as 65444
Router(config-router)#network 30.0.0.0
Router(config-router)#network 2.0.0.0
Router(config-router)#network 3.0.0.0
Router(config-router)#network 13.0.0.0 mask 255.255.255.0
Router(config-router)#network 13.0.1.0 mask 255.255.255.0
Router(config-router)#network 13.0.2.0 mask 255.255.255.0
Router(config-router)#network 13.0.3.0 mask 255.255.255.0
Router(config-router)#no auto-summary
Router(config-router)#no synchronization
Router(config-router)#exit

 *Nov 25 22:42:39.255: %BGP-5-ADJCHANGE: neighbor 2.2.2.1 Up


from router 4

Router(config)#router bgp 65444
Router(config-router)#neighbor 3.3.3.1 remote-as 65123
Router(config-router)#neighbor 4.4.4.2 remote-as 65111
Router(config-router)#neighbor 5.5.5.1 remote-as 65555
Router(config-router)#network 40.0.0.0
Router(config-router)#network 4.0.0.0
Router(config-router)#network 3.0.0.0
Router(config-router)#network 14.0.0.0 mask 255.255.255.0
Router(config-router)#network 14.0.1.0 mask 255.255.255.0
Router(config-router)#network 14.0.2.0 mask 255.255.255.0
Router(config-router)#network 14.0.3.0 mask 255.255.255.0
Router(config-router)#no auto-summary
Router(config-router)#no synchronization
Router(config-router)#exit

 *Nov 25 22:48:38.739: %BGP-5-ADJCHANGE: neighbor 3.3.3.1 Up
*Nov 25 22:49:24.307: %BGP-5-ADJCHANGE: neighbor 4.4.4.2 Up
*Nov 25 23:12:12.911: %BGP-5-ADJCHANGE: neighbor 5.5.5.1 Up 0



from router 5

 Router(config)#router bgp 65555
Router(config-router)#neighbor 5.5.5.2 remote-as 65444
Router(config-router)#network 5.0.0.0
Router(config-router)#network 50.0.0.0
Router(config-router)#network 15.0.0.0 mask 255.255.255.0
Router(config-router)#network 15.0.1.0 mask 255.255.255.0
Router(config-router)#network 15.0.2.0 mask 255.255.255.0
Router(config-router)#network 15.0.3.0 mask 255.255.255.0
Router(config-router)#no auto-summary
Router(config-router)#no synchronization
Router(config-router)#end

 *Nov 25 23:12:12.643: %BGP-5-ADJCHANGE: neighbor 5.5.5.2 Up



from router 1
Router#show ip bgp summary
BGP router identifier 11.0.3.1, local AS number 65111
BGP table version is 31, main routing table version 31
29 network entries using 4176 bytes of memory
54 path entries using 4320 bytes of memory
8/5 BGP path/bestpath attribute entries using 1088 bytes of memory
6 BGP AS-PATH entries using 144 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 9728 total bytes of memory
BGP activity 29/0 prefixes, 59/5 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.2         4        65123     116     115       31    0    0 01:26:51       23
4.4.4.1         4        65444      96      94       31    0    0 01:16:55       24

from router 1

Router#show ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

B     2.0.0.0/8 [20/0] via 1.1.1.2, 01:25:32
B     3.0.0.0/8 [20/0] via 1.1.1.2, 01:22:06
B     5.0.0.0/8 [20/0] via 4.4.4.1, 00:53:48
      12.0.0.0/24 is subnetted, 3 subnets
B        12.0.1.0 [20/0] via 1.1.1.2, 01:25:01
B        12.0.2.0 [20/0] via 1.1.1.2, 01:25:01
B        12.0.3.0 [20/0] via 1.1.1.2, 01:25:01
      13.0.0.0/24 is subnetted, 4 subnets
B        13.0.0.0 [20/0] via 1.1.1.2, 01:22:06
B        13.0.1.0 [20/0] via 1.1.1.2, 01:22:06
B        13.0.2.0 [20/0] via 1.1.1.2, 01:22:06
B        13.0.3.0 [20/0] via 1.1.1.2, 01:21:35
      14.0.0.0/24 is subnetted, 4 subnets
B        14.0.0.0 [20/0] via 4.4.4.1, 01:13:35
B        14.0.1.0 [20/0] via 4.4.4.1, 01:10:35
B        14.0.2.0 [20/0] via 4.4.4.1, 01:10:05
B        14.0.3.0 [20/0] via 4.4.4.1, 01:10:05
      15.0.0.0/24 is subnetted, 4 subnets
B        15.0.0.0 [20/0] via 4.4.4.1, 00:54:18
B        15.0.1.0 [20/0] via 4.4.4.1, 00:54:18
B        15.0.2.0 [20/0] via 4.4.4.1, 00:54:18
B        15.0.3.0 [20/0] via 4.4.4.1, 00:54:18
B     20.0.0.0/8 [20/0] via 1.1.1.2, 01:25:32
B     30.0.0.0/8 [20/0] via 1.1.1.2, 01:22:36
B     40.0.0.0/8 [20/0] via 4.4.4.1, 01:14:05
B     50.0.0.0/8 [20/0] via 4.4.4.1, 00:54:18


 from router 2
Router#show ip bgp
BGP table version is 56, local router ID is 12.0.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  1.0.0.0          0.0.0.0                  0         32768 i
 *                    1.1.1.1                  0             0 65111 i
 * i 2.0.0.0          2.2.2.2                  0    100      0 i
 *>                   0.0.0.0                  0         32768 i
 *>i 3.0.0.0          2.2.2.2                  0    100      0 i
 * i 4.0.0.0          2.2.2.2                  0    100      0 65444 i
 *>                   1.1.1.1                  0             0 65111 i
 *   5.0.0.0          1.1.1.1                                0 65111 65444 i
 *>i                  2.2.2.2                  0    100      0 65444 i
 *>  10.0.0.0         1.1.1.1                  0             0 65111 i
 *>  11.0.0.0/24      1.1.1.1                  0             0 65111 i
 *>  11.0.1.0/24      1.1.1.1                  0             0 65111 i
 *>  11.0.2.0/24      1.1.1.1                  0             0 65111 i
 *>  11.0.3.0/24      1.1.1.1                  0             0 65111 i
     Network          Next Hop            Metric LocPrf Weight Path
 *>  12.0.1.0/24      0.0.0.0                  0         32768 i
 *>  12.0.2.0/24      0.0.0.0                  0         32768 i
 *>  12.0.3.0/24      0.0.0.0                  0         32768 i
 *>i 13.0.0.0/24      2.2.2.2                  0    100      0 i
 *>i 13.0.1.0/24      2.2.2.2                  0    100      0 i
 *>i 13.0.2.0/24      2.2.2.2                  0    100      0 i
 *>i 13.0.3.0/24      2.2.2.2                  0    100      0 i
 *   14.0.0.0/24      1.1.1.1                                0 65111 65444 i
 *>i                  2.2.2.2                  0    100      0 65444 i
 *>i 14.0.1.0/24      2.2.2.2                  0    100      0 65444 i
 *                    1.1.1.1                                0 65111 65444 i
 *   14.0.2.0/24      1.1.1.1                                0 65111 65444 i
 *>i                  2.2.2.2                  0    100      0 65444 i
 *   14.0.3.0/24      1.1.1.1                                0 65111 65444 i
 *>i                  2.2.2.2                  0    100      0 65444 i
 *   15.0.0.0/24      1.1.1.1                                0 65111 65444 65555 i
 *>i                  2.2.2.2                  0    100      0 65444 65555 i
 *   15.0.1.0/24      1.1.1.1                                0 65111 65444 65555 i
 *>i                  2.2.2.2                  0    100      0 65444 65555 i
 *   15.0.2.0/24      1.1.1.1                                0 65111 65444 65555 i
     Network          Next Hop            Metric LocPrf Weight Path
 *>i                  2.2.2.2                  0    100      0 65444 65555 i
 *   15.0.3.0/24      1.1.1.1                                0 65111 65444 65555 i
 *>i                  2.2.2.2                  0    100      0 65444 65555 i
 *>  20.0.0.0         0.0.0.0                  0         32768 i
 *>i 30.0.0.0         2.2.2.2                  0    100      0 i
 *>i 40.0.0.0         2.2.2.2                  0    100      0 65444 i
 *                    1.1.1.1                                0 65111 65444 i
 *   50.0.0.0         1.1.1.1                                0 65111 65444 65555 i
 *>i                  2.2.2.2                  0    100      0 65444 65555 i

from router 2
Router#traceroute 50.1.1.1
Type escape sequence to abort.
Tracing the route to 50.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 2.2.2.2 48 msec 36 msec 84 msec
  2 3.3.3.2 128 msec 152 msec 132 msec
  3 5.5.5.1 [AS 65444] 244 msec 172 msec *



 Our task is to changing router 2 AS 65123 path, by default router 2 take AS 65444 to reach router 5 AS 65555 because it has less ASs but our requirement is router 2 have to take AS 65111 , AS 65444 to reach 50.1.1.1 network via router 1 with use of BGP Weight attribute.

from router 2 

 Router(config)#router bgp 65123
Router(config-router)#neighbor 1.1.1.1 weight 40000
Router(config-router)#exit
Router#clear ip bgp * soft

from router 2

Router#traceroute 50.1.1.1
Type escape sequence to abort.
Tracing the route to 50.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 1.1.1.1 [AS 65111] 80 msec 0 msec 64 msec
  2 4.4.4.1 [AS 65111] 104 msec 80 msec 80 msec
  3 5.5.5.1 [AS 65444] 164 msec 112 msec *



















   






2 comments:

  1. Thank you very much for the opportunity to study for your material, I'm still studying for CCNA one more day after Parabens.

    ReplyDelete

How to configure DHCP Snooping on switch, DHCP Server on router, SVI Inter-VLAN-routing, BPDU Guard, Root-Guard, Port-fast, Dot1q and Port-channel pagp?

In this section, we are going to configure some important topics DHCP Snooping on the switch, DHCP Server on the router, SVI Inter-VLAN-rout...

INSTAGRAM FEED

@Edger C Francis