DONATE


Multilink PPP configuration



 Multilink PPP allows us to make a combination of multiple physical serial links into a single logical link or MLP bundle. MLP is used to aggregate multiple WAN links into one logical channel for the transportation of traffic from one router to another, MLP enables the load—balancing of traffic from different links as we and allows some level of redundancy in case of line failure on a single link. MLP Supports a maximum of ten member links per bundle or single logical link.


In this section, we will configure PPP Multilink using a bundle of 8 serial links with CHAP authentication. 

Topology:
TASK:  configure ppp multilink using all 8 serial interfaces with CHAP authentication.


  • configure the topology as per the diagram 
  • assign IP address to their interfaces 
  • configure single logical link, group number 1
  • configure channel ip address 192.168.1.0/24 
  • Configure EIGRP 100 for routing between router 1 and 2.

R1(config)#Interface fastethernet 0/0
R1(config-if)#Ip address 10.1.1.1   255.0.0.0
R1(config-if)#No shutdown
R1(config-if)#No keepalive
R1(config-if)#Exit

R1(config)#Interface loopback 0
R1(config-if)#Ip address 11.0.0.1 255.255.255.0
R1(config-if)#Exit


R2(config)#Interface fastethernet 0/0
R2(config-if)#Ip address 20.1.1.1   255.0.0.0
R2(config-if)#No shutdown
R2(config-if)#No keepalive
R2(config-if)#Exit

R2(config)#Interface loopback 0
R2(config-if)#Ip address 12.0.0.1 255.255.255.0
R2(config-if)#Exit

R1(config)#Interface multilink 1
R1(config-if)#Ppp multilink
R1(config-if)#Ppp multilink group 1
R1(config-if)#Ip address 192.168.1.1  255.255.255.0
R1(config-if)#No shutdown
R1(config-if)#Exit

R1(config)#Interface serial 3/0
R1(config-if)#No ip address
R1(config-if)#Encapsulation ppp
R1(config-if)#Ppp multilink
R1(config-if)#Ppp multilink  group 1
R1(config-if)#No shutdown
R1(config-if)#Exit

R1(config)#Interface serial 3/1
R1(config-if)#No ip address
R1(config-if)#Encapsulation ppp
R1(config-if)#Ppp multilink
R1(config-if)#Ppp multilink  group 1
R1(config-if)#No shutdown
R1(config-if)#Exit

R1(config)#Interface serial 3/2
R1(config-if)#No ip address
R1(config-if)#Encapsulation ppp
R1(config-if)#Ppp multilink
R1(config-if)#Ppp multilink  group 1
R1(config-if)#No shutdown
R1(config-if)#Exit

R1(config)#Interface serial 3/3
R1(config-if)#No ip address
R1(config-if)#Encapsulation ppp
R1(config-if)#Ppp multilink
R1(config-if)#Ppp multilink  group 1
R1(config-if)#No shutdown
R1(config-if)#Exit

R1(config)#Interface serial 3/4
R1(config-if)#No ip address
R1(config-if)#Encapsulation ppp
R1(config-if)#Ppp multilink
R1(config-if)#Ppp multilink  group 1
R1(config-if)#No shutdown
R1(config-if)#Exit

R1(config)#Interface serial 3/5
R1(config-if)#No ip address
R1(config-if)#Encapsulation ppp
R1(config-if)#Ppp multilink
R1(config-if)#Ppp multilink  group 1
R1(config-if)#No shutdown
R1(config-if)#Exit

R1(config)#Interface serial 3/6
R1(config-if)#No ip address
R1(config-if)#Encapsulation ppp
R1(config-if)#Ppp multilink
R1(config-if)#Ppp multilink  group 1
R1(config-if)#No shutdown
R1(config-if)#Exit

R1(config)#Interface serial 3/7
R1(config-if)#No ip address
R1(config-if)#Encapsulation ppp
R1(config-if)#Ppp multilink
R1(config-if)#Ppp multilink  group 1
R1(config-if)#No shutdown
R1(config-if)#Exit

*Nov 30 05:41:41.267: %LINK-3-UPDOWN: Interface Serial3/0, changed state to up
*Nov 30 05:41:41.471: %LINK-3-UPDOWN: Interface Serial3/1, changed state to up
*Nov 30 05:41:41.531: %LINK-3-UPDOWN: Interface Serial3/2, changed state to up
*Nov 30 05:41:41.595: %LINK-3-UPDOWN: Interface Serial3/3, changed state to up
*Nov 30 05:41:41.627: %LINK-3-UPDOWN: Interface Serial3/4, changed state to up
*Nov 30 05:41:41.687: %LINK-3-UPDOWN: Interface Serial3/5, changed state to up
*Nov 30 05:41:41.719: %LINK-3-UPDOWN: Interface Serial3/6, changed state to up
*Nov 30 05:41:41.783: %LINK-3-UPDOWN: Interface Serial3/7, changed state to up

*Nov 30 05:42:05.115: %LINEPROTO-5-UPDOWN: Line protocol on Interface Multilink1, changed state to up

R2(config)#Interface multilink 1
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink group 1
R2(config-if)#Ip address 192.168.1.2  255.255.255.0
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/0
R2(config-if)#No ip address
R2(config-if)#Encapsulation ppp
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink  group 1
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/1
R2(config-if)#No ip address
R2(config-if)#Encapsulation ppp
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink  group 1
R2(config-if)# No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/2
R2(config-if)#No ip address
R2(config-if)#Encapsulation ppp
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink  group 1
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/3
R2(config-if)#No ip address
R2(config-if)#Encapsulation ppp
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink  group 1
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/4
R2(config-if)#No ip address
R2(config-if)#Encapsulation ppp
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink  group 1
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/5
R2(config-if)#No ip address
R2(config-if)#Encapsulation ppp
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink  group 1
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/6
R2(config-if)#No ip address
R2(config-if)#Encapsulation ppp
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink  group 1
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/7
R2(config-if)#No ip address
R2(config-if)#Encapsulation ppp
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink  group 1
R2(config-if)#No shutdown
R2(config-if)#Exit

*Nov 30 05:46:40.163: %LINEPROTO-5-UPDOWN: Line protocol on Interface Multilink1, changed state to up

R1#show ip interface brief
Interface              IP-Address      OK? Method Status         Protocol
FastEthernet0/0        10.1.1.1        YES manual up                up
Serial3/0              unassigned      YES unset  up                    up
Serial3/1              unassigned      YES unset  up                    up
Serial3/2              unassigned      YES unset  up                    up
Serial3/3              unassigned      YES unset  up                    up
Serial3/4              unassigned      YES unset  up                    up
Serial3/5              unassigned      YES unset  up                    up
Serial3/6              unassigned      YES unset  up                    up
Serial3/7              unassigned      YES unset  up                    up
Loopback0              11.0.0.1        YES manual up                 up
Multilink1             192.168.1.1     YES manual up                up



R2#show ip interface brief
Interface              IP-Address      OK? Method Status         Protocol
FastEthernet0/0        20.1.1.1        YES manual up               up

Serial3/0              unassigned      YES unset  up                    up
Serial3/1              unassigned      YES unset  up                    up
Serial3/2              unassigned      YES unset  up                    up
Serial3/3              unassigned      YES unset  up                    up
Serial3/4              unassigned      YES unset  up                    up
Serial3/5              unassigned      YES unset  up                    up
Serial3/6              unassigned      YES unset  up                    up
Serial3/7              unassigned      YES unset  up                    up
Loopback0              12.0.0.1        YES manual up                 up
Multilink1             192.168.1.2     YES manual up                up

R1(config)#Username R2 password cisco
R1(config)#Interface multilink 1
R1(config-if)#Encapsulation ppp
R1(config-if)#Ppp authentication chap
R1(config-if)#Exit

R2(config)#Username R1 password cisco
R2(config)#Interface multilink 1
R2(config-if)#Encapsulation ppp
R2(config-if)#Ppp authentication chap
R2(config-if)#Exit

R1(config)#router eigrp 100
R1(config-router)#network 192.168.1.0
R1(config-router)#network 10.0.0.0
R1(config-router)#network 11.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#end

*Nov 30 05:59:32.735: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.1.2 (Multilink1) is up: new adjacency


R2(config)#router eigrp 100
R2(config-router)#network 192.168.1.0
R2(config-router)#network 20.0.0.0
R2(config-router)#network 12.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#end

*Nov 30 05:59:33.079: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.1.1 (Multilink1) is up: new adjacency


R1#ping 12.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/27/32 ms

R1#ping 20.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/30/36 ms




R2#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/26/32 ms

R2#ping 11.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

R1#show interfaces multilink 1
Multilink1 is up, line protocol is up
  Hardware is multilink group interface
  Internet address is 192.168.1.1/24
  MTU 1500 bytes, BW 12352 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Open

R2#show interfaces multilink 1
Multilink1 is up, line protocol is up
  Hardware is multilink group interface
  Internet address is 192.168.1.2/24
  MTU 1500 bytes, BW 12352 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Open

R1#show ppp mul
R1#show ppp multilink

Multilink1
  Bundle name: R2
  Remote Username: R2
  Remote Endpoint Discriminator: [1] R2
  Local Username: R1
  Local Endpoint Discriminator: [1] R1
  Bundle up for 00:11:17, total bandwidth 12352, load 1/255
  Receive buffer limit 96000 bytes, frag timeout 1000 ms
    0/0 fragments/bytes in reassembly list
    0 lost fragments, 88 reordered
    0/0 discarded fragments/bytes, 0 lost received
    0x126 received sequence, 0x12E sent sequence
  Member links: 8 active, 0 inactive (max 255, min not set)
    Se3/1, since 00:11:17
    Se3/2, since 00:11:17
    Se3/0, since 00:11:16
    Se3/6, since 00:11:15
    Se3/3, since 00:11:15
    Se3/4, since 00:11:15
    Se3/5, since 00:11:15
    Se3/7, since 00:11:14

R2#show ppp multilink

\
Multilink1
  Bundle name: R1
  Remote Username: R1
  Remote Endpoint Discriminator: [1] R1
  Local Username: R2
  Local Endpoint Discriminator: [1] R2
  Bundle up for 00:11:57, total bandwidth 12352, load 1/255
  Receive buffer limit 96000 bytes, frag timeout 1000 ms
    0/0 fragments/bytes in reassembly list
    0 lost fragments, 82 reordered
    0/0 discarded fragments/bytes, 0 lost received
    0x136 received sequence, 0x136 sent sequence
  Member links: 8 active, 0 inactive (max 255, min not set)
    Se3/1, since 00:11:57
    Se3/2, since 00:11:57
    Se3/0, since 00:11:56
    Se3/6, since 00:11:56
    Se3/3, since 00:11:55
    Se3/4, since 00:11:55
    Se3/5, since 00:11:55
    Se3/7, since 00:11:55









No comments:

Post a Comment

How to configure DHCP Snooping on switch, DHCP Server on router, SVI Inter-VLAN-routing, BPDU Guard, Root-Guard, Port-fast, Dot1q and Port-channel pagp?

In this section, we are going to configure some important topics DHCP Snooping on the switch, DHCP Server on the router, SVI Inter-VLAN-rout...

INSTAGRAM FEED

@Edger C Francis