DONATE


EIGRP Default route


The default route is used by IP to forward any packet with a destination not found in the routing table, which is why it is also called a gateway of last resort. Also, can be used at an end location where there is only one exit path for any destination (internet).



We can also use the default routes for better network performance. How? For example, our routers on the access layer do not need to know all our routes in our Autonomous system. When we use a default route, we can significantly reduce the size of our router routing table and surely improve our network performance on the access layer. 

Default routes help in reducing the size of your routing table. It’s the least preferred route in the routing table.


Let's see the configuration:

Topology: 

EIGRP DEFAULT ROUTE CONFIGURATION
EIGRP DEFAULT ROUTE CONFIGURATION 

                                                                                                                                        
TASK. 
  • Configure the topology as per our diagram. 
  • Assign IP address as per the topology.
  • configure EIGRP AS 100 and advertise interfaces.
  • We have two methods of advertising default route 
  1. Default-network ****
  2. Redistribution static

  • In this scenario we use redistribution static method  
  • Configure static route on router 5 toward router 2
  • ensure router 5 able to ping all network and all the routers able to ping our 15.*** network                      




R1(config)#Interface fastethernet 0/0
R1(config-if)#Ip address 10.1.1.1   255.0.0.0
R1(config-if)#No shutdown
R1(config-if)#No keepalive
R1(config-if)#Exit

R1(config)#Interface serial 3/0
R1(config-if)#Ip address  1.1.1.1 255.0.0.0
R1(config-if)#No shutdown
R1(config-if)#Exit

R2(config)#Interface fastethernet 0/0
R2(config-if)#Ip address 20.1.1.1   255.0.0.0
R2(config-if)#No shutdown
R2(config-if)#No keepalive
R2(config-if)#Exit

R2(config)#Interface serial 3/0
R2(config-if)#Ip address  1.1.1.2 255.0.0.0
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/1
R2(config-if)#Ip address  4.4.4.2 255.0.0.0
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/2
R2(config-if)#Ip address  3.3.3.2 255.0.0.0
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#interface serial 3/3
R2(config-if)#ip address 5.5.5.2 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit


R3(config)#Interface fastethernet 0/0
R3(config-if)#Ip address 30.1.1.1   255.0.0.0
R3(config-if)#No shutdown
R3(config-if)#No keepalive
R3(config-if)#Exit

R3(config)#Interface serial 3/2
R3(config-if)#Ip address  3.3.3.1 255.0.0.0
R3(config-if)#No shutdown
R3(config-if)#Exit

R4(config)#Interface fastethernet 0/0
R4(config-if)#Ip address 40.1.1.1   255.0.0.0
R4(config-if)#No shutdown
R4(config-if)#No keepalive
R4(config-if)#Exit

R4(config)#Interface serial 3/1
R4(config-if)#Ip address  4.4.4.1 255.0.0.0
R4(config-if)#No shutdown
R4(config-if)#Exit

R5(config)#Interface fastethernet 0/0
R5(config-if)#Ip address 50.1.1.1   255.0.0.0
R5(config-if)#No shutdown
R5(config-if)#No keepalive
R5(config-if)#Exit

R5(config)#Interface serial 3/3
R5(config-if)#Ip address  5.5.5.1 255.0.0.0
R5(config-if)#No shutdown
R5(config-if)#Exit

R5(config)#Interface loopback  1
R5(config-if)#Ip address 15.0.1.1 255.255.255.0
R5(config-if)#Exit

R5(config)#Interface loopback  2
R5(config-if)#Ip address 15.0.2.1 255.255.255.0
R5(config-if)#Exit

R5(config)#Interface loopback 3
R5(config-if)#Ip address 15.0.3.1 255.255.255.0
R5(config-if)#Exit



R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0                    1.1.1.1         YES manual up                    up

R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                    1.1.1.2         YES manual up                    up
Serial3/1                    4.4.4.2         YES manual up                    up
Serial3/2                    3.3.3.2         YES manual up                    up
Serial3/3                    5.5.5.2         YES manual up                    up



R3#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/2                    3.3.3.1         YES manual up                    up


R4#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up
Serial3/1                    4.4.4.1         YES manual up                    up



R5#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        50.1.1.1        YES manual up                    up
Serial3/3                    5.5.5.1         YES manual up                    down

Loopback1              15.0.1.1        YES manual up                    up
Loopback2              15.0.2.1        YES manual up                    up
Loopback3              15.0.3.1        YES manual up                    up

R1(config)#router eigrp 100
R1(config-router)#network 10.0.0.0
R1(config-router)#network 1.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#exit

*Dec  4 05:15:11.879: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 1.1.1.2 (Serial3/0) is up: new adjacency

R2(config)#router eigrp 100
R2(config-router)#network 20.0.0.0
R2(config-router)#network 1.0.0.0
R2(config-router)#network 4.0.0.0
R2(config-router)#network 3.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#exit

*Dec  4 05:16:09.051: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 3.3.3.1 (Serial3/2) is up: new adjacency

*Dec  4 05:15:11.975: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 1.1.1.1 (Serial3/0) is up: new adjacency

*Dec  4 05:16:44.895: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 4.4.4.1 (Serial3/1) is up: new adjacency


R2(config)#router eigrp 100
R2(config-router)#redistribute static
R2(config-router)#exit

R2(config)#ip route 0.0.0.0 0.0.0.0 5.5.5.1
R2(config)#end

R3(config)#router eigrp 100
R3(config-router)#network 30.0.0.0
R3(config-router)#network 3.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#exit

*Dec  4 05:16:09.127: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 3.3.3.2 (Serial3/2) is up: new adjacency


R4(config)#router eigrp 100
R4(config-router)#network 40.0.0.0
R4(config-router)#network 4.0.0.0
R4(config-router)#no auto-summary
R4(config-router)#exit
R4(config)#end

*Dec  4 05:16:44.807: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 4.4.4.2 (Serial3/1) is up: new adjacency

R5(config)#ip route 4.0.0.0 255.0.0.0  5.5.5.2
R5(config)#ip route 3.0.0.0 255.0.0.0  5.5.5.2
R5(config)#ip route 20.0.0.0 255.0.0.0  5.5.5.2
R5(config)#ip route 30.0.0.0 255.0.0.0  5.5.5.2
R5(config)#ip route 40.0.0.0 255.0.0.0  5.5.5.2
R5(config)#ip route 10.0.0.0 255.0.0.0  5.5.5.2
R5(config)#ip route 1.0.0.0 255.0.0.0  5.5.5.2
R5(config)#end

R2#clear ip eigrp 100 neighbors



R1#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 1.1.1.2 to network 0.0.0.0

D*EX  0.0.0.0/0 [170/2681856] via 1.1.1.2, 00:00:53, Serial3/0
D     3.0.0.0/8 [90/2681856] via 1.1.1.2, 00:00:53, Serial3/0
D     4.0.0.0/8 [90/2681856] via 1.1.1.2, 00:00:53, Serial3/0
D     20.0.0.0/8 [90/2172416] via 1.1.1.2, 00:00:53, Serial3/0
D     30.0.0.0/8 [90/2684416] via 1.1.1.2, 00:00:53, Serial3/0
D     40.0.0.0/8 [90/2684416] via 1.1.1.2, 00:00:53, Serial3/0

R2#show ip pro
*** IP Routing is NSF aware ***

Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  Redistributing: static
  EIGRP-IPv4 Protocol for AS(100)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 20.1.1.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    1.0.0.0
    3.0.0.0
    4.0.0.0
    20.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    1.1.1.1               90      00:01:45
    3.3.3.1               90      00:01:45
    4.4.4.1               90      00:01:45
  Distance: internal 90 external 170



R3#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 3.3.3.2 to network 0.0.0.0

D*EX  0.0.0.0/0 [170/2681856] via 3.3.3.2, 00:02:27, Serial3/2
D     1.0.0.0/8 [90/2681856] via 3.3.3.2, 00:02:27, Serial3/2
D     4.0.0.0/8 [90/2681856] via 3.3.3.2, 00:02:27, Serial3/2
D     10.0.0.0/8 [90/2684416] via 3.3.3.2, 00:02:24, Serial3/2
D     20.0.0.0/8 [90/2172416] via 3.3.3.2, 00:02:27, Serial3/2
D     40.0.0.0/8 [90/2684416] via 3.3.3.2, 00:02:27, Serial3/2



R4#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 4.4.4.2 to network 0.0.0.0

D*EX  0.0.0.0/0 [170/2681856] via 4.4.4.2, 00:02:52, Serial3/1
D     1.0.0.0/8 [90/2681856] via 4.4.4.2, 00:02:52, Serial3/1
D     3.0.0.0/8 [90/2681856] via 4.4.4.2, 00:02:52, Serial3/1
D     10.0.0.0/8 [90/2684416] via 4.4.4.2, 00:02:49, Serial3/1
D     20.0.0.0/8 [90/2172416] via 4.4.4.2, 00:02:52, Serial3/1
D     30.0.0.0/8 [90/2684416] via 4.4.4.2, 00:02:52, Serial3/1



R5#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

S     1.0.0.0/8 [1/0] via 5.5.5.2
S     3.0.0.0/8 [1/0] via 5.5.5.2
S     4.0.0.0/8 [1/0] via 5.5.5.2
      5.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        5.0.0.0/8 is directly connected, Serial3/3
L        5.5.5.1/32 is directly connected, Serial3/3
S     10.0.0.0/8 [1/0] via 5.5.5.2
      15.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C        15.0.1.0/24 is directly connected, Loopback1
L        15.0.1.1/32 is directly connected, Loopback1
C        15.0.2.0/24 is directly connected, Loopback2
L        15.0.2.1/32 is directly connected, Loopback2
C        15.0.3.0/24 is directly connected, Loopback3
L        15.0.3.1/32 is directly connected, Loopback3
S     20.0.0.0/8 [1/0] via 5.5.5.2
S     30.0.0.0/8 [1/0] via 5.5.5.2
S     40.0.0.0/8 [1/0] via 5.5.5.2
      50.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        50.0.0.0/8 is directly connected, FastEthernet0/0
L        50.1.1.1/32 is directly connected, FastEthernet0/0


R1#traceroute 50.1.1.1
Type escape sequence to abort.
Tracing the route to 50.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 1.1.1.2 60 msec 72 msec 104 msec
  2 5.5.5.1 160 msec 164 msec 92 msec

R1#ping 15.0.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 15.0.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 92/117/144 ms




R3#ping 50.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 50.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 116/134/148 ms

R3#traceroute 15.0.1.1
Type escape sequence to abort.
Tracing the route to 15.0.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 3.3.3.2 40 msec 72 msec 40 msec
  2 5.5.5.1 156 msec 116 msec 96 msec


R4#ping 50.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 50.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/121/156 ms


R5#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 120/129/148 ms

R5#ping 20.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/48/84 ms

R5#ping 30.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 148/177/208 ms

R5#ping 40.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/76/96 ms















No comments:

Post a Comment

How to configure DHCP Snooping on switch, DHCP Server on router, SVI Inter-VLAN-routing, BPDU Guard, Root-Guard, Port-fast, Dot1q and Port-channel pagp?

In this section, we are going to configure some important topics DHCP Snooping on the switch, DHCP Server on the router, SVI Inter-VLAN-rout...

INSTAGRAM FEED

@Edger C Francis