DONATE


Frame-relay configuration


Frame-relay is one of the WAN protocols you need to understand if you plan to become CCNA certified. It’s also one of the most difficult protocols to understand for most CCNA students.



Frame-Relay was a very popular WAN technology in the past days. It still is today to some extent. However, it is safe to say that it is being replacing by competing technologies like Ethernet WAN, Multi-Protocol Label Switching (MPLS), and Virtual Private Network (VPN).

Frame relay uses service provider to provide connectivity. Frame relay is cost effective solution for leased line.

Virtual circuit is connection in frame relay is providing virtual circuits.  Multiple logical connections on same physical connection.

Data link connection identifier (DLCI ) identify virtual circuits range (16- 1007) given by service provider. Local DLCI map with remote IP address.  Manual or auto mapping ( inverse ARP).

 local management interface (LMI) its use to send keepalive message used between router and frame relay switch for checking the connectivity.

Fame relay network types
  • Point to point
  • Point to multi-point



Topology 




TASK; configure point to point frame relay , make sure router 1 make ping to router 2.


R1(config)#interface serial 3/0
R1(config-if)#no shutdown
R1(config-if)#ip address 1.1.1.1 255.0.0.0
R1(config-if)#encapsulation frame-relay
R1(config-if)#end

*Dec  1 19:13:09.207: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to down

R1#show run interface s3/0
Building configuration...

Current configuration : 108 bytes
!
interface Serial3/0
 ip address 1.1.1.1 255.0.0.0
 encapsulation frame-relay
 serial restart-delay 0
end

R1#ping 1.1.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)




R3(config)#interface serial 3/1
R3(config-if)#no shutdown
R3(config-if)#ip address 1.1.1.2 255.0.0.0
R3(config-if)#encapsulation frame-relay
R3(config-if)#end

*Dec  1 19:14:34.723: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/1, changed state to down

R3#show ip interface br
Interface              IP-Address      OK? Method Status           Protocol
Serial3/1              1.1.1.2         YES manual up                    down

R3#show run interface serial 3/1
Building configuration...

Current configuration : 108 bytes
!
interface Serial3/1
 ip address 1.1.1.2 255.0.0.0
 encapsulation frame-relay
 serial restart-delay 0
end

R3#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)


*Dec  1 19:22:14.723: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/1, changed state to up


R2(config)#hostname FRSW

FRSW(config)#frame-relay switching
FRSW(config)#interface serial 3/0
FRSW(config-if)#no shutdown
FRSW(config-if)#encapsulation frame-relay


*Dec  1 19:18:48.259: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up

FRSW(config-if)#encapsulation frame-relay
FRSW(config-if)#frame-relay intf-type dce
FRSW(config-if)#frame-relay lmi-type ?
  cisco
  ansi
  q933a

FRSW(config-if)#frame-relay lmi-type cisco
FRSW(config-if)#frame-relay route 100 interface serial 3/1 200
FRSW(config-if)#exit

FRSW(config)#interface serial 3/1
FRSW(config-if)#no shutdown
FRSW(config-if)#encapsulation frame-relay
FRSW(config-if)#frame-relay intf-type dce
FRSW(config-if)#frame-relay lmi-type cisco
FRSW(config-if)#frame-relay route 200 interface serial 3/0 100
FRSW(config-if)#end


FRSW#show frame-relay route
Input Intf      Input Dlci      Output Intf     Output Dlci     Status
Serial3/0       100             Serial3/1       200             active
Serial3/1       200             Serial3/0       100             active

FRSW#show frame-relay lmi

LMI Statistics for interface Serial3/0 (Frame Relay DCE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Rcvd 27               Num Status msgs Sent 25
  Num Update Status Sent 0              Num St Enq. Timeouts 0

LMI Statistics for interface Serial3/1 (Frame Relay DCE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Rcvd 11               Num Status msgs Sent 10
  Num Update Status Sent 0              Num St Enq. Timeouts 0

R1#ping 1.1.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/59/92 ms

R3#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/47/60 ms


No comments:

Post a Comment

Cisco’s IOS

Cisco’s IOS The Cisco inter network operating system (IOS) is the kernel of Cisco routers as well as all current catalyst switches. A ke...

INSTAGRAM FEED

@Edger C Francis