DONATE


BGP Communities mock lab CCIE

BGP Communities

The community attribute is a transitive optional attribute. Communities can be used to mark a set of prefixes that share a common property. Any BGP router can tag routes in incoming and outgoing routing updates or when doing redistribution.By default, communities are stripped in outgoing BGP updates.

BGP community types:-

Well known (pre-defined
Own communities

Well-known communities (predefined)

  • Internet: advertise this route to the Internet community, any route belonging to this community
  • No-export: do not advertise to EBGP peers; keep this route an AS only.
  • No-advertise: do not advertise this route to any peer, internal or external.
  • Local-AS: used in confederation scenarios, to prevent the transmission of packets outside the local sub-AS.  Local-AS is a well-known BGP community and it's used in confederation scenarios to prevent the transmission of traffic outside the local-as. 
In this lab we are going to configure two BGP communities No-advertise and Local-AS, we split this lab in two parts. you can configure both communities in a small lab.

topology:-  No advertise community 



 

Goal: prevent 192.168.4.1/24 network from advertising in any AS with the help of the No-advertise community.
  • configure the topology as per the diagram 
  • configure the IP addresses as per the topology
  • configure IBGP and EBGP advertise directly connected interfaces 
  • configure No-advertise on router 5. Ensure the 192.168.4.1/25 network ensures router 2 does not advertise to any iBGP and EBGP neighbor.
  • configure access-list 
  • configure route-map
  • apply route-map to BGP neighbor router-2


R1-65123(config)#interface serial 6/0
R1-65123(config-if)#ip address 19.1.1.1 255.0.0.0
R1-65123(config-if)#no shutdown
R1-65123(config-if)#exit

R1-65123(config)#interface serial 5/0
R1-65123(config-if)#ip address 12.1.1.1 255.0.0.0
R1-65123(config-if)#no shutdown
R1-65123(config-if)#exit
R1-65123(config)#interface serial 5/1
R1-65123(config-if)#ip address 13.1.1.1 255.0.0.0
R1-65123(config-if)#no shutdown
R1-65123(config-if)#exit

R1-65123(config)#interface loopback 1
R1-65123(config-if)#ip address 192.168.1.1 255.255.255.0
R1-65123(config-if)#no shutdown
R1-65123(config-if)#exit

R1-65123(config)#interface fastethernet 0/0
R1-65123(config-if)#ip address 10.1.1.1 255.0.0.0
R1-65123(config-if)#no shutdown
R1-65123(config-if)#no keepalive
R1-65123(config-if)#exit
 

router-1 show ip interface brief

 
R2-65123(config)#interface serial 5/2
R2-65123(config-if)#ip address 25.1.1.1 255.0.0.0
R2-65123(config-if)#no shutdown
R2-65123(config-if)#exit
R2-65123(config)#interface serial 5/0
R2-65123(config-if)#ip address 12.1.1.2 255.0.0.0
R2-65123(config-if)#no shutdown
R2-65123(config-if)#exit
R2-65123(config)#interface serial 5/1
R2-65123(config-if)#ip address 24.1.1.1 255.0.0.0
R2-65123(config-if)#no shutdown
R2-65123(config-if)#exit

R2-65123(config)#interface loopback 1
R2-65123(config-if)#ip address 192.168.2.1 255.255.255.0
R2-65123(config-if)#no shutdown
R2-65123(config-if)#exit

R2-65123(config)#interface fastethernet 0/0
R2-65123(config-if)#ip address 20.1.1.1 255.0.0.0
R2-65123(config-if)#no shutdown
R2-65123(config-if)#no keepalive
R2-65123(config-if)#exit
 

router-1 show IP interface brief



 
R3-65123(config)#interface serial 5/3
R3-65123(config-if)#ip address 35.1.1.1 255.0.0.0
R3-65123(config-if)#no shutdown
R3-65123(config-if)#exit
R3-65123(config)#interface serial 5/0
R3-65123(config-if)#ip address 36.1.1.1 255.0.0.0
R3-65123(config-if)#no shutdown
R3-65123(config-if)#exit
R3-65123(config)#interface serial 5/1
R3-65123(config-if)#ip address 13.1.1.2 255.0.0.0
R3-65123(config-if)#no shutdown
R3-65123(config-if)#exit

R3-65123(config)#interface loopback 1
R3-65123(config-if)#ip address 192.168.3.1 255.255.255.0
R3-65123(config-if)#no shutdown
R3-65123(config-if)#exit

R3-65123(config)#interface fastethernet 0/0
R3-65123(config-if)#ip address 30.1.1.1 255.0.0.0
R3-65123(config-if)#no shutdown
R3-65123(config-if)#no keepalive
R3-65123(config-if)#exit
 
router-3 show IP interface brief



 
R4-6544(config)#interface serial 5/1
R4-6544(config-if)#ip address 24.1.1.2 255.0.0.0
R4-6544(config-if)#no shutdown
R4-6544(config-if)#exit

R4-6544(config)#interface loopback 1
R4-6544(config-if)#ip address 192.168.4.1 255.255.255.0
R4-6544(config-if)#no shutdown
R4-6544(config-if)#exit

R4-6544(config)#interface fastethernet 0/0
R4-6544(config-if)#ip address 40.1.1.1 255.0.0.0
R4-6544(config-if)#no shutdown
R4-6544(config-if)#no keepalive
R4-6544(config-if)#exit
 

show IP interface brief


 
R5-6555(config)#interface serial 5/2
R5-6555(config-if)#ip address 25.1.1.2 255.0.0.0
R5-6555(config-if)#no shutdown
R5-6555(config-if)#exit
R5-6555(config)#interface serial 5/3
R5-6555(config-if)#ip address 35.1.1.2 255.0.0.0
R5-6555(config-if)#no shutdown
R5-6555(config-if)#exit

R5-6555(config)#interface loopback 1
R5-6555(config-if)#ip address 192.168.5.1 255.255.255.0
R5-6555(config-if)#exit

R5-6555(config)#interface fastethernet 0/0
R5-6555(config-if)#ip address 50.1.1.1 255.0.0.0
R5-6555(config-if)#no shutdown
R5-6555(config-if)#no keepalive
R5-6555(config-if)#exit
 
router-5 show IP interface brief

 


R6-6566(config)#interface serial 5/0
R6-6566(config-if)#ip address 36.1.1.2 255.0.0.0
R6-6566(config-if)#no shutdown
R6-6566(config-if)#exit

R6-6566(config)#interface loopback 1
R6-6566(config-if)#ip address 192.168.6.1 255.255.255.0
R6-6566(config-if)#exit

R6-6566(config)#interface fastethernet 0/0
R6-6566(config-if)#ip address 60.1.1.1 255.0.0.0
R6-6566(config-if)#no shutdown
R6-6566(config-if)#no keepalive
R6-6566(config-if)#exit
 
 
router-6 show IP interface brief


R1-65123(config)#router bgp 65123
R1-65123(config-router)#neighbor 12.1.1.2 remote-as 65123
R1-65123(config-router)#neighbor 13.1.1.2 remote-as 65123
R1-65123(config-router)#neighbor 12.1.1.2 next-hop-self
R1-65123(config-router)#neighbor 13.1.1.2 next-hop-self
R1-65123(config-router)#neighbor 19.1.1.2 remote-as 65109
R1-65123(config-router)#network 12.0.0.0 mask 255.0.0.0
R1-65123(config-router)#network 13.0.0.0 mask 255.0.0.0
R1-65123(config-router)#network 19.0.0.0 mask 255.0.0.0
R1-65123(config-router)#network 10.0.0.0 mask 255.0.0.0
R1-65123(config-router)#network 192.168.1.0 mask 255.255.255.0
R1-65123(config-router)#no auto-summary
R1-65123(config-router)#no syn
R1-65123(config-router)#exit
 
*Nov  9 11:53:13.895: %BGP-5-ADJCHANGE: neighbor 12.1.1.2 Up
*Nov  9 11:53:15.011: %BGP-5-ADJCHANGE: neighbor 13.1.1.2 Up

 

router-1
show IP bgp summary
show IP bgp



R2-65123(config)#router bgp 65123
R2-65123(config-router)#neighbor 12.1.1.1 remote-as 65123
R2-65123(config-router)#neighbor 24.1.1.2 remote-as 6544
R2-65123(config-router)#neighbor 25.1.1.2 remote-as 6555
R2-65123(config-router)#neighbor 13.1.1.2 remote-as 65123
R2-65123(config-router)#neighbor 12.1.1.1 next-hop-self
R2-65123(config-router)#network 12.0.0.0 mask 255.0.0.0
R2-65123(config-router)#network 24.0.0.0 mask 255.0.0.0
R2-65123(config-router)#network 25.0.0.0 mask 255.0.0.0
R2-65123(config-router)#network 20.0.0.0 mask 255.0.0.0
R2-65123(config-router)#network 192.168.2.0 mask 255.255.255.0
R2-65123(config-router)#no auto-summary
R2-65123(config-router)#no syn
R2-65123(config-router)#exit
 
*Nov  9 11:52:23.863: %BGP-5-ADJCHANGE: neighbor 12.1.1.1 Up
*Nov  9 12:10:45.367: %BGP-5-ADJCHANGE: neighbor 24.1.1.2 Up
*Nov  9 12:10:58.299: %BGP-5-ADJCHANGE: neighbor 25.1.1.2 Up


router-2 
show IP bgp summary
show IP bgp


R3-65123(config)#router bgp 65123
R3-65123(config-router)#neighbor 13.1.1.1 remote-as 65123
R3-65123(config-router)#neighbor 35.1.1.2 remote-as 6555
R3-65123(config-router)#neighbor 36.1.1.2 remote-as 6566
R3-65123(config-router)#neighbor 12.1.1.2 remote-as 65123
R3-65123(config-router)#neighbor 13.1.1.1 next-hop-self
R3-65123(config-router)#network 13.0.0.0 mask 255.0.0.0
R3-65123(config-router)#network 35.0.0.0 mask 255.0.0.0
R3-65123(config-router)#network 36.0.0.0 mask 255.0.0.0
R3-65123(config-router)#network 30.0.0.0 mask 255.0.0.0
R3-65123(config-router)#network 192.168.3.0 mask 255.255.255.0
R3-65123(config-router)#no auto-summary
R3-65123(config-router)#no syn
R3-65123(config-router)#exit

*Nov  9 11:51:44.679: %BGP-5-ADJCHANGE: neighbor 13.1.1.1 Up
*Nov  9 12:01:27.323: %BGP-5-ADJCHANGE: neighbor 12.1.1.2 Up
*Nov  9 12:10:28.947: %BGP-5-ADJCHANGE: neighbor 35.1.1.2 Up
*Nov  9 12:10:41.955: %BGP-5-ADJCHANGE: neighbor 36.1.1.2 Up

 

router-3 
show IP bgp summary
show IP bgp


R4-6544(config)#router bgp 6544
R4-6544(config-router)#neighbor 24.1.1.1 remote-as 65123
R4-6544(config-router)#network 24.0.0.0 mask 255.0.0.0
R4-6544(config-router)#network 40.0.0.0 mask 255.0.0.0
R4-6544(config-router)#network 192.168.4.0 mask 255.255.255.0
R4-6544(config-router)#no auto-summary
R4-6544(config-router)#no syn
R4-6544(config-router)#exit

*Nov  9 12:06:25.423: %BGP-5-ADJCHANGE: neighbor 24.1.1.1 Up
 

router-4
show IP bgp summary
show IP bgp



R5-6555(config)#router bgp 6555
R5-6555(config-router)#neighbor 25.1.1.1 remote-as 65123
R5-6555(config-router)#neighbor 35.1.1.1 remote-as 65123
R5-6555(config-router)#network 25.0.0.0 mask 255.0.0.0
R5-6555(config-router)#network 55.0.0.0 mask 255.0.0.0
R5-6555(config-router)#network 50.0.0.0 mask 255.0.0.0
R5-6555(config-router)#network 192.168.5.0 mask 255.255.255.0
R5-6555(config-router)#no auto-summary
R5-6555(config-router)#no syn
R5-6555(config-router)#exit

*Nov  9 12:05:55.127: %BGP-5-ADJCHANGE: neighbor 25.1.1.1 Up
*Nov  9 12:06:08.771: %BGP-5-ADJCHANGE: neighbor 35.1.1.1 Up


R5-6555#show ip bgp summary
BGP router identifier 192.168.5.1, local AS number 6555
BGP table version is 20, main routing table version 20
18 network entries using 2106 bytes of memory
35 path entries using 1820 bytes of memory
6/5 BGP path/bestpath attribute entries using 744 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 4742 total bytes of memory
BGP activity 18/0 prefixes, 35/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
25.1.1.1        4 65123      54      54       20    0    0 00:45:37       16
35.1.1.1        4 65123      54      54       20    0    0 00:45:23       16

R5-6555#show ip bgp
BGP table version is 20, local router ID is 192.168.5.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.0.0.0         25.1.1.1                               0 65123 i
*                   35.1.1.1                               0 65123 i
*> 12.0.0.0         25.1.1.1                 0             0 65123 i
*                   35.1.1.1                               0 65123 i
*> 13.0.0.0         25.1.1.1                               0 65123 i
*                   35.1.1.1                 0             0 65123 i
*> 20.0.0.0         25.1.1.1                 0             0 65123 i
*                   35.1.1.1                               0 65123 i
*> 24.0.0.0         25.1.1.1                 0             0 65123 i
*                   35.1.1.1                               0 65123 i
*  25.0.0.0         25.1.1.1                 0             0 65123 i
*                   35.1.1.1                               0 65123 i
*>                  0.0.0.0                  0         32768 i
*> 30.0.0.0         25.1.1.1                               0 65123 i
*                   35.1.1.1                 0             0 65123 i
r> 35.0.0.0         25.1.1.1                               0 65123 i
r                   35.1.1.1                 0             0 65123 i
*> 36.0.0.0         25.1.1.1                               0 65123 i
*                   35.1.1.1                 0             0 65123 i
*> 40.0.0.0         25.1.1.1                               0 65123 6544 i
*                   35.1.1.1                               0 65123 6544 i
*> 50.0.0.0         0.0.0.0                  0         32768 i
*  60.0.0.0         35.1.1.1                               0 65123 6566 i
*>                  25.1.1.1                               0 65123 6566 i
*> 192.168.1.0      25.1.1.1                               0 65123 i
*                   35.1.1.1                               0 65123 i
*> 192.168.2.0      25.1.1.1                 0             0 65123 i
*                   35.1.1.1                               0 65123 i
*> 192.168.3.0      25.1.1.1                               0 65123 i
*                   35.1.1.1                 0             0 65123 i
*> 192.168.4.0      25.1.1.1                               0 65123 6544 i
*                   35.1.1.1                               0 65123 6544 i
*> 192.168.5.0      0.0.0.0                  0         32768 i
*  192.168.6.0      35.1.1.1                               0 65123 6566 i
*>                  25.1.1.1                               0 65123 6566 i

 
R6-6566(config)#router bgp 6566
R6-6566(config-router)#neighbor 36.1.1.1 remote-as 65123
R6-6566(config-router)#network 36.0.0.0 mask 255.0.0.0
R6-6566(config-router)#network 60.0.0.0 mask 255.0.0.0
R6-6566(config-router)#network 192.168.6.0 mask 255.255.255.0
R6-6566(config-router)#no auto-summary
R6-6566(config-router)#no syn
R6-6566(config-router)#exit

*Nov  9 12:05:51.835: %BGP-5-ADJCHANGE: neighbor 36.1.1.1 Up

router-6
show IP bgp summary
show IP bgp


R1-65123#ping 192.168.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/47/88 ms
R1-65123#ping 192.168.3.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/34/44 ms
R1-65123#ping 192.168.4.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/70/96 ms
R1-65123#ping 192.168.5.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/72/116 ms
R1-65123#ping 192.168.5.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/79/140 ms


R1-65123#traceroute 192.168.4.1

Type escape sequence to abort.
Tracing the route to 192.168.4.1

  1 12.1.1.2 20 msec 32 msec 32 msec
  2 24.1.1.2 76 msec 28 msec 96 msec

R1-65123#show ip bgp 192.168.4.1
BGP routing table entry for 192.168.4.0/24, version 15
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  6544
    12.1.1.2 from 12.1.1.2 (192.168.2.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best

R2-65123#show ip bgp 192.168.4.1
BGP routing table entry for 192.168.4.0/24, version 14
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Advertised to update-groups:
     1          2          3
  6544
    24.1.1.2 from 24.1.1.2 (192.168.4.1)
      Origin IGP, metric 0, localpref 100, valid, external, best


 
R4-6544(config)#access-list 1 permit 192.168.4.0 255.0.0.0

R4-6544(config)#do show access-list 1
Standard IP access list 1
    10 permit 0.168.4.0, wildcard bits 255.0.0.0


R4-6544(config)#route-map no-advertise permit 1
R4-6544(config-route-map)#match ip address 1
R4-6544(config-route-map)#set community ?
  <1-4294967295>  community number
  aa:nn           community number in aa:nn format
  additive        Add to the existing community
  internet        Internet (well-known community)
  local-AS        Do not send outside local AS (well-known community)
  no-advertise    Do not advertise to any peer (well-known community)
  no-export       Do not export to next AS (well-known community)
  none            No community attribute
  <cr>
 
R4-6544(config-route-map)#set community no-advertise
R4-6544(config-route-map)#exit
 
R4-6544(config)#route-map no-advertise permit 2
R4-6544(config-route-map)#exit

R4-6544(config)#do show route-map no-advertise
route-map no-advertise, permit, sequence 1
  Match clauses:
    ip address (access-lists): 1
  Set clauses:
    community no-advertise
  Policy routing matches: 0 packets, 0 bytes
route-map no-advertise, permit, sequence 2
  Match clauses:
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes

R4-6544(config)#router bgp 6544
R4-6544(config-router)#neighbor 24.1.1.1 route-map no-advertise out
R4-6544(config-router)#neighbor 24.1.1.1 send-community
R4-6544(config-router)#end

(neighbor send-community BGP subcommand tells BGP to include the community PATH_ATTRIBUTE in the update)

R4-6544#clear ip bgp * soft

R2-65123#show ip bgp 192.168.4.1
BGP routing table entry for 192.168.4.0/24, version 20
Paths: (1 available, best #1, table Default-IP-Routing-Table, not advertised to any peer)
Flag: 0x880
  Not advertised to any peer
  6544
    24.1.1.2 from 24.1.1.2 (192.168.4.1)
      Origin IGP, metric 0, localpref 100, valid, external, best
      Community: no-advertise


R1-65123#show ip bgp 192.168.4.1
BGP routing table entry for 192.168.4.0/24, version 15
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  6544
    12.1.1.2 from 12.1.1.2 (192.168.2.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best

R1-65123#show ip bgp 192.168.4.1
% Network not in table




BGP community Local-AS


topology:-

  • configure the topology as per the diagram and assign the IP addresses.
  • configure iBGP and EBGP neighborship. 
  • configure the router 11 to advertise the 192.168.11.1/24 prefix all the routers within the AS 65109 only.
  • ensure rest of the ASs will not get this network.
  • make sure rest of the routes from all the ASs are share and install in routing tables. 
  • trace the 192.168.5.1/24 from 192.168.12.1/24


R9-65109(config)#interface serial 6/0
R9-65109(config-if)#ip address 19.1.1.2 255.0.0.0
R9-65109(config-if)#no shutdown
R9-65109(config-if)#exit
R9-65109(config)#interface serial 5/0
R9-65109(config-if)#ip address 91.1.1.1 255.0.0.0
R9-65109(config-if)#no shutdown
R9-65109(config-if)#exit
R9-65109(config)#interface serial 5/1
R9-65109(config-if)#ip address 109.1.1.1 255.0.0.0
R9-65109(config-if)#no shutdown
R9-65109(config-if)#exit

R9-65109(config)#interface loopback 1
R9-65109(config-if)#ip address 192.168.9.1 255.255.255.0
R9-65109(config-if)#no shutdown
R9-65109(config-if)#exit

R9-65109(config)#interface fastethernet 0/0
R9-65109(config-if)#ip address 90.1.1.1 255.0.0.0
R9-65109(config-if)#no shutdown
R9-65109(config-if)#no keepalive
R9-65109(config-if)#exit
 
router-10
show IP interface brief

 
R10-65109(config)#interface serial 5/2
R10-65109(config-if)#ip address 107.1.1.1 255.0.0.0
R10-65109(config-if)#no shutdown
R10-65109(config-if)#exit
R10-65109(config)#interface serial 5/0
R10-65109(config-if)#ip address 102.1.1.1 255.0.0.0
R10-65109(config-if)#no shutdown
R10-65109(config-if)#exit
R10-65109(config)#interface serial 5/1
R10-65109(config-if)#ip address 109.1.1.2 255.0.0.0
R10-65109(config-if)#no shutdown
R10-65109(config-if)#exit

R10-65109(config)#interface loopback 1
R10-65109(config-if)#ip address 192.168.10.1 255.255.255.0
R10-65109(config-if)#no shutdown
R10-65109(config-if)#exit

R10-65109(config)#interface fastethernet 0/0
R10-65109(config-if)#ip address 100.1.1.1 255.0.0.0
R10-65109(config-if)#no shutdown
R10-65109(config-if)#no keepalive
R10-65109(config-if)#exit


router-10
show IP interface brief



 
R11-65109(config)#interface serial 5/3
R11-65109(config-if)#ip address 17.1.1.1 255.0.0.0
R11-65109(config-if)#no shutdown
R11-65109(config-if)#exit
R11-65109(config)#interface serial 5/0
R11-65109(config-if)#ip address 91.1.1.2 255.0.0.0
R11-65109(config-if)#no shutdown
R11-65109(config-if)#exit
R11-65109(config)#interface serial 5/1
R11-65109(config-if)#ip address 18.1.1.1 255.0.0.0
R11-65109(config-if)#no shutdown
R11-65109(config-if)#exit

R11-65109(config)#interface loopback 1
R11-65109(config-if)#ip address 192.168.11.1 255.255.255.0
R11-65109(config-if)#no shutdown
R11-65109(config-if)#exit

R11-65109(config)#interface fastethernet 0/0
R11-65109(config-if)#ip address 110.1.1.1 255.0.0.0
R11-65109(config-if)#no shutdown
R11-65109(config-if)#no keepalive
R11-65109(config-if)#exit
 

router 11
show IP interfacebrief



 
R8-6588(config)#interface serial 5/1
R8-6588(config-if)#ip address 18.1.1.2 255.0.0.0
R8-6588(config-if)#no shutdown
R8-6588(config-if)#exit

R8-6588(config)#interface loopback 1
R8-6588(config-if)#ip address 192.168.8.1 255.255.255.0
R8-6588(config-if)#no shutdown
R8-6588(config-if)#exit

R8-6588(config)#interface fastethernet 0/0
R8-6588(config-if)#ip address 80.1.1.1 255.0.0.0
R8-6588(config-if)#no shutdown
R8-6588(config-if)#no keepalive
R8-6588(config-if)#exit

router-8
show IP interface brief



 
R7-6577(config)#interface serial 5/2
R7-6577(config-if)#ip address 107.1.1.2 255.0.0.0
R7-6577(config-if)#no shutdown
R7-6577(config-if)#exit
R7-6577(config)#interface serial 5/3
R7-6577(config-if)#ip address 17.1.1.2 255.0.0.0
R7-6577(config-if)#no shutdown
R7-6577(config-if)#exit

R7-6577(config)#interface loopback 1
R7-6577(config-if)#ip address 192.168.7.1 255.255.255.0
R7-6577(config-if)#exit

R7-6577(config)#interface fastethernet 0/0
R7-6577(config-if)#ip address 70.1.1.1 255.0.0.0
R7-6577(config-if)#no shutdown
R7-6577(config-if)#no keepalive
R7-6577(config-if)#exit
 

router-7
show IP interface brief




R12-6512(config)#interface serial 5/0
R12-6512(config-if)#ip address 102.1.1.2 255.0.0.0
R12-6512(config-if)#no shutdown
R12-6512(config-if)#exit

R12-6512(config)#interface loopback 1
R12-6512(config-if)#ip address 192.168.12.1 255.255.255.0
R12-6512(config-if)#exit

R12-6512(config)#interface fastethernet 0/0
R12-6512(config-if)#ip address 120.1.1.1 255.0.0.0
R12-6512(config-if)#no shutdown
R12-6512(config-if)#no keepalive
R12-6512(config-if)#exit

router-12
show IP interface brief




R9-65109(config)#router bgp 65109
R9-65109(config-router)#neighbor 91.1.1.2 remote-as 65109
R9-65109(config-router)#neighbor 109.1.1.2 remote-as 65109
R9-65109(config-router)#neighbor 91.1.1.2 next-hop-self
R9-65109(config-router)#neighbor 109.1.1.2 next-hop-self
R9-65109(config-router)#neighbor 19.1.1.1 remote-as 65123
R9-65109(config-router)#network 91.0.0.0 mask 255.0.0.0
R9-65109(config-router)#network 109.0.0.0 mask 255.0.0.0
R9-65109(config-router)#network 19.0.0.0 mask 255.0.0.0
R9-65109(config-router)#network 90.0.0.0 mask 255.0.0.0
R9-65109(config-router)#network 192.168.9.0 mask 255.255.255.0
R9-65109(config-router)#no auto-summary
R9-65109(config-router)#no syn
R9-65109(config-router)#exit

*Nov  9 15:57:23.167: %BGP-5-ADJCHANGE: neighbor 109.1.1.2 Up
*Nov  9 15:59:45.815: %BGP-5-ADJCHANGE: neighbor 91.1.1.2 Up

 
R9-65109#show ip bgp summary
BGP router identifier 192.168.9.1, local AS number 65109
BGP table version is 37, main routing table version 37
36 network entries using 4212 bytes of memory
41 path entries using 2132 bytes of memory
11/10 BGP path/bestpath attribute entries using 1364 bytes of memory
7 BGP AS-PATH entries using 168 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 7876 total bytes of memory
BGP activity 36/0 prefixes, 41/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
19.1.1.1        4 65123      11      11       37    0    0 00:02:41       18
91.1.1.2        4 65109      42      46       37    0    0 00:35:34        9
109.1.1.2       4 65109      43      47       37    0    0 00:37:57        9


router-9
show IP bgp


R10-65109(config)#router bgp 65109
R10-65109(config-router)#neighbor 109.1.1.1 remote-as 65109
R10-65109(config-router)#neighbor 91.1.1.2 remote-as 65109
R10-65109(config-router)#neighbor 107.1.1.2 remote-as 6577
R10-65109(config-router)#neighbor 102.1.1.2 remote-as 6512
R10-65109(config-router)#neighbor 109.1.1.1 next-hop-self
R10-65109(config-router)#network 109.0.0.0 mask 255.0.0.0
R10-65109(config-router)#network 107.0.0.0 mask 255.0.0.0
R10-65109(config-router)#network 102.0.0.0 mask 255.0.0.0
R10-65109(config-router)#network 100.0.0.0 mask 255.0.0.0
R10-65109(config-router)#network 192.168.10.0 mask 255.255.255.0
R10-65109(config-router)#no auto-summary
R10-65109(config-router)#no syn
R10-65109(config-router)#exit

*Nov  9 15:56:12.551: %BGP-5-ADJCHANGE: neighbor 109.1.1.1 Up
*Nov  9 15:59:28.711: %BGP-5-ADJCHANGE: neighbor 91.1.1.2 Up
*Nov  9 16:01:38.883: %BGP-5-ADJCHANGE: neighbor 107.1.1.2 Up
*Nov  9 16:03:18.155: %BGP-5-ADJCHANGE: neighbor 102.1.1.2 Up

 
R10-65109#show ip bgp summary
BGP router identifier 192.168.10.1, local AS number 65109
BGP table version is 37, main routing table version 37
36 network entries using 4212 bytes of memory
43 path entries using 2236 bytes of memory
11/9 BGP path/bestpath attribute entries using 1364 bytes of memory
7 BGP AS-PATH entries using 168 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 7980 total bytes of memory
BGP activity 36/0 prefixes, 43/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
91.1.1.2        4 65109      44      44       37    0    0 00:37:52        9
102.1.1.2       4  6512      40      49       37    0    0 00:34:03        3
107.1.1.2       4  6577      48      49       37    0    0 00:35:42        4
109.1.1.1       4 65109      51      47       37    0    0 00:41:08       22

R10-65109#show ip bgp
BGP table version is 37, local router ID is 192.168.10.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.0.0.0         109.1.1.1                0    100      0 65123 i
*>i12.0.0.0         109.1.1.1                0    100      0 65123 i
*>i13.0.0.0         109.1.1.1                0    100      0 65123 i
*  17.0.0.0         107.1.1.2                0             0 6577 i
*>i                 91.1.1.2                 0    100      0 i
*>i18.0.0.0         91.1.1.2                 0    100      0 i
*>i19.0.0.0         109.1.1.1                0    100      0 i
*>i20.0.0.0         109.1.1.1                0    100      0 65123 i
*>i24.0.0.0         109.1.1.1                0    100      0 65123 i
*>i25.0.0.0         109.1.1.1                0    100      0 65123 i
*>i30.0.0.0         109.1.1.1                0    100      0 65123 i
*>i35.0.0.0         109.1.1.1                0    100      0 65123 i
*>i36.0.0.0         109.1.1.1                0    100      0 65123 i
*>i40.0.0.0         109.1.1.1                0    100      0 65123 6544 i
*>i50.0.0.0         109.1.1.1                0    100      0 65123 6555 i
*>i60.0.0.0         109.1.1.1                0    100      0 65123 6566 i
* i70.0.0.0         17.1.1.2                 0    100      0 6577 i
*>                  107.1.1.2                0             0 6577 i
*>i80.0.0.0         18.1.1.2                 0    100      0 6588 i
*>i90.0.0.0         109.1.1.1                0    100      0 i
* i91.0.0.0         91.1.1.2                 0    100      0 i
*>i                 109.1.1.1                0    100      0 i
*> 100.0.0.0        0.0.0.0                  0         32768 i
*  102.0.0.0        102.1.1.2                0             0 6512 i
*>                  0.0.0.0                  0         32768 i
*  107.0.0.0        107.1.1.2                0             0 6577 i
*>                  0.0.0.0                  0         32768 i
* i109.0.0.0        109.1.1.1                0    100      0 i
*>                  0.0.0.0                  0         32768 i
*>i110.0.0.0        91.1.1.2                 0    100      0 i
*> 120.0.0.0        102.1.1.2                0             0 6512 i
*>i192.168.1.0      109.1.1.1                0    100      0 65123 i
*>i192.168.2.0      109.1.1.1                0    100      0 65123 i
*>i192.168.3.0      109.1.1.1                0    100      0 65123 i
*>i192.168.5.0      109.1.1.1                0    100      0 65123 6555 i
*>i192.168.6.0      109.1.1.1                0    100      0 65123 6566 i
* i192.168.7.0      17.1.1.2                 0    100      0 6577 i
*>                  107.1.1.2                0             0 6577 i
*>i192.168.8.0      18.1.1.2                 0    100      0 6588 i
*>i192.168.9.0      109.1.1.1                0    100      0 i
*> 192.168.10.0     0.0.0.0                  0         32768 i
*>i192.168.11.0     91.1.1.2                 0    100      0 i
*> 192.168.12.0     102.1.1.2                0             0 6512 i

R11-65109(config)#router bgp 65109
R11-65109(config-router)#neighbor 91.1.1.1 remote-as 65109
R11-65109(config-router)#neighbor 109.1.1.2 remote-as 65109
R11-65109(config-router)#neighbor 18.1.1.2 remote-as 6588
R11-65109(config-router)#neighbor 17.1.1.2 remote-as 6577
R11-65109(config-router)#neighbor 91.1.1.1 next-hop-self
R11-65109(config-router)#network 91.0.0.0 mask 255.0.0.0
R11-65109(config-router)#network 18.0.0.0 mask 255.0.0.0
R11-65109(config-router)#network 17.0.0.0 mask 255.0.0.0
R11-65109(config-router)#network 110.0.0.0 mask 255.0.0.0
R11-65109(config-router)#network 192.168.11.0 mask 255.255.255.0
R11-65109(config-router)#no auto-summary
R11-65109(config-router)#no syn
R11-65109(config-router)#exit
 



R8-6588(config)#router bgp 6588
R8-6588(config-router)#neighbor 18.1.1.1 remote-as 65109
R8-6588(config-router)#network 18.0.0.0 mask 255.0.0.0
R8-6588(config-router)#network 80.0.0.0 mask 255.0.0.0
R8-6588(config-router)#network 192.168.8.0 mask 255.255.255.0
R8-6588(config-router)#no auto-summary
R8-6588(config-router)#no syn
R8-6588(config-router)#exit

*Nov  9 15:58:42.019: %BGP-5-ADJCHANGE: neighbor 18.1.1.1 Up



 
R7-6577(config)#router bgp 6577
R7-6577(config-router)#neighbor 17.1.1.1 remote-as 65109
R7-6577(config-router)#neighbor 107.1.1.1 remote-as 65109
R7-6577(config-router)#network 17.0.0.0 mask 255.0.0.0
R7-6577(config-router)#network 107.0.0.0 mask 255.0.0.0
R7-6577(config-router)#network 70.0.0.0 mask 255.0.0.0
R7-6577(config-router)#network 192.168.7.0 mask 255.255.255.0
R7-6577(config-router)#no auto-summary
R7-6577(config-router)#no syn
R7-6577(config-router)#exit
 
R7-6577#show ip bgp
BGP table version is 37, local router ID is 192.168.7.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  10.0.0.0         107.1.1.1                              0 65109 65123 i
*>                  17.1.1.1                               0 65109 65123 i
*  12.0.0.0         107.1.1.1                              0 65109 65123 i
*>                  17.1.1.1                               0 65109 65123 i
*  13.0.0.0         107.1.1.1                              0 65109 65123 i
*>                  17.1.1.1                               0 65109 65123 i
*  17.0.0.0         17.1.1.1                 0             0 65109 i
*                   107.1.1.1                              0 65109 i
*>                  0.0.0.0                  0         32768 i
*  18.0.0.0         17.1.1.1                 0             0 65109 i
*>                  107.1.1.1                              0 65109 i
*  19.0.0.0         107.1.1.1                              0 65109 i
*>                  17.1.1.1                               0 65109 i
*  20.0.0.0         107.1.1.1                              0 65109 65123 i
*>                  17.1.1.1                               0 65109 65123 i
*  24.0.0.0         107.1.1.1                              0 65109 65123 i
*>                  17.1.1.1                               0 65109 65123 i
   Network          Next Hop            Metric LocPrf Weight Path
*  25.0.0.0         107.1.1.1                              0 65109 65123 i
*>                  17.1.1.1                               0 65109 65123 i
*  30.0.0.0         107.1.1.1                              0 65109 65123 i
*>                  17.1.1.1                               0 65109 65123 i
*  35.0.0.0         107.1.1.1                              0 65109 65123 i
*>                  17.1.1.1                               0 65109 65123 i
*  36.0.0.0         107.1.1.1                              0 65109 65123 i
*>                  17.1.1.1                               0 65109 65123 i
*  40.0.0.0         107.1.1.1                              0 65109 65123 6544 i
*>                  17.1.1.1                               0 65109 65123 6544 i
*  50.0.0.0         107.1.1.1                              0 65109 65123 6555 i
*>                  17.1.1.1                               0 65109 65123 6555 i
*  60.0.0.0         107.1.1.1                              0 65109 65123 6566 i
*>                  17.1.1.1                               0 65109 65123 6566 i
*> 70.0.0.0         0.0.0.0                  0         32768 i
*  80.0.0.0         17.1.1.1                               0 65109 6588 i
*>                  107.1.1.1                              0 65109 6588 i
*  90.0.0.0         17.1.1.1                               0 65109 i
*>                  107.1.1.1                              0 65109 i
*  91.0.0.0         17.1.1.1                 0             0 65109 i
*>                  107.1.1.1                              0 65109 i
*  100.0.0.0        17.1.1.1                               0 65109 i
   Network          Next Hop            Metric LocPrf Weight Path
*>                  107.1.1.1                0             0 65109 i
*  102.0.0.0        17.1.1.1                               0 65109 i
*>                  107.1.1.1                0             0 65109 i
*  107.0.0.0        17.1.1.1                               0 65109 i
*                   107.1.1.1                0             0 65109 i
*>                  0.0.0.0                  0         32768 i
*  109.0.0.0        17.1.1.1                               0 65109 i
*>                  107.1.1.1                0             0 65109 i
*  110.0.0.0        17.1.1.1                 0             0 65109 i
*>                  107.1.1.1                              0 65109 i
*  120.0.0.0        17.1.1.1                               0 65109 6512 i
*>                  107.1.1.1                              0 65109 6512 i
*  192.168.1.0      107.1.1.1                              0 65109 65123 i
*>                  17.1.1.1                               0 65109 65123 i
*  192.168.2.0      107.1.1.1                              0 65109 65123 i
*>                  17.1.1.1                               0 65109 65123 i
*  192.168.3.0      107.1.1.1                              0 65109 65123 i
*>                  17.1.1.1                               0 65109 65123 i
*  192.168.5.0      107.1.1.1                              0 65109 65123 6555 i
*>                  17.1.1.1                               0 65109 65123 6555 i
*  192.168.6.0      107.1.1.1                              0 65109 65123 6566 i
*>                  17.1.1.1                               0 65109 65123 6566 i
   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.7.0      0.0.0.0                  0         32768 i
*  192.168.8.0      17.1.1.1                               0 65109 6588 i
*>                  107.1.1.1                              0 65109 6588 i
*  192.168.9.0      17.1.1.1                               0 65109 i
*>                  107.1.1.1                              0 65109 i
*  192.168.10.0     17.1.1.1                               0 65109 i
*>                  107.1.1.1                0             0 65109 i
*  192.168.11.0     17.1.1.1                 0             0 65109 i
*>                  107.1.1.1                              0 65109 i
*  192.168.12.0     17.1.1.1                               0 65109 6512 i
*>                  107.1.1.1                              0 65109 6512 i



R12-6512(config)#router bgp 6512
R12-6512(config-router)#neighbor 102.1.1.1 remote-as 65109
R12-6512(config-router)#network 102.0.0.0 mask 255.0.0.0
R12-6512(config-router)#network 120.0.0.0 mask 255.0.0.0
R12-6512(config-router)#network 192.168.12.0 mask 255.255.255.0
R12-6512(config-router)#no auto-summary
R12-6512(config-router)#no syn
R12-6512(config-router)#exit

*Nov  9 15:59:48.839: %BGP-5-ADJCHANGE: neighbor 102.1.1.1 Up



R9-65109#show ip bgp 192.168.8.1
BGP routing table entry for 192.168.8.0/24, version 15
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Advertised to update-groups:
     1
  6588
    91.1.1.2 from 91.1.1.2 (192.168.11.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best


R12-6512#show ip bgp 192.168.11.1
BGP routing table entry for 192.168.11.0/24, version 16
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  65109
    102.1.1.1 from 102.1.1.1 (192.168.10.1)
      Origin IGP, localpref 100, valid, external, best

R7-6577#show ip bgp 192.168.11.1
BGP routing table entry for 192.168.11.0/24, version 17
Paths: (2 available, best #2, table Default-IP-Routing-Table)
  Advertised to update-groups:
     1
  65109
    17.1.1.1 from 17.1.1.1 (192.168.11.1)
      Origin IGP, metric 0, localpref 100, valid, external
  65109
    107.1.1.1 from 107.1.1.1 (192.168.10.1)
      Origin IGP, localpref 100, valid, external, best


R8-6588#show ip bgp 192.168.11.1
BGP routing table entry for 192.168.11.0/24, version 15
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  65109
    18.1.1.1 from 18.1.1.1 (192.168.11.1)
      Origin IGP, metric 0, localpref 100, valid, external, best



R11-65109(config)#access-list 11 permit 192.168.11.0 0.0.0.255
R11-65109(config)#do show access-list 11
Standard IP access list 11
    10 permit 192.168.11.0, wildcard bits 0.0.0.255

R11-65109(config)#route-map local-as permit 11
R11-65109(config-route-map)#match ip address 11
R11-65109(config-route-map)#set community local-as
R11-65109(config-route-map)#exit

R11-65109(config)#route-map local-as permit 12
R11-65109(config-route-map)#exit

R11-65109(config)#router bgp 65109
R11-65109(config-router)#network 192.168.11.0 mask 255.255.255.0 route-map local-as
R11-65109(config-router)#neighbor 18.1.1.2 send-community
R11-65109(config-router)#neighbor 17.1.1.2 send-community
R11-65109(config-router)#neighbor 109.1.1.2 send-community
R11-65109(config-router)#exit

R8-6588#show ip bgp 192.168.11.1
% Network not in table

R7-6577#show ip bgp 192.168.11.1
% Network not in table

R12-6512#show ip bgp 192.168.11.1
% Network not in table


R9-65109#show ip bgp 192.168.11.1
BGP routing table entry for 192.168.11.0/24, version 10
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Advertised to update-groups:
     1
  Local
    91.1.1.2 from 91.1.1.2 (192.168.11.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best

R10-65109#show ip bgp 192.168.11.1
BGP routing table entry for 192.168.11.0/24, version 38
Paths: (1 available, best #1, table Default-IP-Routing-Table, not advertised outside local AS)
  Not advertised to any peer
  Local
    91.1.1.2 from 91.1.1.2 (192.168.11.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Community: local-AS


R12-6512#traceroute 192.168.5.1

Type escape sequence to abort.
Tracing the route to 192.168.5.1

  1 102.1.1.1 16 msec 32 msec 32 msec
  2 109.1.1.1 [AS 65109] 28 msec 96 msec 64 msec
  3 19.1.1.1 [AS 65109] 72 msec 88 msec 92 msec
  4 12.1.1.2 [AS 65123] 184 msec 124 msec 120 msec
  5 25.1.1.2 [AS 65123] 128 msec 152 msec 156 msec


No comments:

Post a Comment

CCNP CCIE EBGP configuration

  Border Gateway Protocol (BGP) is the protocol underlying the global routing system of the internet. Here’s a detailed breakdown: Purpose:...

INSTAGRAM FEED

@Edger C Francis