Route Reflector Cluster
A BGP-enabled router or BGP speakers. By default BGP speaker routers do not advertise iBGP-learned prefixes to iBGP peer routers - this has to be done to maintain loop prevention. RFC4456 introduces the route reflection feature which helps to remove the need of full mesh configuration between iBGP speakers routers. When the route reflector reflects a route, it creates and modifies an optional non-transitive attribute called CLUSTER_LIST by adding its own cluster ID to it. This attribute is used for loop prevention: when a BGP router receives update which CLUSTER_LIST contains router's own cluster ID, this update is discarded.
Route reflector
Route Reflector scalable alternative to an ibgp full mesh its allow a BGP speaker (route reflector –RR) to advertise route received from an ibgp peer to other ibgp peers.
note:client update server. Server update to all the remaining clients.
All client should establish neighbor with only servers . client will not establish neighbor with any other client. In case if you have 2 servers ( server establish neighbor with other servers and clients).
Route reflector clusters
A group of redundant route reflector and their clients from a cluster. Route reflector rules divide a transit AS into smaller areas (called clusters). Each BGP cluster must have a unique cluster-id. Every time a prefixe is reflected, the cluster-id is added to the cluster-id BGP attribute. The prefixe that already contains the local cluster-id in the cluster-list is not reflector
Note:Each cluster contain route reflectors and route reflector clients.
Route Reflector (RR)
Purpose: The primary role of a Route Reflector is to reflect BGP routes from one iBGP peer to another, reducing the need for a full mesh of iBGP connections within an autonomous system.
Operation: RRs receive routes from their clients (other routers in the network) and then propagate these routes to other clients. This ensures that all routers in the network learn about all the routes without having to connect directly to each other.
Types of Peers:
RR Cluster
Purpose: An RR Cluster is a group of Route Reflectors that work together to provide redundancy and scalability in a network.
Cluster ID: Each RR Cluster is identified by a unique Cluster ID. This ID is used to prevent routing loops within the cluster by tagging routes with the Cluster ID.
Redundancy: By having multiple RRs in a cluster, the network can handle failures more gracefully. If one RR goes down, other RRs in the cluster can continue to reflect routes.
Coordination: RRs within the same cluster coordinate with each other to ensure consistent route reflection and prevent loops.
lets see the configuration:
topology:-
The goal:- is to configure RR two servers router-2 and router-4 in AS 1234. configure RR Cluster group router 9 and 5 cluster-id 10.10.10.10 and group 2 router 6-7-8 cluster-id 30.30.30.30. in the end, configure EBGP neighbor between router-2 and router-8 and ensure all the routes are exchanged.
- configure the topology as per the diagram
- configure the IP addresses as per the topology
- configure EIGRP 1234 on router 1-2-3-4
- advertise directly connected route
- configure EIGRP 65100 on router 5-6-7-8-9
- advertise directly connected route
configure the IP addresses as per the topology
R1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.12.1 YES manual up up
FastEthernet2/0 192.168.41.2 YES manual up up
Loopback1 11.1.1.1 YES manual up up
Loopback2 11.1.2.1 YES manual up up
Loopback3 11.1.3.1 YES manual up up
Loopback4 11.1.4.1 YES manual up up
RR-SERVER-#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.12.2 YES manual up up
FastEthernet2/0 192.168.23.1 YES manual up up
Serial5/0 28.1.1.1 YES manual up up
Loopback1 12.1.1.1 YES manual up up
Loopback2 12.1.2.1 YES manual up up
Loopback3 12.1.3.1 YES manual up up
Loopback4 12.1.4.1 YES manual up up
R3#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.34.1 YES manual up up
FastEthernet2/0 192.168.23.2 YES manual up up
Loopback1 13.1.1.1 YES manual up up
Loopback2 13.1.2.1 YES manual up up
Loopback3 13.1.3.1 YES manual up up
Loopback4 13.1.4.1 YES manual up up
R4-RR-SERVER-2-#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.34.2 YES manual up up
FastEthernet2/0 192.168.41.1 YES manual up up
Loopback1 14.1.1.1 YES manual up up
Loopback2 14.1.2.1 YES manual up up
Loopback3 14.1.3.1 YES manual up up
Loopback4 14.1.4.1 YES manual up up
R5#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.56.1 YES manual up up
Loopback1 50.1.1.1 YES manual up up
R6#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.56.2 YES manual up up
FastEthernet2/0 192.168.67.1 YES manual up up
Loopback1 60.1.1.1 YES manual up up
R7#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.78.1 YES manual up up
FastEthernet2/0 192.168.67.2 YES manual up up
Loopback1 70.1.1.1 YES manual up up
R8#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.78.2 YES manual up up
Serial5/0 28.1.1.2 YES manual up up
Loopback1 80.1.1.1 YES manual up up
R9#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down ATM1/0 unassigned YES unset administratively down down FastEthernet2/0 192.168.95.1 YES manual up up Loopback1 90.1.1.1 YES manual up up
configure the EIGRP 1234 / EIGRP 65100 and advertise all the directly connected interfaces and loopbacks
R1(config)#router eigrp 1234
R1(config-router)#network 192.168.12.0
R1(config-router)#network 192.168.41.0
R1(config-router)#network 11.1.1.0
R1(config-router)#network 11.1.2.0
R1(config-router)#network 11.1.3.0
R1(config-router)#network 11.1.4.0
R1(config-router)#no auto-summary
R1(config-router)#exit
*Nov 18 15:00:22.811: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1234: Neighbor 192.168.12.2 (FastEthernet0/0) is up: new adjacency
*Nov 18 15:02:08.027: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1234: Neighbor 192.168.41.1 (FastEthernet2/0) is up: new adjacency
RR-SERVER-(config)#router eigrp 1234
RR-SERVER-(config-router)#network 192.168.12.0
RR-SERVER-(config-router)#network 192.168.23.0
RR-SERVER-(config-router)#network 12.1.1.0
RR-SERVER-(config-router)#network 12.1.2.0
RR-SERVER-(config-router)#network 12.1.3.0
RR-SERVER-(config-router)#network 12.1.4.0
RR-SERVER-(config-router)#no auto-summary
RR-SERVER-(config-router)#exit
*Nov 18 15:04:35.971: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1234: Neighbor 192.168.12.1 (FastEthernet0/0) is up: new adjacency
*Nov 18 15:05:20.679: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1234: Neighbor 192.168.23.2 (FastEthernet2/0) is up: new adjacency
R3(config)#router eigrp 1234
R3(config-router)#network 192.168.34.0
R3(config-router)#network 192.168.23.0
R3(config-router)#network 13.1.1.0
R3(config-router)#network 13.1.2.0
R3(config-router)#network 13.1.3.0
R3(config-router)#network 13.1.4.0
R3(config-router)#no auto-summary
R3(config-router)#exit
*Nov 18 14:57:19.399: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1234: Neighbor 192.168.23.1 (FastEthernet2/0) is up: new adjacency
*Nov 18 14:58:19.575: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1234: Neighbor 192.168.34.2 (FastEthernet0/0) is up: new adjacency
R4-RR-SERVER-2-(config)#router eigrp 1234
R4-RR-SERVER-2-(config-router)#network 192.168.34.0
R4-RR-SERVER-2-(config-router)#network 192.168.41.0
R4-RR-SERVER-2-(config-router)#network 14.1.1.0
R4-RR-SERVER-2-(config-router)#network 14.1.2.0
R4-RR-SERVER-2-(config-router)#network 14.1.3.0
R4-RR-SERVER-2-(config-router)#network 14.1.4.0
R4-RR-SERVER-2-(config-router)#no auto-summary
R4-RR-SERVER-2-(config-router)#exit
*Nov 18 14:56:51.851: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1234: Neighbor 192.168.34.1 (FastEthernet0/0) is up: new adjacency
*Nov 18 14:56:51.855: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1234: Neighbor 192.168.41.2 (FastEthernet2/0) is up: new adjacency
R5(config)#router eigrp 65100
R5(config-router)#network 192.168.95.0
R5(config-router)#network 192.168.56.0
R5(config-router)#network 50.0.0.0
R5(config-router)#no auto-summary
R5(config-router)#exit
*Nov 18 16:10:17.723: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 65100: Neighbor 192.168.56.2 (FastEthernet0/0) is up: new adjacency
R6(config)#router eigrp 65100
R6(config-router)#network 192.168.67.0
R6(config-router)#network 192.168.56.0
R6(config-router)#network 60.0.0.0
R6(config-router)#no auto-summary
R6(config-router)#exit
*Nov 18 16:07:53.647: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 65100: Neighbor 192.168.56.1 (FastEthernet0/0) is up: new adjacency
*Nov 18 16:08:24.071: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 65100: Neighbor 192.168.67.2 (FastEthernet2/0) is up: new adjacency
R7(config)#router eigrp 65100
R7(config-router)#network 192.168.67.0
R7(config-router)#network 192.168.78.0
R7(config-router)#network 70.0.0.0
R7(config-router)#no auto-summary
R7(config-router)#exit
*Nov 18 16:04:00.199: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 65100: Neighbor 192.168.67.1 (FastEthernet2/0) is up: new adjacency
*Nov 18 16:04:23.771: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 65100: Neighbor 192.168.78.2 (FastEthernet0/0) is up: new adjacency
R8(config)#router eigrp 65100
R8(config-router)#network 192.168.78.0
R8(config-router)#network 80.0.0.0
R8(config-router)#no auto-summary
R8(config-router)#exit
*Nov 18 16:03:27.991: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 65100: Neighbor 192.168.78.1 (FastEthernet0/0) is up: new adjacency
R9(config)#router eigrp 65100
R9(config-router)#network 192.168.78.0
R9(config-router)#network 90.0.0.0
R9(config-router)#no auto-summary
R9(config-router)#exit
*Nov 18 16:24:11.843: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 65100: Neighbor 192.168.95.2 (FastEthernet2/0) is up: new adjacency
configure BGP 1234 router 1-2-3-4 and advertise only loopback
R1(config)#router bgp 1234
R1(config-router)#neighbor 12.1.1.1 remote-as 1234
R1(config-router)#neighbor 12.1.1.1 update-source loopback 1
R1(config-router)#neighbor 14.1.1.1 remote-as 1234
R1(config-router)#neighbor 14.1.1.1 update-source loopback 1
R1(config-router)#network 11.1.1.0 mask 255.255.255.0
R1(config-router)#network 11.1.2.0 mask 255.255.255.0
R1(config-router)#network 11.1.3.0 mask 255.255.255.0
R1(config-router)#network 11.1.4.0 mask 255.255.255.0
R1(config-router)#no auto-summary
R1(config-router)#no syn
R1(config-router)#exit
*Nov 19 14:01:57.083: %BGP-5-ADJCHANGE: neighbor 12.1.1.1 Up
*Nov 19 14:02:42.815: %BGP-5-ADJCHANGE: neighbor 14.1.1.1 Up
RR-SERVER-(config)#router bgp 1234
RR-SERVER-(config-router)#neighbor 11.1.1.1 remote-as 1234
RR-SERVER-(config-router)#neighbor 11.1.1.1 update-source loopback 1
RR-SERVER-(config-router)#neighbor 11.1.1.1 route-reflector-client
RR-SERVER-(config-router)#neighbor 13.1.1.1 remote-as 1234
RR-SERVER-(config-router)#neighbor 13.1.1.1 update-source loopback 1
RR-SERVER-(config-router)#neighbor 13.1.1.1 route-reflector-client
RR-SERVER-(config-router)#neighbor 14.1.1.1 remote-as 1234
RR-SERVER-(config-router)#neighbor 14.1.1.1 update-source loopback 1
RR-SERVER-(config-router)#neighbor 14.1.1.1 route-reflector-client
RR-SERVER-(config-router)#network 12.1.1.0 mask 255.255.255.0
RR-SERVER-(config-router)#network 12.1.2.0 mask 255.255.255.0
RR-SERVER-(config-router)#network 12.1.3.0 mask 255.255.255.0
RR-SERVER-(config-router)#network 12.1.4.0 mask 255.255.255.0
RR-SERVER-(config-router)#no auto-summary
RR-SERVER-(config-router)#no syn
RR-SERVER-(config-router)#exit
*Nov 19 13:59:37.027: %BGP-5-ADJCHANGE: neighbor 11.1.1.1 Up
*Nov 19 13:59:40.599: %BGP-5-ADJCHANGE: neighbor 13.1.1.1 Up
*Nov 19 14:00:16.747: %BGP-5-ADJCHANGE: neighbor 14.1.1.1 Up
RR-SERVER-#show ip bgp 11.1.2.1
BGP routing table entry for 11.1.2.0/24, version 11
Paths: (2 available, best #2, table Default-IP-Routing-Table, RIB-failure(17))
Advertised to update-groups:
1
Local, (Received from a RR-client)
11.1.1.1 (metric 156160) from 14.1.1.1 (14.1.4.1)
Origin IGP, metric 0, localpref 100, valid, internal
Originator: 11.1.4.1, Cluster list: 14.1.4.1
Local, (Received from a RR-client)
11.1.1.1 (metric 156160) from 11.1.1.1 (11.1.4.1)
Origin IGP, metric 0, localpref 100, valid, internal, best
RR-SERVER-#show ip bgp 13.1.2.1
BGP routing table entry for 13.1.2.0/24, version 19
Paths: (2 available, best #2, table Default-IP-Routing-Table, RIB-failure(17))
Advertised to update-groups:
1
Local, (Received from a RR-client)
13.1.1.1 (metric 156160) from 14.1.1.1 (14.1.4.1)
Origin IGP, metric 0, localpref 100, valid, internal
Originator: 13.1.4.1, Cluster list: 14.1.4.1
Local, (Received from a RR-client)
13.1.1.1 (metric 156160) from 13.1.1.1 (13.1.4.1)
Origin IGP, metric 0, localpref 100, valid, internal, best
R3(config)#router bgp 1234
R3(config-router)#neighbor 12.1.1.1 remote-as 1234
R3(config-router)#neighbor 12.1.1.1 update-source loopback 1
R3(config-router)#neighbor 14.1.1.1 remote-as 1234
R3(config-router)#neighbor 14.1.1.1 update-source loopback 1
R3(config-router)#network 13.1.1.0 mask 255.255.255.0
R3(config-router)#network 13.1.2.0 mask 255.255.255.0
R3(config-router)#network 13.1.3.0 mask 255.255.255.0
R3(config-router)#network 13.1.4.0 mask 255.255.255.0
R3(config-router)#no auto-summary
R3(config-router)#no syn
R3(config-router)#exit
*Nov 19 14:01:30.155: %BGP-5-ADJCHANGE: neighbor 12.1.1.1 Up
*Nov 19 14:02:22.283: %BGP-5-ADJCHANGE: neighbor 14.1.1.1 Up
R4-RR-SERVER-2-(config)#router bgp 1234
R4-RR-SERVER-2-(config-router)#neighbor 11.1.1.1 remote-as 1234
R4-RR-SERVER-2-(config-router)#neighbor 11.1.1.1 update-source loopback 1
R4-RR-SERVER-2-(config-router)#neighbor 11.1.1.1 route-reflector-client
R4-RR-SERVER-2-(config-router)#neighbor 13.1.1.1 remote-as 1234
R4-RR-SERVER-2-(config-router)#neighbor 13.1.1.1 update-source loopback 1
R4-RR-SERVER-2-(config-router)#neighbor 13.1.1.1 route-reflector-client
R4-RR-SERVER-2-(config-router)#neighbor 12.1.1.1 remote-as 1234
R4-RR-SERVER-2-(config-router)#neighbor 12.1.1.1 update-source loopback 1
R4-RR-SERVER-2-(config-router)#neighbor 12.1.1.1 route-reflector-client
R4-RR-SERVER-2-(config-router)#network 14.1.1.0 mask 255.255.255.0
R4-RR-SERVER-2-(config-router)#network 14.1.2.0 mask 255.255.255.0
R4-RR-SERVER-2-(config-router)#network 14.1.3.0 mask 255.255.255.0
R4-RR-SERVER-2-(config-router)#network 14.1.4.0 mask 255.255.255.0
R4-RR-SERVER-2-(config-router)#no auto-summary
R4-RR-SERVER-2-(config-router)#no syn
R4-RR-SERVER-2-(config-router)#exit
*Nov 19 13:59:46.751: %BGP-5-ADJCHANGE: neighbor 12.1.1.1 Up
*Nov 19 13:59:52.739: %BGP-5-ADJCHANGE: neighbor 11.1.1.1 Up
*Nov 19 14:00:02.683: %BGP-5-ADJCHANGE: neighbor 13.1.1.1 Up
R4-RR-SERVER-2-#show ip bgp summary | begin network
16 network entries using 1872 bytes of memory
24 path entries using 1248 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
2 BGP rrinfo entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 3540 total bytes of memory
BGP activity 16/0 prefixes, 24/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
11.1.1.1 4 1234 25 28 29 0 0 00:20:51 4
12.1.1.1 4 1234 28 28 29 0 0 00:20:57 12
13.1.1.1 4 1234 25 28 29 0 0 00:20:41 4
configuration of RR Cluster
configure BGP 65100 and advertise only loopback. configure router 5 and 7 RR server.
R5(config)#router bgp 65100
R5(config-router)#bgp router-id 50.1.1.1
R5(config-router)#neighbor 90.1.1.1 remote-as 65100
R5(config-router)#neighbor 90.1.1.1 update-source loopback 1
R5(config-router)#neighbor 90.1.1.1 route-reflector-client
R5(config-router)#network 50.0.0.0
R5(config-router)#neighbor 70.1.1.1 remote-as 65100
R5(config-router)#neighbor 70.1.1.1 update-source loopback 1
R5(config-router)#neighbor 70.1.1.1 route-reflector-client
R5(config-router)#no auto-summary
R5(config-router)#no syn
R5(config-router)#exit
*Nov 19 14:49:06.599: %BGP-5-ADJCHANGE: neighbor 90.1.1.1 Up
*Nov 19 14:49:06.711: %BGP-5-ADJCHANGE: neighbor 70.1.1.1 Up
R6(config)#router bgp 65100
R6(config-router)#bgp router-id 60.1.1.1
R6(config-router)#neighbor 70.1.1.1 remote-as 65100
R6(config-router)#neighbor 70.1.1.1 update-source loopback 1
R6(config-router)#network 60.0.0.0
R6(config-router)#no auto-summary
R6(config-router)#no syn
R6(config-router)#exit
*Nov 19 14:32:40.643: %BGP-5-ADJCHANGE: neighbor 70.1.1.1 Up
R7(config)#router bgp 65100
R7(config-router)#bgp router-id 70.1.1.1
R7(config-router)#neighbor 60.1.1.1 remote-as 65100
R7(config-router)#neighbor 60.1.1.1 update-source loopback 1
R7(config-router)#neighbor 60.1.1.1 route-reflector-client
R7(config-router)#neighbor 80.1.1.1 remote-as 65100
R7(config-router)#neighbor 80.1.1.1 update-source loopback 1
R7(config-router)#neighbor 80.1.1.1 route-reflector-client
R7(config-router)#neighbor 50.1.1.1 remote-as 65100
R7(config-router)#neighbor 50.1.1.1 update-source loopback 1
R7(config-router)#neighbor 50.1.1.1 route-reflector-client
R7(config-router)#network 70.0.0.0
R7(config-router)#no auto-summary
R7(config-router)#no syn
R7(config-router)#exit
*Nov 19 14:31:25.519: %BGP-5-ADJCHANGE: neighbor 80.1.1.1 Up
*Nov 19 14:31:25.915: %BGP-5-ADJCHANGE: neighbor 50.1.1.1 Up
*Nov 19 14:31:15.191: %BGP-5-ADJCHANGE: neighbor 60.1.1.1 Up
R8(config)#router bgp 65100
R8(config-router)#bgp router-id 80.1.1.1
R8(config-router)#neighbor 70.1.1.1 remote-as 65100
R8(config-router)#neighbor 70.1.1.1 update-source loopback 1
R8(config-router)#network 80.0.0.0
R8(config-router)#no auto-summary
R8(config-router)#no syn
R8(config-router)#exit
*Nov 19 14:30:29.163: %BGP-5-ADJCHANGE: neighbor 70.1.1.1 Up
R9(config)#router bgp 65100
R9(config-router)#bgp router-id 90.1.1.1
R9(config-router)#neighbor 50.1.1.1 remote-as 65100
R9(config-router)#neighbor 50.1.1.1 update-source loopback 1
R9(config-router)#network 90.0.0.0
R9(config-router)#no auto-summary
R9(config-router)#no syn
R9(config-router)#exit
*Nov 19 14:35:08.179: %BGP-5-ADJCHANGE: neighbor 50.1.1.1 Up
configure the Cluster- 10.10.10.10 on router-5 Cluster-id 30.30.30.30 on router-7
R5(config)#router bgp 65100
R5(config-router)#bgp cluster-id 10.10.10.10
R5(config-router)#do clear ip bgp * soft
R7(config)#router bgp 65100
R7(config-router)#bgp cluster-id 30.30.30.30
R7(config-router)#do clear ip bgp *
R9#show ip bgp
BGP table version is 22, local router ID is 90.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
r>i50.0.0.0 50.1.1.1 0 100 0 i
r>i60.0.0.0 60.1.1.1 0 100 0 i
r>i70.0.0.0 70.1.1.1 0 100 0 i
r>i80.0.0.0 80.1.1.1 0 100 0 i
*> 90.0.0.0 0.0.0.0 0 32768 I
R9#show ip bgp summary
BGP router identifier 90.1.1.1, local AS number 65100
BGP table version is 22, main routing table version 22
5 network entries using 585 bytes of memory
5 path entries using 260 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
3 BGP rrinfo entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1289 total bytes of memory
BGP activity 10/5 prefixes, 17/12 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
50.1.1.1 4 65100 62 41 22 0 0 00:03:19 4
R5#show ip bgp summary
BGP router identifier 50.1.1.1, local AS number 65100
BGP table version is 25, main routing table version 25
5 network entries using 585 bytes of memory
5 path entries using 260 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
2 BGP rrinfo entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1265 total bytes of memory
BGP activity 12/7 prefixes, 15/10 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
70.1.1.1 4 65100 66 68 25 0 0 00:03:33 3
90.1.1.1 4 65100 41 62 25 0 0 00:03:54 1
R5#show ip bgp 80.1.1.1
BGP routing table entry for 80.0.0.0/8, version 23
Paths: (1 available, best #1, table Default-IP-Routing-Table, RIB-failure(17))
Advertised to update-groups:
1
Local, (Received from a RR-client)
80.1.1.1 (metric 161280) from 70.1.1.1 (70.1.1.1)
Origin IGP, metric 0, localpref 100, valid, internal, best
Originator: 80.1.1.1, Cluster list: 30.30.30.30
R7#show ip bgp 90.1.1.1
BGP routing table entry for 90.0.0.0/8, version 5
Paths: (1 available, best #1, table Default-IP-Routing-Table, RIB-failure(17))
Advertised to update-groups:
1
Local, (Received from a RR-client)
90.1.1.1 (metric 161280) from 50.1.1.1 (50.1.1.1)
Origin IGP, metric 0, localpref 100, valid, internal, best
Originator: 90.1.1.1, Cluster list: 10.10.10.10
configure EBGP neighbor between router-2 and router-8
RR-SERVER-(config)#router bgp 1234
RR-SERVER-(config-router)#neighbor 28.1.1.2 remote-as 65100
RR-SERVER-(config-router)#network 28.0.0.0
RR-SERVER-(config-router)#no auto-summary
RR-SERVER-(config-router)#no syn
RR-SERVER-(config-router)#exit
*Nov 19 14:27:54.555: %BGP-5-ADJCHANGE: neighbor 28.1.1.2 Up
R8(config)#router bgp 65100
R8(config-router)#neighbor 28.1.1.1 remote-as 1234
R8(config-router)#network 28.0.0.0
R8(config-router)#no auto-summary
R8(config-router)#no syn
R8(config-router)#exit
*Nov 19 14:44:19.187: %BGP-5-ADJCHANGE: neighbor 28.1.1.1 Up
RR-SERVER-#show ip bgp summary
BGP router identifier 12.1.4.1, local AS number 1234
BGP table version is 35, main routing table version 35
22 network entries using 2574 bytes of memory
31 path entries using 1612 bytes of memory
5/4 BGP path/bestpath attribute entries using 620 bytes of memory
2 BGP rrinfo entries using 48 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 4878 total bytes of memory
BGP activity 22/0 prefixes, 31/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
11.1.1.1 4 1234 33 39 35 0 0 00:29:31 4
13.1.1.1 4 1234 33 39 35 0 0 00:29:27 4
14.1.1.1 4 1234 38 39 35 0 0 00:28:51 12
28.1.1.2 4 65100 7 7 35 0 0 00:01:13 6
R8#show ip bgp summary
BGP router identifier 80.1.1.1, local AS number 65100
BGP table version is 27, main routing table version 27
22 network entries using 2574 bytes of memory
23 path entries using 1196 bytes of memory
5/4 BGP path/bestpath attribute entries using 620 bytes of memory
3 BGP rrinfo entries using 72 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 4486 total bytes of memory
BGP activity 28/6 prefixes, 32/9 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
28.1.1.1 4 1234 7 7 27 0 0 00:01:34 17
70.1.1.1 4 65100 81 59 27 0 0 00:15:24 4
R8#show ip bgp
BGP table version is 27, local router ID is 80.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 11.1.1.0/24 28.1.1.1 0 1234 i
*> 11.1.2.0/24 28.1.1.1 0 1234 i
*> 11.1.3.0/24 28.1.1.1 0 1234 i
*> 11.1.4.0/24 28.1.1.1 0 1234 i
*> 12.1.1.0/24 28.1.1.1 0 0 1234 i
*> 12.1.2.0/24 28.1.1.1 0 0 1234 i
*> 12.1.3.0/24 28.1.1.1 0 0 1234 i
*> 12.1.4.0/24 28.1.1.1 0 0 1234 i
*> 13.1.1.0/24 28.1.1.1 0 1234 i
*> 13.1.2.0/24 28.1.1.1 0 1234 i
*> 13.1.3.0/24 28.1.1.1 0 1234 i
*> 13.1.4.0/24 28.1.1.1 0 1234 i
*> 14.1.1.0/24 28.1.1.1 0 1234 i
*> 14.1.2.0/24 28.1.1.1 0 1234 i
*> 14.1.3.0/24 28.1.1.1 0 1234 i
*> 14.1.4.0/24 28.1.1.1 0 1234 i
* 28.0.0.0 28.1.1.1 0 0 1234 i
*> 0.0.0.0 0 32768 i
r>i50.0.0.0 50.1.1.1 0 100 0 i
r>i60.0.0.0 60.1.1.1 0 100 0 i
r>i70.0.0.0 70.1.1.1 0 100 0 i
*> 80.0.0.0 0.0.0.0 0 32768 i
r>i90.0.0.0 90.1.1.1 0 100 0 i
RR-SERVER-#show ip bgp
BGP table version is 35, local router ID is 12.1.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
r i11.1.1.0/24 11.1.1.1 0 100 0 i
r>i 11.1.1.1 0 100 0 i
r i11.1.2.0/24 11.1.1.1 0 100 0 i
r>i 11.1.1.1 0 100 0 i
r i11.1.3.0/24 11.1.1.1 0 100 0 i
r>i 11.1.1.1 0 100 0 i
r i11.1.4.0/24 11.1.1.1 0 100 0 i
r>i 11.1.1.1 0 100 0 i
*> 12.1.1.0/24 0.0.0.0 0 32768 i
*> 12.1.2.0/24 0.0.0.0 0 32768 i
*> 12.1.3.0/24 0.0.0.0 0 32768 i
*> 12.1.4.0/24 0.0.0.0 0 32768 i
r i13.1.1.0/24 13.1.1.1 0 100 0 i
r>i 13.1.1.1 0 100 0 i
r i13.1.2.0/24 13.1.1.1 0 100 0 i
r>i 13.1.1.1 0 100 0 i
r i13.1.3.0/24 13.1.1.1 0 100 0 i
r>i 13.1.1.1 0 100 0 i
r i13.1.4.0/24 13.1.1.1 0 100 0 i
r>i 13.1.1.1 0 100 0 i
r>i14.1.1.0/24 14.1.1.1 0 100 0 i
r>i14.1.2.0/24 14.1.1.1 0 100 0 i
r>i14.1.3.0/24 14.1.1.1 0 100 0 i
r>i14.1.4.0/24 14.1.1.1 0 100 0 i
* 28.0.0.0 28.1.1.2 0 0 65100 i
*> 0.0.0.0 0 32768 i
*> 50.0.0.0 28.1.1.2 0 65100 i
*> 60.0.0.0 28.1.1.2 0 65100 i
*> 70.0.0.0 28.1.1.2 0 65100 i
*> 80.0.0.0 28.1.1.2 0 0 65100 i
*> 90.0.0.0 28.1.1.2 0 65100 i
R8#traceroute 11.1.1.1
Type escape sequence to abort.
Tracing the route to 11.1.1.1
1 28.1.1.1 20 msec 32 msec 32 msec
2 192.168.12.1 64 msec 68 msec 60 msec
R8#ping 11.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/64/76 ms
No comments:
Post a Comment