DONATE


OSPF Autonomous system network map configuration


In this section we will see the configuration of OSPF Autonomous system map.

lets begin our OSPF autonomous system network map configuration. 

Topology:-

GOAL:
  • configure the topology as diagram 
  • assign IP addresses respectively as per the topology
  • configure OSPF in autonomous system 100 
  • advertise all interfaces
  • configure redistribution on router 5 (ASBR) 
  • configure EIGRP Autonomous system 110 on router 6
  • ensure all OSPF routers get external routes  in there table 
  • ensure connectivity, router 1 can ping router 6


R1(config)#interface ethernet 2/0
R1(config-if)#ip address 1.1.1.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 10.1.1.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#no keepalive
R1(config-if)#exit


R2(config)#interface ethernet 2/1
R2(config-if)#ip address 2.2.2.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 20.1.1.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit

                      #interface ethernet 2/0
R3(config-if)#ip address 1.1.1.2 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit

R3(config)#interface ethernet 2/1
R3(config-if)#ip address 2.2.2.2 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit

R3(config)#interface fastEthernet 0/0
R3(config-if)#ip address 30.1.1.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit


R3(config)#interface serial 3/0
R3(config-if)#ip address 3.3.3.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit

R4(config)#interface serial 3/0
R4(config-if)#ip address 3.3.3.2 255.0.0.0
R4(config-if)#no shutdown
R4(config-if)#exit

R4(config)#interface fastEthernet 0/0
R4(config-if)#ip address 40.1.1.1 255.0.0.0
R4(config-if)#no shutdown
R4(config-if)#exit

R4(config)#interface ethernet 2/0
R4(config-if)#ip address 4.4.4.1 255.0.0.0
R4(config-if)#no shutdown
R4(config-if)#exit


R5(config)#interface ethernet 2/0
R5(config-if)#ip address 4.4.4.2 255.0.0.0
R5(config-if)#no shutdown
R5(config-if)#exit

R5(config)#interface serial 3/0
R5(config-if)#ip address 11.0.0.6 255.0.0.0
R5(config-if)#no shutdown
R5(config-if)#exit

R5(config)#interface fastEthernet 0/0
R5(config-if)#ip address 50.1.1.1 255.0.0.0
R5(config-if)#no shutdown
R5(config-if)#no keepalive
R5(config-if)#exit

R6(config)#interface serial 3/0
R6(config-if)#no shutdown
R6(config-if)#exit

R6(config)#interface fastEthernet 0/0
R6(config-if)#ip address 60.1.1.1 255.0.0.0
R6(config-if)#no shutdown
R6(config-if)#exit

R1(config)#router ospf 100
R1(config-router)#network 10.0.0.0 0.255.255.255 area 1
R1(config-router)#network 1.0.0.0 0.255.255.255 area 1
R1(config-router)#exit

R2(config)#router ospf 100
R2(config-router)#network 20.0.0.0 0.255.255.255 area 1
R2(config-router)#network 2.0.0.0 0.255.255.255 area 1
R2(config-router)#exit

R3(config)#router ospf 100
R3(config-router)#network 1.0.0.0 0.255.255.255 area 1
R3(config-router)#network 2.0.0.0 0.255.255.255 area 1
R3(config-router)#network 30.0.0.0 0.255.255.255 area 1
R3(config-router)#network 3.0.0.0 0.255.255.255 area 0
R3(config-router)#exit

R4(config)#router ospf 100
R4(config-router)#network 3.0.0.0 0.255.255.255 area 0
R4(config-router)#network 40.0.0.0 0.255.255.255 area 0
R4(config-router)#network 4.0.0.0 0.255.255.255 area 0
R4(config-router)#exit

R5(config)#router ospf 100

R5(config-router)#network 4.0.0.0 0.255.255.255 area 0
R5(config-router)#network .0.0.0 0.255.255.255 area 0

*Oct 14 07:12:15.899: %OSPF-5-ADJCHG: Process 100, Nbr 40.1.1.1 on Ethernet2/0 from LOADING to FULL, Loading Done

R5(config-router)#network 11.0.0.0 0.255.255.255 area 0
R5(config-router)#network 50.0.0.0 0.255.255.255 area 0
R5(config-router)#redistribute eigrp 110 metric-type 1
R5(config-router)#exit


R5(config)#router ospf 100
R5(config-router)#network 4.0.0.0 0.255.255.255 area 0

*Oct 14 07:28:18.487: %OSPF-5-ADJCHG: Process 100, Nbr 40.1.1.1 on Ethernet2/0 from LOADING to FULL, Loading D                                                          one

R5(config-router)#network 50.0.0.0 0.255.255.255 area 0
R5(config-router)#exit

R5(config)#router eigrp 110
R5(config-router)#network 11.0.0.0

*Oct 14 07:28:52.963: %DUAL-5-NBRCHANGE: EIGRP-IPv4 110: Neighbor 11.0.0.5 (Serial3/0) is up: new adjacency

R5(config-router)#redistribute ospf 100 metric 1500 100 100 100 1500
R5(config-router)#exit

R5(config)#router ospf 100
R5(config-router)#redistribute eigrp 110 subnets metric-type 1
R5(config-router)#exit

R6(config)#router eigrp 110
R6(config-router)#network 60.0.0.0
R6(config-router)#network 11.0.0.0

*Oct 14 07:28:19.359: %DUAL-5-NBRCHANGE: EIGRP-IPv4 110: Neighbor 11.0.0.6 (Serial3/0) is up: new adjacency

R6(config-router)#exit

R1#show ip route ospf 100
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O     2.0.0.0/8 [110/20] via 1.1.1.2, 00:34:21, Ethernet2/0
O IA  3.0.0.0/8 [110/74] via 1.1.1.2, 00:28:20, Ethernet2/0
O IA  4.0.0.0/8 [110/84] via 1.1.1.2, 00:28:20, Ethernet2/0
O E1  11.0.0.0/8 [110/104] via 1.1.1.2, 00:12:23, Ethernet2/0
O IA  40.0.0.0/8 [110/75] via 1.1.1.2, 00:28:20, Ethernet2/0
O IA  50.0.0.0/8 [110/85] via 1.1.1.2, 00:14:26, Ethernet2/0
O E1  60.0.0.0/8 [110/104] via 1.1.1.2, 00:00:34, Ethernet2/0


R2#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O     1.0.0.0/8 [110/20] via 2.2.2.2, 00:35:13, Ethernet2/1
O IA  3.0.0.0/8 [110/74] via 2.2.2.2, 00:29:14, Ethernet2/1
O IA  4.0.0.0/8 [110/84] via 2.2.2.2, 00:29:14, Ethernet2/1
O     10.0.0.0/8 [110/21] via 2.2.2.2, 00:35:13, Ethernet2/1
O E1  11.0.0.0/8 [110/104] via 2.2.2.2, 00:13:18, Ethernet2/1
O IA  40.0.0.0/8 [110/75] via 2.2.2.2, 00:29:14, Ethernet2/1
O IA  50.0.0.0/8 [110/85] via 2.2.2.2, 00:15:21, Ethernet2/1
O E1  60.0.0.0/8 [110/104] via 2.2.2.2, 00:01:28, Ethernet2/1

R3#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O     4.0.0.0/8 [110/74] via 3.3.3.2, 00:29:53, Serial3/0
O     10.0.0.0/8 [110/11] via 1.1.1.1, 00:30:03, Ethernet2/0
O E1  11.0.0.0/8 [110/94] via 3.3.3.2, 00:14:01, Serial3/0
O     40.0.0.0/8 [110/65] via 3.3.3.2, 00:29:53, Serial3/0
O     50.0.0.0/8 [110/75] via 3.3.3.2, 00:15:59, Serial3/0
O E1  60.0.0.0/8 [110/94] via 3.3.3.2, 00:02:06, Serial3/0

R4#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O IA  1.0.0.0/8 [110/74] via 3.3.3.1, 00:30:24, Serial3/0
O IA  2.0.0.0/8 [110/74] via 3.3.3.1, 00:30:24, Serial3/0
O IA  10.0.0.0/8 [110/75] via 3.3.3.1, 00:30:24, Serial3/0
O E1  11.0.0.0/8 [110/30] via 4.4.4.2, 00:14:28, Ethernet2/0
O     50.0.0.0/8 [110/11] via 4.4.4.2, 00:16:27, Ethernet2/0
O E1  60.0.0.0/8 [110/30] via 4.4.4.2, 00:02:34, Ethernet2/0

R5#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

O IA  1.0.0.0/8 [110/84] via 4.4.4.1, 00:18:06, Ethernet2/0
O IA  2.0.0.0/8 [110/84] via 4.4.4.1, 00:18:06, Ethernet2/0
O     3.0.0.0/8 [110/74] via 4.4.4.1, 00:18:06, Ethernet2/0
      4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        4.0.0.0/8 is directly connected, Ethernet2/0
L        4.4.4.2/32 is directly connected, Ethernet2/0
O IA  10.0.0.0/8 [110/85] via 4.4.4.1, 00:18:06, Ethernet2/0
      11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        11.0.0.0/8 is directly connected, Serial3/0
L        11.0.0.6/32 is directly connected, Serial3/0
O     40.0.0.0/8 [110/11] via 4.4.4.1, 00:18:06, Ethernet2/0
      50.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        50.0.0.0/8 is directly connected, FastEthernet0/0
L        50.1.1.1/32 is directly connected, FastEthernet0/0
D     60.0.0.0/8 [90/2172416] via 11.0.0.5, 00:03:59, Serial3/0

R6#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

D EX  1.0.0.0/8 [170/2244096] via 11.0.0.6, 00:14:24, Serial3/0
D EX  2.0.0.0/8 [170/2244096] via 11.0.0.6, 00:14:24, Serial3/0
D EX  3.0.0.0/8 [170/2244096] via 11.0.0.6, 00:14:24, Serial3/0
D EX  4.0.0.0/8 [170/2244096] via 11.0.0.6, 00:14:24, Serial3/0
D EX  10.0.0.0/8 [170/2244096] via 11.0.0.6, 00:14:24, Serial3/0
      11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        11.0.0.0/8 is directly connected, Serial3/0
L        11.0.0.5/32 is directly connected, Serial3/0
D EX  40.0.0.0/8 [170/2244096] via 11.0.0.6, 00:14:24, Serial3/0
D EX  50.0.0.0/8 [170/2244096] via 11.0.0.6, 00:14:24, Serial3/0
      60.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        60.0.0.0/8 is directly connected, FastEthernet0/0
L        60.1.1.1/32 is directly connected, FastEthernet0/0


R5#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "ospf 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 50.1.1.1
  It is an autonomous system boundary router
 Redistributing External Routes from,
    eigrp 110, includes subnets in redistribution
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    4.0.0.0 0.255.255.255 area 0
    50.0.0.0 0.255.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    30.1.1.1             110      00:20:04
    40.1.1.1             110      00:20:04
  Distance: (default is 110)

Routing Protocol is "eigrp 110"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  Redistributing: ospf 100
  EIGRP-IPv4 Protocol for AS(110)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 50.1.1.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    11.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    11.0.0.5              90      00:05:57
  Distance: internal 90 external 170

R1#ping 60.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 60.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 276/309/356 ms

R1#traceroute 60.1.1.1
Type escape sequence to abort.
Tracing the route to 60.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 1.1.1.2 68 msec 128 msec 76 msec
  2 3.3.3.2 180 msec 152 msec 132 msec
  3 4.4.4.2 220 msec 220 msec 216 msec
  4 11.0.0.5 292 msec 224 msec 296 msec


R2#ping 60.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 60.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 252/292/348 ms

R2#traceroute 60.1.1.1
Type escape sequence to abort.
Tracing the route to 60.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 2.2.2.2 60 msec 68 msec 116 msec
  2 3.3.3.2 132 msec 132 msec 140 msec
  3 4.4.4.2 236 msec 248 msec 216 msec
  4 11.0.0.5 284 msec 312 msec 272 msec

R3#ping 60.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 60.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 192/232/268 ms

R3#traceroute 60.1.1.1
Type escape sequence to abort.
Tracing the route to 60.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 3.3.3.2 76 msec 88 msec 84 msec
  2 4.4.4.2 156 msec 172 msec 144 msec
  3 11.0.0.5 224 msec 184 msec 204 msec

R4#ping 60.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 60.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 108/136/176 ms

R4#traceroute 60.1.1.1
Type escape sequence to abort.
Tracing the route to 60.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 4.4.4.2 108 msec 64 msec 52 msec
  2 11.0.0.5 120 msec 80 msec 168 msec

R5#ping 60.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 60.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/74/108 ms

R5#traceroute 60.1.1.1
Type escape sequence to abort.
Tracing the route to 60.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 11.0.0.5 52 msec 140 msec 64 msec

R6#ping 10.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 232/268/336 ms

R6#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 11.0.0.6 36 msec 100 msec 104 msec
  2 4.4.4.1 168 msec 144 msec 140 msec
  3 3.3.3.1 188 msec 224 msec 244 msec
  4 1.1.1.1 308 msec 280 msec 224 msec

No comments:

Post a Comment

How to configure DHCP Snooping on switch, DHCP Server on router, SVI Inter-VLAN-routing, BPDU Guard, Root-Guard, Port-fast, Dot1q and Port-channel pagp?

In this section, we are going to configure some important topics DHCP Snooping on the switch, DHCP Server on the router, SVI Inter-VLAN-rout...

INSTAGRAM FEED

@Edger C Francis