DONATE


Route Redistribution PPP Multilink mock configuration



Route redistribution with PPP Multilink 

Route redistribution allows us to take routes from one routing protocol and install those routes into different routing protocol. By default router only advertise same routing protocol within the same AS. So we need redistribution to inject different routing protocol routes into our network routing protocol.
In other words Redistribution is the process of exchanging routing information between different routing protocols.

We can use redistribution when we using multiple protocols or migrating to a more advance routing, we can use redistribution if you having mismatch between devices (vendors) or political boundaries.

Note: internal routes are routes advertised within the same protocol.

          External routes are routes which get redistributed.

Multilink PPP help us to combine (bundle) of multiple physical serial links into a single logical link. You will only need one single subnet for the logical multilink PPP interface and if we use EIGRP or OSPF only a single neighbor adjacency is required. Multilink PPP does load balancing on layer 2. This is pretty good.


lets see the configuration:-










  • Configure the topology as per the diagram; we are using four serial range 3/0 to 3/3 between router 1 and router 2. Configure bundle of four more serial links 3/4 to 3/7 between router 2 and router 3.
  • Configure single logical link, group number 1 between router 1 and router 2.
  • Configure single logical link, group number 2  between router 2 and router 3
  • Configure channel ip address 192.168.1.0/24 between router 1 and router 2
  • Configure channel ip address 192.168.2.0/24 between router 2 and router 3
  •  Configure loopbacks as per the diagram
  • Configure RIP, OSPF and EIGRP as per the topology and advertise networks as per the topology
  • Configure redistribution and make sure the entire routers  get all the networks 



R1(config)#Interface fastethernet 0/0
R1(config-if)#Ip address 10.1.1.1 255.255.255.0
R1(config-if)#No keepalive
R1(config-if)#No shutdown
R1(config-if)#Exit

R1(config)#Interface loopback 0
R1(config-if)#Ip address 11.0.0.1 255.255.255.0
R1(config-if)#Interface loopback 1
R1(config-if)#Ip address 11.0.1.1 255.255.255.0
R1(config-if)#exit

R1(config)#Interface loopback 2
R1(config-if)#Ip address 11.0.2.1 255.255.255.0
R1(config-if)#exit

R1(config)#Interface loopback 3
R1(config-if)#Ip address 11.0.3.1 255.255.25
R1(config-if)#exit

R1(config)#Interface multilink 1
R1(config-if)#Ppp multilink group 1
R1(config-if)#Ip address 192.168.1.1  255.255.255.0
R1(config-if)#Exit

R1(config)#Interface serial 3/0
R1(config-if)#No ip address
R1(config-if)#Encapsulation ppp
R1(config-if)#Ppp multilink
R1(config-if)#Ppp multilink group 1
R1(config-if)#No shutdown
R1(config-if)#Exit

R1(config)#Interface serial 3/1
R1(config-if)#No ip address
R1(config-if)#Encapsulation ppp
R1(config-if)#Ppp multilink
R1(config-if)#Ppp multilink group 1
R1(config-if)#No shutdown
R1(config-if)#Exit

R1(config)#Interface serial 3/2
R1(config-if)#No ip address
R1(config-if)#Encapsulation ppp
R1(config-if)#Ppp multilink
R1(config-if)#Ppp multilink group 1
R1(config-if)#No shutdown
R1(config-if)#Exit

R1(config)#Interface serial 3/3
R1(config-if)#No ip address
R1(config-if)#Encapsulation ppp
R1(config-if)#Ppp multilink
R1(config-if)#Ppp multilink group 1
R1(config-if)#No shutdown
R1(config-if)#Exit

R2(config)#Interface fastethernet 0/0
R2(config-if)#Ip address 20.1.1.1 255.255.255.0
R2(config-if)#No keepalive
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface loopback 0
R2(config-if)#Ip address 12.0.0.1 255.255.255.0
R2(config-if)#Interface loopback 1
R2(config-if)#Ip address 12.0.1.1 255.255.255.0
R2(config-if)#exit

R2(config)#Interface loopback 2
R2(config-if)#Ip address 12.0.2.1 255.255.255.0
R2(config-if)#exit

R2(config)#Interface loopback 3
R2(config-if)#Ip address 12.0.3.1 255.255.255.0
R2(config-if)#exit

R2(config)#Interface multilink 1
R2(config-if)#Ip address 192.168.1.2  255.255.255.0
R2(config-if)#Exit

R2(config)#Interface serial 3/0
R2(config-if)#No ip address
R2(config-if)#Encapsulation ppp
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink group 1
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/1
R2(config-if)#No ip address
R2(config-if)#Encapsulation ppp
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink group 1
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/2
R2(config-if)#No ip address
R2(config-if)#Encapsulation ppp
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink group 1
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/3
R2(config-if)#No ip address
R2(config-if)#Encapsula
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink group 1
R2(config-if)#No shutdown
R2(config-if)#Exit


R2(config)#Interface multilink 2
R2(config-if)#Ppp multilink group 2
R2(config-if)#Ip address 192.168.2.1  255.255.255.0
R2(config-if)#Exit

R2(config)#Interface serial 3/4
R2(config-if)#No ip address
R2(config-if)#Encapsulation ppp
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink group 2
R2(config-if)#No shutdown
R2(config-if)#Exit
R2(config)#Interface serial 3/5
R2(config-if)#No ip address
R2(config-if)#Encapsulation ppp
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink group 2
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/6
R2(config-if)#No ip address
R2(config-if)#Encapsulation ppp
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink group 2
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/7
R2(config-if)#No ip address
R2(config-if)#Encapsulation ppp
R2(config-if)#Ppp multilink
R2(config-if)#Ppp multilink group 2
R2(config-if)#No shutdown
R2(config-if)#Exit


R3(config)#Interface fastethernet 0/0
R3(config-if)#Ip address 30.1.1.1 255.255.255.0
R3(config-if)#No keepalive
R3(config-if)#No shutdown
R3(config-if)#Exit

R3(config)#Interface loopback 0
R3(config-if)#Ip address 13.0.0.1 255.255.255.0
R3(config-if)#Interface loopback 1
R3(config-if)#Ip address 13.0.1.1 255.255.255.0
R3(config-if)#exit

R3(config)#Interface loopback 2
R3(config-if)#Ip address 13.0.2.1 255.255.255.0
R3(config-if)#exit

R3(config)#Interface loopback 3
R3(config-if)#Ip address 13.0.3.1 255.255.255.0
R3(config-if)#exit

R3(config)#Interface multilink 2
R3(config-if)#Ppp multilink group 2
R3(config-if)#Ip address 192.168.2.2  255.255.255.0
R3(config-if)#Exit

R3(config)#Interface serial 3/4
R3(config-if)#No ip address
R3(config-if)#Encapsulation ppp
R3(config-if)#Ppp multilink
R3(config-if)#Ppp multilink group 2
R3(config-if)#No shutdown
R3(config-if)#Exit

R3(config)#Interface serial 3/5
R3(config-if)#No ip address
R3(config-if)#Encapsulation ppp
R3(config-if)#Ppp multilink
R3(config-if)#Ppp multilink group 2
R3(config-if)#No shutdown
R3(config-if)#Exit

R3(config)#Interface serial 3/6
R3(config-if)#No ip address
R3(config-if)#Encapsulation ppp
R3(config-if)#Ppp multilink group 2
R3(config-if)#No shutdown
R3(config-if)#Exit

R3(config)#Interface serial 3/7
R3(config-if)#No ip address
R3(config-if)#Encapsulation ppp
R3(config-if)#Ppp multilink group 2
R3(config-if)#No shutdown
R3(config-if)#Exit

 R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up

Serial3/0              unassigned      YES unset  up                    up
Serial3/1              unassigned      YES unset  up                    up
Serial3/2              unassigned      YES unset  up                    up
Serial3/3              unassigned      YES unset  up                    up
Loopback0              11.0.0.1        YES manual up                    up
Loopback1              11.0.1.1        YES manual up                    up
Loopback2              11.0.2.1        YES manual up                    up
Loopback3              11.0.3.1        YES manual up                    up
Multilink1             192.168.1.1     YES manual up                    up


R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up

Serial3/0              unassigned      YES unset  up                    up
Serial3/1              unassigned      YES unset  up                    up
Serial3/2              unassigned      YES unset  up                    up
Serial3/3              unassigned      YES unset  up                    up
Serial3/4              unassigned      YES unset  up                    up
Serial3/5              unassigned      YES unset  up                    up
Serial3/6              unassigned      YES unset  up                    up
Serial3/7              unassigned      YES unset  up                    up
Loopback0              12.0.0.1        YES manual up                    up
Loopback1              12.0.1.1        YES manual up                    up
Loopback2              12.0.2.1        YES manual up                    up
Loopback3              12.0.3.1        YES manual up                    up
Multilink1             192.168.1.2     YES manual up                    up
Multilink2             192.168.2.1     YES manual up                    up



R3#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/4              unassigned      YES unset  up                    up
Serial3/5              unassigned      YES unset  up                    up
Serial3/6              unassigned      YES unset  up                    up
Serial3/7              unassigned      YES unset  up                    up
Loopback0              13.0.0.1        YES manual up                    up
Loopback1              13.0.1.1        YES manual up                    up
Loopback2              13.0.2.1        YES manual up                    up
Loopback3              13.0.3.1        YES manual up                    up
Multilink2             192.168.2.2     YES manual up                    up

R1#show interfaces multilink 1
Multilink1 is up, line protocol is up
  Hardware is multilink group interface
  Internet address is 192.168.1.1/24
  MTU 1500 bytes, BW 6176 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Open



R1#show run interface multilink 1
Building configuration...

Current configuration : 104 bytes
!
interface Multilink1
 ip address 192.168.1.1 255.255.255.0
 ppp multilink
 ppp multilink group 1
end

R2#  show interfaces multilink 1
Multilink1 is up, line protocol is up
  Hardware is multilink group interface
  Internet address is 192.168.1.2/24
  MTU 1500 bytes, BW 6176 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Open
R2# show run interface multilink 1
Building configuration...

Current configuration : 104 bytes
!
interface Multilink1
 ip address 192.168.1.2 255.255.255.0
 ppp multilink
 ppp multilink group 1
end


R3#  show interfaces multilink 2
Multilink2 is up, line protocol is up
  Hardware is multilink group interface
  Internet address is 192.168.2.2/24
  MTU 1500 bytes, BW 6176 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Open



R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 11.0.0.0
R1(config-router)#network 11.0.1.0
R1(config-router)#network 11.0.2.0
R1(config-router)#network 11.0.3.0
R1(config-router)#no auto-summary
R1(config-router)#exit

R1(config)#router eigrp 100
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#exit

R1(config)#router ospf 1
R1(config-router)#network 192.168.1.0 255.0.0.0 area 0
R1(config-router)#exit

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 20.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#exit

R2(config)#router eigrp 200
R2(config-router)#network 12.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#exit

R2(config)#router ospf 1
R2(config-router)#network 192.168.1.0 255.0.0.0 area 0
R2(config-router)#exit

R2(config)#router ospf 2
R2(config-router)#network 192.168.2.0 255.0.0.0 area 0
R2(config-router)#exit

R3(config)#router eigrp 300
R3(config-router)#network 30.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#exit

R3(config)#router rip.
 R3(config-router)#ver 2
R3(config-router)#network 13.0.0.0
R3(config-router)#network 13.0.1.0
R3(config-router)#network 13.0.2.0
R3(config-router)#network 13.0.3.0
R3(config-router)#no auto-summary
R3(config-router)#exit

R3(config)#router ospf 2
R3(config-router)#network 192.168.2.0 255.0.0.0 area 0
R3(config-router)#exit

R1(config)#router ospf 1
R1(config-router)#redistribute eigrp 100 subnet metric-type 1
R1(config-router)#redistribute rip  subnet metric-type 1
R1(config-router)#exit

R1(config)#router eigrp 100
R1(config-router)#redistribute rip metric 1000 2000 255 1 1500
R1(config-router)#redistribute ospf 1  metric 1000 2000 255 1 1500
R1(config-router)#exit

R1(config)#router rip
R1(config-router)#redistribute ospf 1  metric 4
R1(config-router)#exit

R2(config)#router eigrp 200
R2(config-router)#redistribute ospf 1 metric 1000 2000 255 1 1500
R2(config-router)#redistribute rip  metric 1000 2000 255 1 1500
R2(config-router)#exit

R2(config)#router rip
R2(config-router)#redistribute eigrp 200 metric 4
R2(config-router)#redistribute ospf 1  metric 4
R2(config-router)#exit

R2(config)#router ospf 1
R2(config-router)#redistribute eigrp 200 subnets metric-type 2
R2(config-router)#redistribute rip  subnets metric-type 2
R2(config-router)#redistribute ospf 2 subnets metric-type 2
R2(config-router)#exit

R2(config)#router ospf 2
R2(config-router)#redistribute ospf 1 subnet metric-type 2
R2(config-router)#redistribute rip  subnet metric-type 2
R2(config-router)#redistribute eigrp 200  subnet metric-type 2
R2(config-router)#exit



R3(config)#router eigrp 300
R3(config-router)#redistribute ospf 2 metric 1000 2000 255 1 1500
R3(config-router)#redistribute ospf 3 metric 1000 2000 255 1 1500
R3(config-router)#redistribute rip  metric 1000 2000 255 1 1500
R3(config-router)#exit

R3(config)#router ospf 2
R3(config-router)#redistribute eigrp 300 subnet metric-type 2
R3(config-router)#redistribute ospf 3  subnet metric-type 2
R3(config-router)#redistribute rip   subnet metric-type 2
R3(config-router)#exit

R3(config)#router rip
R3(config-router)#redistribute eigrp 300 metric 4
R3(config-router)#redistribute ospf 2  metric 4
R3(config-router)#redistribute ospf 3  metric 4
R3(config-router)#exit

R1#show ip route

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.1.1.0/24 is directly connected, FastEthernet0/0
L        10.1.1.1/32 is directly connected, FastEthernet0/0
      11.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C        11.0.0.0/24 is directly connected, Loopback0
L        11.0.0.1/32 is directly connected, Loopback0
C        11.0.1.0/24 is directly connected, Loopback1
L        11.0.1.1/32 is directly connected, Loopback1
C        11.0.2.0/24 is directly connected, Loopback2
L        11.0.2.1/32 is directly connected, Loopback2
C        11.0.3.0/24 is directly connected, Loopback3
L        11.0.3.1/32 is directly connected, Loopback3
      12.0.0.0/24 is subnetted, 4 subnets
O E2     12.0.0.0 [110/20] via 192.168.1.2, 00:53:23, Multilink1
O E2     12.0.1.0 [110/20] via 192.168.1.2, 00:53:23, Multilink1
O E2     12.0.2.0 [110/20] via 192.168.1.2, 00:53:23, Multilink1
O E2     12.0.3.0 [110/20] via 192.168.1.2, 00:53:23, Multilink1
      13.0.0.0/24 is subnetted, 4 subnets
O E2     13.0.0.0 [110/20] via 192.168.1.2, 00:44:04, Multilink1
O E2     13.0.1.0 [110/20] via 192.168.1.2, 00:44:04, Multilink1
O E2     13.0.2.0 [110/20] via 192.168.1.2, 00:44:04, Multilink1
O E2     13.0.3.0 [110/20] via 192.168.1.2, 00:44:04, Multilink1
      20.0.0.0/24 is subnetted, 1 subnets
O E2     20.1.1.0 [110/20] via 192.168.1.2, 00:53:13, Multilink1
      30.0.0.0/24 is subnetted, 1 subnets
O E2     30.1.1.0 [110/20] via 192.168.1.2, 00:47:40, Multilink1
      192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Multilink1
L        192.168.1.1/32 is directly connected, Multilink1
C        192.168.1.2/32 is directly connected, Multilink1
O     192.168.2.0/24 [110/32] via 192.168.1.2, 01:11:54, Multilink1


R2#show ip route

Gateway of last resort is not set

      10.0.0.0/24 is subnetted, 1 subnets
O E1     10.1.1.0 [110/36] via 192.168.1.1, 01:01:19, Multilink1
      11.0.0.0/24 is subnetted, 4 subnets
O E1     11.0.0.0 [110/36] via 192.168.1.1, 01:01:08, Multilink1
O E1     11.0.1.0 [110/36] via 192.168.1.1, 01:01:08, Multilink1
O E1     11.0.2.0 [110/36] via 192.168.1.1, 01:01:08, Multilink1
O E1     11.0.3.0 [110/36] via 192.168.1.1, 01:01:08, Multilink1
      12.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C        12.0.0.0/24 is directly connected, Loopback0
L        12.0.0.1/32 is directly connected, Loopback0
C        12.0.1.0/24 is directly connected, Loopback1
L        12.0.1.1/32 is directly connected, Loopback1
C        12.0.2.0/24 is directly connected, Loopback2
L        12.0.2.1/32 is directly connected, Loopback2
C        12.0.3.0/24 is directly connected, Loopback3
L        12.0.3.1/32 is directly connected, Loopback3
      13.0.0.0/24 is subnetted, 4 subnets
O E2     13.0.0.0 [110/20] via 192.168.2.2, 00:44:29, Multilink2
O E2     13.0.1.0 [110/20] via 192.168.2.2, 00:44:29, Multilink2
O E2     13.0.2.0 [110/20] via 192.168.2.2, 00:44:29, Multilink2
O E2     13.0.3.0 [110/20] via 192.168.2.2, 00:44:29, Multilink2
      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        20.1.1.0/24 is directly connected, FastEthernet0/0
L        20.1.1.1/32 is directly connected, FastEthernet0/0
      30.0.0.0/24 is subnetted, 1 subnets
O E2     30.1.1.0 [110/20] via 192.168.2.2, 00:48:05, Multilink2
      192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Multilink1
C        192.168.1.1/32 is directly connected, Multilink1
L        192.168.1.2/32 is directly connected, Multilink1
      192.168.2.0/24 is variably subnetted, 3 subnets, 2 masks
C        192.168.2.0/24 is directly connected, Multilink2
L        192.168.2.1/32 is directly connected, Multilink2
C        192.168.2.2/32 is directly connected, Multilink2

R3#show ip route
Gateway of last resort is not set

      10.0.0.0/24 is subnetted, 1 subnets
O E1     10.1.1.0 [110/52] via 192.168.2.1, 01:01:39, Multilink2
      11.0.0.0/24 is subnetted, 4 subnets
O E1     11.0.0.0 [110/52] via 192.168.2.1, 01:01:27, Multilink2
O E1     11.0.1.0 [110/52] via 192.168.2.1, 01:01:27, Multilink2
O E1     11.0.2.0 [110/52] via 192.168.2.1, 01:01:27, Multilink2
O E1     11.0.3.0 [110/52] via 192.168.2.1, 01:01:27, Multilink2
      12.0.0.0/24 is subnetted, 4 subnets
O E2     12.0.0.0 [110/20] via 192.168.2.1, 00:54:07, Multilink2
O E2     12.0.1.0 [110/20] via 192.168.2.1, 00:54:07, Multilink2
O E2     12.0.2.0 [110/20] via 192.168.2.1, 00:54:07, Multilink2
O E2     12.0.3.0 [110/20] via 192.168.2.1, 00:54:07, Multilink2
      13.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C        13.0.0.0/24 is directly connected, Loopback0
L        13.0.0.1/32 is directly connected, Loopback0
C        13.0.1.0/24 is directly connected, Loopback1
L        13.0.1.1/32 is directly connected, Loopback1
C        13.0.2.0/24 is directly connected, Loopback2
L        13.0.2.1/32 is directly connected, Loopback2
C        13.0.3.0/24 is directly connected, Loopback3
L        13.0.3.1/32 is directly connected, Loopback3
      20.0.0.0/24 is subnetted, 1 subnets
O E2     20.1.1.0 [110/20] via 192.168.2.1, 00:53:58, Multilink2
      30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        30.1.1.0/24 is directly connected, FastEthernet0/0
L        30.1.1.1/32 is directly connected, FastEthernet0/0
O     192.168.1.0/24 [110/32] via 192.168.2.1, 01:07:21, Multilink2
      192.168.2.0/24 is variably subnetted, 3 subnets, 2 masks
C        192.168.2.0/24 is directly connected, Multilink2
C        192.168.2.1/32 is directly connected, Multilink2
L        192.168.2.2/32 is directly connected, Multilink2

R1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 22 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip, eigrp 100, ospf 1 (internal, external 1 & 2, nssa-external 1 & 2)

  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Loopback0             2     2
    Loopback1             2     2
    Loopback2             2     2
    Loopback3             2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    11.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 120)

Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  Redistributing: rip, ospf 1
  EIGRP-IPv4 Protocol for AS(100)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 11.0.3.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: internal 90 external 170

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 11.0.3.1
  It is an autonomous system boundary router
 Redistributing External Routes from,
    rip, includes subnets in redistribution
    eigrp 100, includes subnets in redistribution
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    192.0.0.0 0.255.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    12.0.3.1             110      00:54:32
    13.0.3.1             110      00:45:22
  Distance: (default is 110)


R2#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 19 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip, eigrp 200, ospf 1 (internal, external 1 & 2, nssa-external 1 & 2)

  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    20.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 120)

Routing Protocol is "eigrp 200"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  Redistributing: rip, ospf 1
  EIGRP-IPv4 Protocol for AS(200)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 12.0.3.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    12.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: internal 90 external 170

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 12.0.3.1
  It is an autonomous system boundary router
 Redistributing External Routes from,
    rip, includes subnets in redistribution
    eigrp 200, includes subnets in redistribution
    ospf 2, includes subnets in redistribution
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    192.0.0.0 0.255.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    11.0.3.1             110      01:02:23
    13.0.3.1             110      00:45:44
  Distance: (default is 110)

Routing Protocol is "ospf 2"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 12.0.2.1
  It is an autonomous system boundary router
 Redistributing External Routes from,
    rip, includes subnets in redistribution
    eigrp 200, includes subnets in redistribution
    ospf 1, includes subnets in redistribution
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    192.0.0.0 0.255.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 110)

Routing Protocol is "eigrp 100"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  Redistributing: rip, ospf 1
  EIGRP-IPv4 Protocol for AS(100)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 12.0.3.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: internal 90 external 170




R3#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "eigrp 300"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  Redistributing: rip, ospf 2, ospf 3
  EIGRP-IPv4 Protocol for AS(300)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 13.0.3.1
    Topology : 0 (base)
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    30.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: internal 90 external 170

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 23 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: eigrp 300, rip, ospf 2 (internal, external 1 & 2, nssa-external 1 & 2)

  Redistributing: ospf 3 (internal, external 1 & 2, nssa-external 1 & 2)

  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Loopback0             2     2
    Loopback1             2     2
    Loopback2             2     2
    Loopback3             2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    13.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 120)

Routing Protocol is "ospf 2"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 13.0.3.1
  It is an autonomous system boundary router
 Redistributing External Routes from,
    eigrp 300, includes subnets in redistribution
    rip, includes subnets in redistribution
    ospf 3, includes subnets in redistribution
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    192.0.0.0 0.255.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    11.0.3.1             110      01:02:42
    12.0.3.1             110      00:55:13
  Distance: (default is 110)














No comments:

Post a Comment

Cisco’s IOS

Cisco’s IOS The Cisco inter network operating system (IOS) is the kernel of Cisco routers as well as all current catalyst switches. A ke...

INSTAGRAM FEED

@Edger C Francis