DONATE


How to configure Static DMVPN or Static Mapping?

 

Dynamic Multipoint Virtual Networks (DMVPN)

DMVPN is a Hub-and-Spoke topology and the main tool to create VPNs is combination of mGRE. The registration process can be conducted via Static or Dynamic. click here for all the theories about DMVPN and MPLS.



1. Introduction of MPLS

2.What is MPLS Label distributing protocol (LDP) ? How LDP works?

3.how to configure MPLS LDP Peering ?

4.What is MPLS L3 VPN ? How to configure?

5.How to configure MPLS L3 VPN with RIPv2 ?

6.How to configure MPLS L3 VPN with EIGRP ?

7.How to configure MPLS L3 VPN with OSPF ?

8.What is OSPF Sham Links? how to configure OSPF Sham Links?




 In this section we are going to configure Static DMVPN or Static Mapping.






R1(config)#interface fastEthernet 0/0

R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit


R1(config)#interface loopback 0

R1(config-if)#ip address 1.1.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit


R2(config)#interface fastEthernet 2/0
R2(config-if)#ip address 192.168.2.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface loopback 0
R2(config-if)#ip address 2.2.2.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R3(config)#interface fastEthernet 2/1

R3(config-if)#ip address 192.168.3.3 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#exit


R3(config)#interface loopback 0
R3(config-if)#ip address 3.3.3.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit


R4(config)#interface gigabitEthernet 3/0
R4(config-if)#ip address 192.168.4.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit


R4(config)#interface loopback 0
R4(config-if)#ip address 4.4.4.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#end

R5(config)#interface fastEthernet 0/0
R5(config-if)#ip address 192.168.1.5 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit

R5(config)#interface fastEthernet 2/0
R5(config-if)#ip address 192.168.2.5 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit

R5(config)#interface fastEthernet 2/1
R5(config-if)#ip address 192.168.3.5 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit

R5(config)#interface gigabitEthernet 3/0
R5(config-if)#ip address 192.168.4.5 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit

R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.5
R1(config)#end

R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.5
R2(config)#end

R3(config)#ip route 0.0.0.0 0.0.0.0 192.168.3.5
R3(config)#end

R4(config)# ip route 0.0.0.0 0.0.0.0 192.168.4.5
R4(config)#end


R5(config)#ip route 192.168.1.0 255.255.255.0 192.168.1.1
R5(config)#ip route 1.1.1.0 255.255.255.0 192.168.1.1
R5(config)#ip route 192.168.2.0 255.255.255.0 192.168.2.2
R5(config)#ip route 2.2.2.0 255.255.255.0 192.168.2.2
R5(config)#ip route 192.168.3.0 255.255.255.0 192.168.3.3
R5(config)#ip route 3.3.3.0 255.255.255.0 192.168.3.3
R5(config)#ip route 192.168.4.0 255.255.255.0 192.168.4.4
R5(config)#ip route 4.4.4.0 255.255.255.0 192.168.4.4
R5(config)#exit

R1(config)#interface tunnel 1
R1(config-if)#ip address 100.1.1.1 255.255.255.0
R1(config-if)#tunnel source 192.168.1.1
R1(config-if)#tunnel mode gre multipoint
R1(config-if)#ip nhrp network-id 123
R1(config-if)#ip nhrp map 100.1.1.2 192.168.2.2
R1(config-if)#ip nhrp map 100.1.1.3 192.168.3.3
R1(config-if)#ip nhrp map 100.1.1.4 192.168.4.4
R1(config-if)#end

R2(config)#interface tunnel 1
R2(config-if)#ip address 100.1.1.2 255.255.255.0
R2(config-if)#tunnel source 192.168.2.2
R2(config-if)#tunnel destination 192.168.1.1
R2(config-if)#ip nhrp network-id 231
R2(config-if)#ip nhrp map 100.1.1.1 192.168.1.1
R2(config-if)#end

R3(config)#interface tunnel 1
R3(config-if)#ip address 100.1.1.3 255.255.255.0
R3(config-if)#tunnel source 192.168.3.3
R3(config-if)#tunnel destination 192.168.1.1
R3(config-if)#ip nhrp network-id 321
R3(config-if)#ip nhrp map 100.1.1.1 192.168.1.1
R3(config-if)#END


R4(config)#interface tunnel 1

R4(config-if)#ip address 100.1.1.4 255.255.255.0

R4(config-if)#tunnel source 192.168.4.4

R4(config-if)#tunnel destination 192.168.1.1

R4(config-if)#ip nhrp network-id 432

R4(config-if)#ip nhrp map 100.1.1.1 192.168.1.1

R4(config-if)#end

R1#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/69/132 ms


R1#traceroute 2.2.2.2
Type escape sequence to abort.
Tracing the route to 2.2.2.2
VRF info: (vrf in name/id, vrf out name/id)
  1 192.168.1.5 8 msec 52 msec 48 msec
  2 192.168.2.2 44 msec 48 msec 44 msec


R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/57/76 ms


R1#traceroute 3.3.3.3
Type escape sequence to abort.
Tracing the route to 3.3.3.3
VRF info: (vrf in name/id, vrf out name/id)
  1 192.168.1.5 52 msec 48 msec 48 msec
  2 192.168.3.3 44 msec 52 msec 48 msec



R1#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/54/72 ms



R1#traceroute 4.4.4.4
Type escape sequence to abort.
Tracing the route to 4.4.4.4
VRF info: (vrf in name/id, vrf out name/id)
  1 192.168.1.5 48 msec 44 msec 52 msec
  2 192.168.4.4 48 msec 48 msec 48 msec

R2#ping 1.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 44/53/72 ms



R2#traceroute 1.1.1.1

Type escape sequence to abort.

Tracing the route to 1.1.1.1

VRF info: (vrf in name/id, vrf out name/id)

  1 192.168.2.5 48 msec 48 msec 48 msec

  2 192.168.1.1 48 msec 48 msec 52 msec



R2#ping 3.3.3.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/46/52 ms




R2#traceroute 3.3.3.3

Type escape sequence to abort.

Tracing the route to 3.3.3.3

VRF info: (vrf in name/id, vrf out name/id)

  1 192.168.2.5 52 msec 104 msec 52 msec

  2 192.168.3.3 56 msec 52 msec 48 msec



R2#ping 4.4.4.4

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 48/59/92 ms




R2#traceroute 4.4.4.4

Type escape sequence to abort.

Tracing the route to 4.4.4.4

VRF info: (vrf in name/id, vrf out name/id)

  1 192.168.2.5 68 msec 76 msec 68 msec

  2 192.168.4.4 72 msec 72 msec 80 msec



( FROM ROUTER 1) :-






(FROM ROUTER 2 :-





(FROM ROUTER 3 :-





( FROM ROUTER 4):-




Thank you so much for visiting




1 comment:

How to configure DHCP Snooping on switch, DHCP Server on router, SVI Inter-VLAN-routing, BPDU Guard, Root-Guard, Port-fast, Dot1q and Port-channel pagp?

In this section, we are going to configure some important topics DHCP Snooping on the switch, DHCP Server on the router, SVI Inter-VLAN-rout...

INSTAGRAM FEED

@Edger C Francis