When we have many neighbors that have similar configuration parameters.
Cisco IOS allows us to create a logical group of those similar neighbors into a BGP peer group then you apply your non-default BGP configuration to those parameters to each neighbor individually.
Actually, a single router can have multiple peer groups, each representing a separate set of parameters. The result is less CPU resources required. Remember router still sends out individual BGP updates to each of its neighbors. It does require based on BGP characteristics establishing a TCP session with each neighbor.
let's see the configuration of BGP Peer group: -
Topology;
Task-
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)# interface fastethernet 0/0
R1(config-if)# ip address 10.1.1.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#no keepalive
R1(config-if)#exit
R1(config)#interface loopback 0
R1(config-if)# ip address 11.0.0.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#interface loopback 1
R1(config-if)# ip address 11.0.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#interface loopback 2
R1(config-if)# ip address 11.0.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#interface loopback 3
R1(config-if)# ip address 11.0.3.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#interface serial 3/0
R1(config-if)# ip address 1.1.1.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)# ip address 3.3.3.2 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
*Nov 22 23:38:40.923: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
*Nov 22 23:38:41.371: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
*Nov 22 23:38:41.687: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up
*Nov 22 23:38:42.015: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback3, changed state to up interface serial 3/3
*Nov 22 23:38:42.651: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Nov 22 23:38:43.651: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0,
*Nov 22 23:38:44.771: %LINK-3-UPDOWN: Interface Serial3/0, changed state to up
*Nov 22 23:38:45.183: %LINK-3-UPDOWN: Interface Serial3/3, changed state to up
*Nov 22 23:38:45.779: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up
*Nov 22 23:38:46.183: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/3, changed state to up
*Nov 22 23:39:08.931: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed
*Nov 22 23:39:08.999: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/3, changed state to down
*Nov 22 23:39:18.927: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up
*Nov 22 23:40:08.931: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/3, changed state to up
R1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.1.1.1 YES manual up up
Serial3/0 1.1.1.1 YES manual up up
Serial3/3 3.3.3.2 YES manual up up
Loopback0 11.0.0.1 YES manual up up
Loopback1 11.0.1.1 YES manual up up
Loopback2 11.0.2.1 YES manual up up
Loopback3 11.0.3.1 YES manual up up
From Router 2
From Router 3
R1(config)#router bgp 110
R1(config-router)#neighbor cisco peer-group
R1(config-router)#neighbor cisco remote-as 110
R1(config-router)#neighbor cisco update-source loopback 0
R1(config-router)#neighbor cisco version 4
R1(config-router)#neighbor cisco password internetworks
R1(config-router)#neighbor 12.0.0.1 peer-group cisco
R1(config-router)#neighbor 13.0.0.1 peer-group cisco
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#no synchronization
R1(config-router)#end
*Nov 23 02:14:37.243: %BGP-5-ADJCHANGE: neighbor 12.0.0.1 Up
R2(config)#router bgp 110
R2(config-router)#neighbor cisco peer-group
R2(config-router)#neighbor cisco remote-as 110
R2(config-router)#neighbor cisco update-source loopback 0
R2(config-router)#neighbor cisco version 4
R2(config-router)#neighbor cisco password internetworks
R2(config-router)#neighbor 11.0.0.1 peer-group cisco
R2(config-router)#neighbor 13.0.0.1 peer-group cisco
R2(config-router)#network 20.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#no synchronization
R2(config-router)#end
*Nov 23 02:14:37.263: %BGP-5-ADJCHANGE: neighbor 11.0.0.1 Up
R3(config)#router bgp 110
R3(config-router)#neighbor cisco peer-group
R3(config-router)#neighbor cisco remote-as 110
R3(config-router)#neighbor cisco update-source loopback 0
R3(config-router)#neighbor cisco version 4
R3(config-router)#neighbor cisco password internetworks
R3(config-router)#neighbor 11.0.0.1 peer-group cisco
R3(config-router)#neighbor 12.0.0.1 peer-group cisco
R3(config-router)#network 30.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#no synchronization
R3(config-router)#end
*Nov 23 02:15:14.979: %BGP-5-ADJCHANGE: neighbor 12.0.0.1 Up
*Nov 23 02:15:17.223: %BGP-5-ADJCHANGE: neighbor 11.0.0.1 Up
From Router 1
From Router 2
From Router 3
Cisco IOS allows us to create a logical group of those similar neighbors into a BGP peer group then you apply your non-default BGP configuration to those parameters to each neighbor individually.
Actually, a single router can have multiple peer groups, each representing a separate set of parameters. The result is less CPU resources required. Remember router still sends out individual BGP updates to each of its neighbors. It does require based on BGP characteristics establishing a TCP session with each neighbor.
let's see the configuration of BGP Peer group: -
Topology;
Task-
- configure the topology as per the diagram and assign the IP addresses respectively to their interfaces.
- configure IGP EIGRP 100 and advertise interfaces
- configure BGP 110
- configure BGP Peer_group.
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)# interface fastethernet 0/0
R1(config-if)# ip address 10.1.1.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#no keepalive
R1(config-if)#exit
R1(config)#interface loopback 0
R1(config-if)# ip address 11.0.0.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#interface loopback 1
R1(config-if)# ip address 11.0.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#interface loopback 2
R1(config-if)# ip address 11.0.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#interface loopback 3
R1(config-if)# ip address 11.0.3.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#interface serial 3/0
R1(config-if)# ip address 1.1.1.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)# ip address 3.3.3.2 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
*Nov 22 23:38:40.923: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
*Nov 22 23:38:41.371: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
*Nov 22 23:38:41.687: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up
*Nov 22 23:38:42.015: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback3, changed state to up interface serial 3/3
*Nov 22 23:38:42.651: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Nov 22 23:38:43.651: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0,
*Nov 22 23:38:44.771: %LINK-3-UPDOWN: Interface Serial3/0, changed state to up
*Nov 22 23:38:45.183: %LINK-3-UPDOWN: Interface Serial3/3, changed state to up
*Nov 22 23:38:45.779: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up
*Nov 22 23:38:46.183: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/3, changed state to up
*Nov 22 23:39:08.931: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed
*Nov 22 23:39:08.999: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/3, changed state to down
*Nov 22 23:39:18.927: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up
*Nov 22 23:40:08.931: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/3, changed state to up
R2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)# interface fastethernet 0/0
R2(config-if)# ip address 20.1.1.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#no keepalive
R2(config-if)#exit
R2(config)#interface loopback 0
R2(config-if)# ip address 12.0.0.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#interface loopback 1
R2(config-if)# ip address 12.0.1.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#interface loopback 2
R2(config-if)# ip address 12.0.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#interface loopback 3
R2(config-if)# ip address 12.0.3.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#interface serial 3/0
R2(config-if)# ip address 1.1.1.2 255.0.0.0
R2(config-if)#no shutdown
R2(config)# interface serial 3/1
R2(config-if)# ip address 2.2.2.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
*Nov 22 23:39:14.959: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
*Nov 22 23:39:15.387: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
*Nov 22 23:39:15.663: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up
*Nov 22 23:39:15.935: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback3, changed state to up
*Nov 22 23:39:16.615: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Nov 22 23:39:17.615: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
*Nov 22 23:39:18.535: %LINK-3-UPDOWN: Interface Serial3/0, changed state to up
*Nov 22 23:39:18.879: %LINK-3-UPDOWN: Interface Serial3/1, changed state to up
*Nov 22 23:39:19.543: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up
*Nov 22 23:39:19.887: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/1, changed state to up
*Nov 22 23:39:48.947: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/1, changed state to down
*Nov 22 23:39:58.951: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/1, changed state to up
R3#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)# interface fastethernet 0/0
R3(config-if)# ip address 30.1.1.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#no keepalive
R3(config-if)#exit
R3(config)#interface loopback 0
R3(config-if)# ip address 13.0.0.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#interface loopback 1
R3(config-if)# ip address 13.0.1.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#interface loopback 2
R3(config-if)# ip address 13.0.2.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#interface loopback 3
R3(config-if)# ip address 13.0.3.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#interface serial 3/1
R3(config-if)# ip address 2.2.2.2 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config-if)# interface serial 3/3
R3(config-if)# ip address 3.3.3.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit
*Nov 22 23:39:42.227: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
*Nov 22 23:39:42.643: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
*Nov 22 23:39:42.983: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up
*Nov 22 23:39:43.263: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback3, changed state to up
*Nov 22 23:39:43.951: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Nov 22 23:39:44.951: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
*Nov 22 23:39:45.883: %LINK-3-UPDOWN: Interface Serial3/1, changed state to up
*Nov 22 23:39:46.891: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/1, changed state to up
*Nov 22 23:39:50.807: %LINK-3-UPDOWN: Interface Serial3/3, changed state to up
R3(config-if)#exit
R3(config)#
*Nov 22 23:39:51.815: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/3, changed state to up
R1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.1.1.1 YES manual up up
Serial3/0 1.1.1.1 YES manual up up
Serial3/3 3.3.3.2 YES manual up up
Loopback0 11.0.0.1 YES manual up up
Loopback1 11.0.1.1 YES manual up up
Loopback2 11.0.2.1 YES manual up up
Loopback3 11.0.3.1 YES manual up up
R2#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 20.1.1.1 YES manual up up
Serial3/0 1.1.1.2 YES manual up up
Serial3/1 2.2.2.1 YES manual up up
Loopback0 12.0.0.1 YES manual up up
Loopback1 12.0.1.1 YES manual up up
Loopback2 12.0.2.1 YES manual up up
Loopback3 12.0.3.1 YES manual up up
R3#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 30.1.1.1 YES manual up up
Serial3/1 2.2.2.2 YES manual up up
Serial3/3 3.3.3.1 YES manual up up
Loopback0 13.0.0.1 YES manual up up
Loopback1 13.0.1.1 YES manual up up
Loopback2 13.0.2.1 YES manual up up
Loopback3 13.0.3.1 YES manual up up
R1(config)#router eigrp 100
R1(config-router)#network 10.0.0.0
R1(config-router)#network 1.0.0.0
R1(config-router)#network 3.0.0.0
R1(config-router)#network 11.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#end
*Nov 22 23:57:26.463: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 1.1.1.2 (Serial3/0) is up: new adjacency
*Nov 22 23:57:59.715: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 3.3.3.1 (Serial3/3) is up: new adjacency
R2(config)#router eigrp 100
R2(config-router)#network 20.0.0.0
R2(config-router)#network 1.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#network 12.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#end
*Nov 22 23:57:26.587: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 1.1.1.1 (Serial3/0) is up: new adjacency
*Nov 22 23:57:59.795: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 2.2.2.2 (Serial3/1) is up: new adjacency
R3(config)#router eigrp 100
R3(config-router)#network 30.0.0.0
R3(config-router)#network 3.0.0.0
R3(config-router)#network 2.0.0.0
R3(config-router)#network 13.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#end
*Nov 22 23:57:59.775: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 2.2.2.1 (Serial3/1) is up: new adjacency
*Nov 22 23:57:59.779: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 3.3.3.2 (Serial3/3) is up: new adjacency
From Router 1
From Router 2
From Router 2 |
From Router 3
From Router 3 |
R1(config)#router bgp 110
R1(config-router)#neighbor cisco peer-group
R1(config-router)#neighbor cisco remote-as 110
R1(config-router)#neighbor cisco update-source loopback 0
R1(config-router)#neighbor cisco version 4
R1(config-router)#neighbor cisco password internetworks
R1(config-router)#neighbor 12.0.0.1 peer-group cisco
R1(config-router)#neighbor 13.0.0.1 peer-group cisco
R1(config-router)#network 10.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#no synchronization
R1(config-router)#end
*Nov 23 02:15:17.163: %BGP-5-ADJCHANGE: neighbor 13.0.0.1 Up
R2(config)#router bgp 110
R2(config-router)#neighbor cisco peer-group
R2(config-router)#neighbor cisco remote-as 110
R2(config-router)#neighbor cisco update-source loopback 0
R2(config-router)#neighbor cisco version 4
R2(config-router)#neighbor cisco password internetworks
R2(config-router)#neighbor 11.0.0.1 peer-group cisco
R2(config-router)#neighbor 13.0.0.1 peer-group cisco
R2(config-router)#network 20.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#no synchronization
R2(config-router)#end
*Nov 23 02:14:37.263: %BGP-5-ADJCHANGE: neighbor 11.0.0.1 Up
*Nov 23 02:15:14.927: %BGP-5-ADJCHANGE: neighbor 13.0.0.1 Up
R3(config-router)#neighbor cisco peer-group
R3(config-router)#neighbor cisco remote-as 110
R3(config-router)#neighbor cisco update-source loopback 0
R3(config-router)#neighbor cisco version 4
R3(config-router)#neighbor cisco password internetworks
R3(config-router)#neighbor 11.0.0.1 peer-group cisco
R3(config-router)#neighbor 12.0.0.1 peer-group cisco
R3(config-router)#network 30.0.0.0
R3(config-router)#no auto-summary
R3(config-router)#no synchronization
R3(config-router)#end
*Nov 23 02:15:17.223: %BGP-5-ADJCHANGE: neighbor 11.0.0.1 Up
From Router 1
From Router 1 |
From Router 2
From Router 2 |
From Router 3
From Router 3 |
Grand Victoria Casino & Resort - Mapyro
ReplyDeleteView the location and contact information for Grand 충주 출장안마 Victoria 경상남도 출장샵 Casino & 전주 출장마사지 Resort, including 계룡 출장샵 address, telephone number, map, map, Grand Victoria Casino & Resort. 세종특별자치 출장샵